Showing results for 
Search instead for 
Did you mean: 

C3KX-SM-10G on 3750X - version info and upgrade instructions

Level 2
Level 2

I have a version mismatch between my 3750X code running 150-2-SE and the C3KX-SM-10G service module.

show switch service-modules shows that the switch needs the service module at 03.00.65. How do I correlate that version with the version of the c3kx-sm10g-tar file posted on CCO?

Is there a documentation link to how you upgrade and reload only the service module and not the switch stack?

9 Replies 9

Reza Sharifi
Hall of Fame
Hall of Fame

The module doesn't have its own code.  As long as you load the IOS that support the 10Gig module, you should be fine.  IOS 15 does support that module.  You can't upgrade or reboot just the module.  When you reboot the whole switch reboots.


Reza, thanks for the response, but the module ABSOLUTELY runs it's own code. You'll find it on CCO under the 3750X versions. You may be confusing the C3KX-NM-10G with the C3KX-SM-10G.

Thru a process of elimination, I determined that firmware c3kx-sm10g-tar.150-2.SE1.tar is 03.00.65. This is after I did a firmware upgrade specifically for that service module. Before the upgrade, it was 03.00.41.

C3750X-DC-P10#sh switch service-modules

Switch/Stack supports service module CPU version: 03.00.65

                          Temperature                     CPU

Switch#  H/W Status       (CPU/FPGA)      CPU Link      Version


2       OK               75C/73C         connected     03.00.65

I still would like know how the C3KX-SM firmware filenames match to the CPU version.

I also found out how to reload the SM independently of the switch:

switch fru-link reload


You are correct.  I apologize.  As you said, I confused the C3KX-NM-10G with the C3KX-SM-10G. 

This module does Netflow and MACsec.

Good info (+5)



Thank you Ninad; I also was getting a "ver-mismatch" and your link led me to the answer.

Anybody else having this issue, it's a simple fix:


From the CLI:

archive download-sw /overwrite tftp://tftp-server-ip/c3kx-sm10g-tar.150-2.SE.tar

(Of course you must have the .tar file setup in your working tftp server first)


If you've previously tried to do this from the web interface (or CNA) as I had, you may get this message when you run the above command:

Unable to create temp dir "flash:update"

The directory already exists, please make sure another upgrade is not in progress.

If not, either delete or rename this directory and restart the upgrade.

If so, run the following command to delete that folder:

delete /force /recursive update

Then run the archive command again.


If you are still looking for a documentation on this, please refer to the link below,




I'm doning the same upgrade on the SM.

I tried the archive download-sw command on the 3750X itself but after the image is downloaded I get the error

"ERROR: Image is not a valid IOS image archive.".

Should I run this command on the module? If yes how can I connect to it?

The switch is running IOS 15.0(2)SE2.


I'm having this same error. Anyone have the update sequence for this SM module?

Not applicable

Hi Kbyrd

I am basically trying to upgrade Cat 3750X device with C3KX-NM-10G service module. 

Do I need to have a separate upgrade procedure for the above-mentioned Module?

hello gane, hope you can work through the problem. this was about 2 years ago for me and my memory is a bit foggy. I think I had to obtain the special firmware for the module itself. also, keep in mind that the NM version of module does some advance network monitoring (netflow) and needs to be paired with the correct switch OS. so you may get an error if your switch license level doesn't support the NM monitoring. also, I vaguely remember the upgrade taking a really long time for programming phase - like 10-15 minutes before the reload.

Review Cisco Networking for a $25 gift card