cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
335
Views
0
Helpful
1
Replies
Highlighted
Beginner

Can a switch has more than one trunk port configured?

What happen if I configure two trunk port on a switch?

My network is like this:

I am connecting a POE switch to ASA 5505.

I am connecting an IP phone to the switch, behind the phone is computer.

I would like to assign subnet 192.168.1.x/24 to the phone, and 192.168.2.x/24 to computer.

Because 5505 does not support sub interface. I have to configure two physical interface as the gateway for the two subnets. Let's say E0/1 and E0/2. E0/1 belongs to vlan 10, E0/2 belongs to vlan 1074.

interface Ethernet0/1

switchport access vlan 10

!

interface Ethernet0/2

switchport access vlan 1074

!

interface Vlan10

nameif PHONE

security-level 100

ip address 192.168.1.1 255.255.255.0

interface Vlan1074

nameif Office

security-level 100

ip address 192.168.2.1 255.255.255.0

The switch Port#1 connected to the phone. configuration as below

switchport access vlan 1074

switchport voice vlan 10

switchport port-security

switchport port-security maximum 2

no cdp enable

spanning-tree portfast

Switch Port#23 & #24 both configured as trunk port, and connected to ASA 5505 E0/1 and E0/2.

I tested it but it didn't work. Can any one point out what's wrong with my thought?  Thanks a lot!!!

1 REPLY 1
Highlighted
Beginner

Hi,

If you have your ASA setup with access ports it is expecting untagged frames to be received from the switch.

If your switch is setup with trunk ports, it will be tagging the frames it sends to the ASA.

To resolve the problem, configure the switch ports connected to the ASA as access ports in the relevent VLANs (i.e. switch port 23 in VLAN 10 and switch port 24 in VLAN 1074).

Then all the traffic will be untagged and the ASA will accept the frames from the switch.

Good luck!

Content for Community-Ad