Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

Can not upgrade Cisco 2960G Switch

I have a few 24-port Cisco 2960G Switches (model WS-C2960G-24TC-L) that I upgraded to IOS Release 15.0(1)SE2 using the web interface. I am now trying to upgrade those switches with the new release, 15.0(1)SE3, however I seem unable to do it, I have tried this on two switches so far, both have been upgraded to SE2 just a couple months ago or so, and both of them will not accept the SE3 upgrade, basically, I can select the tar file in the web browser and click "Upgrade"  but when I do the status never changes from "Loading the tar file to the switch". I have tried multiple times from multiple computers using many different web browsers, including IE6 which is listed as supported. I have let it go for as long as 1.5 hours but to no avail.

I also had a few idential switches here that had never been upgarded to SE2, I have had no problems loading SE3 onto them using the same method so it would seem that the tar file I have downloaded is valid.

Does anyoneone have any idea why this might be happening?

Thanks in advance.


Accepted Solutions
Reza Sharifi
Hall of Fame Expert

Have you tried using the cli?


View solution in original post

Reza Sharifi
Hall of Fame Expert

Have you tried using the cli?


View solution in original post

I have not tried that yet, since I was able to upgrade the switches using the web interface before it seems like I should be able to again. I will look into trying it with the cli however, thanks for the suggestion.

You can try using cli that would be a better option and easily we can troubleshoot.... but anyways have u checked the memory space availability....???

Well it looks as though using the CLI did allow me to upgrade the switch.

Thank you for your help.

Glad to help and thanks for the rating

I know cli for sure works, but not sure about the Web interface. I never use the Web interface.

Good Luck