11-10-2022 03:16 AM
So I'm have an issue in CML that's super basic. I'm either overlooking something extremely trivial or have lost my mind. I have switch-01 and switch-02. G0/1 on 01 is connected to g/01 on 02. Bot ports are access ports with VLAN 100 assigned to the port. VLAN 100 is on both switches with 01 having an IP of 192.168.0.2/24 and 02 having an IP of 192.168.0.3/24. The switches can't ping the SVI and they should be able to. Do they need a static route in place?
Switch-01
---------------
Current configuration : 2864 bytes
!
! Last configuration change at 10:59:43 UTC Thu Nov 10 2022
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname switch-01
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
no ip domain-lookup
ip cef
no ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
negotiation auto
!
interface GigabitEthernet0/1
switchport access vlan 100
switchport mode access
negotiation auto
!
interface GigabitEthernet0/2
negotiation auto
!
interface GigabitEthernet0/3
negotiation auto
!
interface Vlan100
ip address 192.168.0.2 255.255.255.0
standby version 2
standby 1 ip 192.168.0.1
standby 1 priority 105
standby 1 preempt
!
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
!
!
!
!
!
control-plane
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
switch-01#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/0, Gi0/2, Gi0/3
100 sp active Gi0/1
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
switch-01#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is not set
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, Vlan100
L 192.168.0.2/32 is directly connected, Vlan100
Switch-02
----------------------------
Current configuration : 2840 bytes
!
! Last configuration change at 11:13:56 UTC Thu Nov 10 2022
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname switch-02
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
no ip domain-lookup
ip cef
no ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
negotiation auto
!
interface GigabitEthernet0/1
switchport access vlan 100
switchport mode access
negotiation auto
!
interface GigabitEthernet0/2
negotiation auto
!
interface GigabitEthernet0/3
negotiation auto
!
interface Vlan100
ip address 192.168.0.3 255.255.255.0
standby version 2
standby 1 ip 192.168.0.1
standby 1 preempt
!
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
!
!
!
!
!
control-plane
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
switch-02#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/0, Gi0/2, Gi0/3
100 sp active Gi0/1
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
switch-02#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is not set
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, Vlan100
L 192.168.0.3/32 is directly connected, Vlan100
11-10-2022 04:00 AM - edited 11-10-2022 04:02 AM
before i coment anything i would like to have below outpout : (from bot the device)
show version (what image you have)
show ip arp
show spanning brief
11-10-2022 04:11 AM - edited 11-10-2022 04:12 AM
Just to add, I stuck an alpine linux desktop on g0/2 on switch-02. It has an ip of 192.168.0.10/24. G0/2 on switch-02 is an access port and configured just like g0/1 with switchport mode access and switchport access vlan 100. The alpine linux instance can ping the SVI on switch-02, but not the SVI on switch-01 and the SVI on switch-01 can't ping the linux instance connected to g0/2 on switch-02. The IP for the alpine linux instance does show up in the arp table on switch-01 though. Show spanning-tree shows int g0/1 as forwarding on both switches.
Switch-01
------------------
switch-01#sh ver
Cisco IOS Software, vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Experimental Version 15.2(20200924:215240) [sweickge-sep24-2020-l2iol-release 135]
Copyright (c) 1986-2020 by Cisco Systems, Inc.
Compiled Tue 29-Sep-20 11:53 by sweickge
ROM: Bootstrap program is IOSv
switch-01 uptime is 1 hour, 11 minutes
System returned to ROM by reload
System image file is "flash0:/vios_l2-adventerprisek9-m"
Last reload reason: Unknown reason
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
export@cisco.com.
Cisco IOSv () processor (revision 1.0) with 722145K/62464K bytes of memory.
Processor board ID 90ODMOEX0BE
1 Virtual Ethernet interface
5 Gigabit Ethernet interfaces
DRAM configuration is 72 bits wide with parity disabled.
256K bytes of non-volatile configuration memory.
0K bytes of ATA System CompactFlash 0 (Read/Write)
0K bytes of ATA CompactFlash 1 (Read/Write)
11217K bytes of ATA CompactFlash 2 (Read/Write)
0K bytes of ATA CompactFlash 3 (Read/Write)
Configuration register is 0x101
switch-01#sh ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.0.1 - 0000.0c9f.f001 ARPA Vlan100
Internet 192.168.0.2 - 5254.0002.8064 ARPA Vlan100
Internet 192.168.0.10 0 5254.0013.d1f3 ARPA Vlan100
switch-01#sh spanning br
Hello Max Fwd
Vlan Bridge ID Time Age Dly Protocol
---------------- --------------------------------- ----- --- --- --------
VLAN0001 32769 (32768, 1) 5254.0002.230a 2 20 15 ieee
VLAN0100 32868 (32768, 100) 5254.0002.230a 2 20 15 ieee
Switch-01
-----------------------
switch-02#sh ver
Cisco IOS Software, vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Experimental Version 15.2(20200924:215240) [sweickge-sep24-2020-l2iol-release 135]
Copyright (c) 1986-2020 by Cisco Systems, Inc.
Compiled Tue 29-Sep-20 11:53 by sweickge
ROM: Bootstrap program is IOSv
switch-02 uptime is 1 hour, 10 minutes
System returned to ROM by reload
System image file is "flash0:/vios_l2-adventerprisek9-m"
Last reload reason: Unknown reason
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
export@cisco.com.
Cisco IOSv () processor (revision 1.0) with 722145K/62464K bytes of memory.
Processor board ID 9986JTUTXFS
1 Virtual Ethernet interface
5 Gigabit Ethernet interfaces
DRAM configuration is 72 bits wide with parity disabled.
256K bytes of non-volatile configuration memory.
0K bytes of ATA System CompactFlash 0 (Read/Write)
0K bytes of ATA CompactFlash 1 (Read/Write)
11217K bytes of ATA CompactFlash 2 (Read/Write)
0K bytes of ATA CompactFlash 3 (Read/Write)
Configuration register is 0x101
switch-02#sh ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.0.3 - 5254.0002.8064 ARPA Vlan100
Internet 192.168.0.10 0 5254.0013.d1f3 ARPA Vlan100
switch-02#sh spanning br
Hello Max Fwd
Vlan Bridge ID Time Age Dly Protocol
---------------- --------------------------------- ----- --- --- --------
VLAN0001 32769 (32768, 1) 5254.0002.972d 2 20 15 ieee
VLAN0100 32868 (32768, 100) 5254.0002.972d 2 20 15 ieee
11-10-2022 05:01 AM - edited 11-10-2022 05:04 AM
I created two new switches, connected them, created a vlan, set the connected ports to access, allowed the vlan, and it could ping. I wiped the config on switch-01 and switch-02 and started from scratch. It's working now. The two switches can ping and the HSRP is working. I've hit weird bugs in CML before. It may have just been that.
11-10-2022 05:06 AM
that what i thought that is the reason i asked to post some information before we come to conclusion, we seen some time bot the switch produce same MAC address.
Glad all good. enjoy labbing.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide