cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
364
Views
5
Helpful
10
Replies
Highlighted
Beginner

Can't ping from one 2960X to another

Hi,

I've got two 2960X switches connected via straight cable.  SW1 sits between SW2 and my router (and the rest of my network). I can ping and telnet into SW1 from any machine on my network with no issues.  I cannot do the same with SW2.  I can't ping or telnet from any machines, and I can't ping it from SW1.

Both switches have the same VLANs configured on them (1, 10, 20, 30, 99 (Native)) and the ports that are interconnecting them are both trunked and all VLANs are allowed to pass through.

Is there some other step I'm missing?  Thank you in advance!

10 REPLIES 10
Engager

Re: Can't ping from one 2960X to another

Hi @NPO-IT ,

 

Can you share the settings of both switches?
This is to check if something is missing.

 

Regards

Rising star

Re: Can't ping from one 2960X to another

Hello,

Could you share the current configuration os this device?

By the way, you can check missing configuration, like;

Does your switch SW2 has a IP on VLAN INTERFACE configured properly?
Does your switch Sw2 has a default gateway configured?
Does your switch has a interfaces trunk allowed vlans that you need pass through it?

Thanks in advance.
Jaderson Pessoa
*** Rate All Helpful Responses ***
Beginner

Re: Can't ping from one 2960X to another

Here's the configuration for SW1:

Current configuration : 7569 bytes
!
! Last configuration change at 05:46:51 UTC Mon Apr 15 2019
! NVRAM config last updated at 05:04:25 UTC Sun Apr 14 2019
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CATALYST2960X_02
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$3IRH$PoS4VJCHPvFjL1.L/AIVu.
!
no aaa new-model
clock timezone UTC -10 0
switch 1 provision ws-c2960x-48lps-l
!
!
!
!
!
!
!
!
!
!
!
udld aggressive

!
mls qos map cos-dscp 0 8 16 24 32 46 46 56
!
crypto pki trustpoint TP-self-signed-2119445120
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2119445120
 revocation-check none
 rsakeypair TP-self-signed-2119445120
!
!
crypto pki certificate chain TP-self-signed-2119445120
 certificate self-signed 01
...
        quit
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
auto qos srnd4
errdisable recovery cause link-flap
errdisable recovery interval 60
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
macro global description cisco-global
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/2
 description VP Admin Office
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/3
 description Director of Finance Office
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/4
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/5
 description VP Exec Admin
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/6
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/7
 description Development Office
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/8
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/9
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/10
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/11
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/12
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/13
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/14
 description FINANCE OFFICE
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/15
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/16
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/17
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/18
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/19
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/20
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/21
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/22
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/23
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/24
 description Finance Office
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/25
 description EXEC Printer
!
interface GigabitEthernet1/0/26
 switchport mode trunk
!
interface GigabitEthernet1/0/27
 switchport mode trunk
!
interface GigabitEthernet1/0/28
 switchport mode trunk
!
interface GigabitEthernet1/0/29
 switchport mode trunk
!
interface GigabitEthernet1/0/30
 switchport mode trunk
!
interface GigabitEthernet1/0/31
 switchport mode trunk
!
interface GigabitEthernet1/0/32
 switchport mode trunk
!
interface GigabitEthernet1/0/33
 switchport mode trunk
!
interface GigabitEthernet1/0/34
 switchport mode trunk
!
interface GigabitEthernet1/0/35
 switchport mode trunk
!
interface GigabitEthernet1/0/36
 switchport mode trunk
!
interface GigabitEthernet1/0/37
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/38
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/39
 switchport access vlan 65
 switchport trunk native vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/40
 switchport trunk native vlan 65
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
 switchport access vlan 64
 switchport mode access
!
interface GigabitEthernet1/0/46
 switchport mode trunk
!
interface GigabitEthernet1/0/47
 description UPLINK FROM SW2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet1/0/48
 description UPLINK TO FORTIGATE 100E
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 no ip address
!
interface Vlan64
 ip address 192.168.64.3 255.255.255.0
!
ip default-gateway 192.168.64.1
ip http server
ip http secure-server
!
!
!
no vstack
!
line con 0
line vty 0 4
 password *
 login
line vty 5 15
 password *
 login
!
!
end

And here is the config for SW2

Current configuration : 5647 bytes
!
! Last configuration change at 05:19:29 UTC Sun Apr 14 2019
! NVRAM config last updated at 05:21:10 UTC Sun Apr 14 2019
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CATALYST2960X_1
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$jwdT$zt80gUTOkke9T.9ZgTuMj1
!
no aaa new-model
clock timezone UTC -10 0
switch 1 provision ws-c2960x-24ps-l
!
!
!
!
!
!
!
!
!
!
!
udld aggressive

!
mls qos map cos-dscp 0 8 16 24 32 46 46 56
!
crypto pki trustpoint TP-self-signed-2119469312
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2119469312
 revocation-check none
 rsakeypair TP-self-signed-2119469312
!
!
crypto pki certificate chain TP-self-signed-2119469312
 certificate self-signed 01
...
        quit
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
auto qos srnd4
errdisable recovery cause link-flap
errdisable recovery interval 60
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
macro global description cisco-global
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet1/0/1
 description UPLINK TO SW1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/4
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/5
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/6
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/7
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/8
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/9
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/10
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/11
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/12
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/13
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/14
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/15
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/16
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/17
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/18
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/19
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/20
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/21
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/22
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/23
 description Admin Cubicle 02
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/24
 switchport access vlan 65
 switchport voice vlan 55
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 no ip address
!
interface Vlan64
 ip address 192.168.64.4 255.255.255.0
!
ip default-gateway 192.168.64.1
ip http server
ip http secure-server
!
!
!
no vstack
!
line con 0
line vty 0 4
 password telnet
 login
line vty 5 15
 password telnet
 login
!
!
end


Rising star

Re: Can't ping from one 2960X to another

@NPO-IT hello,

 

Could you remove this commands and test?

SW1

interface GigabitEthernet1/0/47
description UPLINK FROM SW2
no switchport trunk native vlan 99
switchport mode trunk

 

SW2

interface GigabitEthernet1/0/1
description UPLINK TO SW1
no switchport trunk native vlan 99
switchport mode trun

Jaderson Pessoa
*** Rate All Helpful Responses ***
Engager

Re: Can't ping from one 2960X to another

Hi @NPO-IT ,

 

Query:
Does vlan 64 exist on switch 2?
If it is not, create it and see if the vlan interface goes to UP.

 

Regards

VIP Advisor

Re: Can't ping from one 2960X to another

Helllo

Is the trunk up on either switch

- sh int trunk

do both switches see each other?

- sh cdp neighbours

is the L3 svi up

- sh ip int brief

 

If one switch running as the core make sure ip routing is enabled on that switch and then disable ip routing in the other switch and give it a default gateway

 

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Can't ping from one 2960X to another

Thanks Paul. Is SW1 considered a core switch because SW2 is downstream of it (in relation to the router)? Right now, IP routing isn’t enabled on either switch. If I enable it on SW1, should the gateway address I set on SW2 be the address of the router or of SW1?
VIP Advisor

Re: Can't ping from one 2960X to another

Hello


@NPO-IT wrote:
Thanks Paul. Is SW1 considered a core switch because SW2 is downstream of it (in relation to the router)? Right now, IP routing isn’t enabled on either switch. If I enable it on SW1, should the gateway address I set on SW2 be the address of the router or of SW1?

If sw1 is going to be performing the routing for the vlans  and is considered as the core sw then yes enable ip routing and give sw2 a D/G of the sw1 mgt svi addresses



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
VIP Advisor

Re: Can't ping from one 2960X to another

Hello

looking at the config you post i see native vlan 99 is configured between the two switches, may i ask is this vlan is actually created in the vlan database along woth the other vlans 64.65, if it isn't please make sure it is?

on both switches

conf t

vlan 64-65,99
exit

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Rising star

Re: Can't ping from one 2960X to another

If possible, input here your current configuration and we can find missing configuration.

Thanks in advance.
Jaderson Pessoa
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad