cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

118
Views
0
Helpful
1
Replies
Highlighted
Beginner

Can't print with new Cisco 1941 router.

Aloha From Hawaii,

I've recently setup a new Cisco 1941 router for a small school.  The router works great except that all network printing/scanning to our Ricoh Aficio MP 5002 printer/copiers and HP ink jet printers doesn't work.  I can see those devices on the network.  I can ping them and get quick and perfect replies.  Both Mac and Win XP / 7 / 8 computers can setup these devices, but when anyone goes to print or scan over the network the job never prints. The computers report that they can't communicate with the printers.

All of these devices work flawlessly with the old router that I setup years and years ago. (The network is running on the old router now.)

I feel that I'm missing something very basic in the router configuration, and I would appreciate any input from the community.

Attached is my router configuration (global IPs and MAC addresses and identifying information has been redacted.):

 

Using 4286 out of 262136 bytes
!
! Last configuration change at 21:09:54 UTC Mon Mar 16 2015 by <xxx>
version 15.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname xxxxx
!
boot-start-marker
boot-end-marker
!
!
security authentication failure rate 10 log
security passwords min-length 6
logging console critical
enable secret xxxxxx
enable password xxxxxxx
!         
aaa new-model
!         
!         
aaa authentication login local_auth local
!         
!         
!         
!         
!         
aaa session-id common
!         
ip gratuitous-arps
!         
!         
!         
ip dhcp excluded-address 10.0.0.1 10.0.0.62
!         
ip dhcp pool main
 utilization mark high 80 log
 utilization mark low 10 log
 network 10.0.0.0 255.255.0.0
 default-router 10.0.0.1
 dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 8.8.8.8 208.67.222.222 8.8.4.4 208.67.220.220
 lease 6  
!         
!         
!         
no ip bootp server
ip domain name local
ip name-server 208.67.222.222
ip cef    
login block-for 20 attempts 12 within 10
no ipv6 cef
multilink bundle-name authenticated
!         
!         
!         
license <XXXXXXXX>
!         
!         
username <XXXXXX>
!         
redundancy
!         
!         
ip ssh time-out 60
ip ssh authentication-retries 2
!         
!         
!         
!         
interface Loopback0
 ip address 172.20.1.1 255.255.255.252
!         
interface Embedded-Service-Engine0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 shutdown
 no mop enabled
!         
interface GigabitEthernet0/0
 mac-address 0022.6b57.xxxx
 ip address xxx.xxx.xxx.xxx 255.xxx.xxx.xxx
 no ip redirects
 no ip unreachables
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no mop enabled
!         
interface GigabitEthernet0/1
 ip address 10.0.0.1 255.255.0.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 no mop enabled
!         
ip forward-protocol nd
!         
no ip http server
no ip http secure-server
!         
ip nat pool NATPOOL xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx prefix-length 30
ip nat inside source list 99 pool NATPOOL overload
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
!         
!         
logging trap debugging
logging facility local2
dialer-list 1 protocol ip permit
no cdp run
!         
!         
access-list 99 permit 10.0.0.0 0.0.255.255
access-list 100 permit udp any any eq bootpc
access-list 101 permit tcp any any
access-list 101 permit udp any any
access-list 101 permit icmp any any
access-list 102 permit udp any any eq rip
access-list 102 permit ospf any any
access-list 102 permit tcp any any eq bgp
access-list 102 permit tcp any eq bgp any
!         
!         
!         
control-plane
!         
!   
!         
line con 0
 exec-timeout 5 0
 login authentication local_auth
 transport output telnet
line aux 0
 exec-timeout 15 0
 login authentication local_auth
 transport output telnet
line 2    
 exec-timeout 15 0
 login authentication local_auth
 no activation-character
 no exec  
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 password xxxxx
 login authentication local_auth
 transport input telnet ssh
!         
scheduler allocate 20000 1000
!         
end 

 

 

Everyone's tags (1)
1 REPLY 1
Hall of Fame Guru

I have to log off as it's

I have to log off as it's late here but one observation from your router config.

Presumably the clients and printers are on the same IP subnet ie. 10.0.0.0 255.255.0.0 because that is the only interface other than the outside interface you have.

So printing on your LAN doesn't go to the router ie. it is direct between the client and the printer.

The only traffic going to your router would be internet traffic.

Unless I have misunderstood how you have things setup ?

Jon

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards