cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
922
Views
0
Helpful
8
Replies

Can you see anything wrong with my output drops?

Chris Golden
Level 1
Level 1

Hi there, could someone with an expert eye tell me if you see something wrong on this interface summary.  I notice a lot of output drops?

 

GigabitEthernet1/0/40 is up, line protocol is up (connected) 
  Hardware is Gigabit Ethernet, address is 2834.a2fc.f5a8 (bia 2834.a2fc.f5a8)
  Description: UPLINK-FROM-SW1AN
  MTU 9014 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:03, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 64577934
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1311000 bits/sec, 212 packets/sec
  5 minute output rate 1861000 bits/sec, 296 packets/sec
     1690456673 packets input, 1243471503312 bytes, 0 no buffer
     Received 37922813 broadcasts (6164559 multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 6164559 multicast, 0 pause input
     0 input packets with dribble condition detected
     1747198376 packets output, 1436286894560 bytes, 0 underruns
     64577934 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out
8 Replies 8

Hi

Try clearing the counters and verify if the output errors are increasing again. You could change the cable or move it to other port and see the behavior.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

 

Current configuration : 143 bytes
!
interface GigabitEthernet1/0/6
 description WINNODE1-iSCSI
 switchport access vlan 1035
 switchport mode access
 spanning-tree portfast
end

SWRTSR(config)#do sh run int gi2/0/6
Building configuration...

Current configuration : 143 bytes
!
interface GigabitEthernet2/0/6
 description WINNODE1-iSCSI
 switchport access vlan 1038
 switchport mode access
 spanning-tree portfast
end

SWRTSR(config)#do sh int gig1/0/6 | inc output drop              
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 42826285
SWRTSR(config)#do sh int gig2/0/6 | inc output drop
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 44942947

IBMeR
Level 1
Level 1

Hello,

Output errors in most cases you may see if you have drops output traffic - for example, in time interface overflow or qos policy drops.

I can't say more exactly - it's platform-dependent. What equipment model is it?

P.S. You may compare drops count with this string your output:

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 64577934

Hi its a WS-C3850-48T

This document explains this problem for this platform. You can find case study around end of document:

https://www.cisco.com/c/en/us/support/docs/switches/catalyst-3850-series-switches/200594-Catalyst-3850-Troubleshooting-Output-dr.html

So I reset the counters and the problem is still there:

 

5 minute output rate 107724000 bits/sec, 11341 packets/sec
     732038946 packets input, 1039418203867 bytes, 0 no buffer
     Received 979480 broadcasts (877032 multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 877032 multicast, 0 pause input
     0 input packets with dribble condition detected
     248494333 packets output, 207704499465 bytes, 0 underruns
     6217516 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

I increased the qos queue-softmax-multiplier to 200 and now presently I do not see any drops other than these two interfaces:

 

Current configuration : 143 bytes
!
interface GigabitEthernet1/0/6
 description WINNODE1-iSCSI
 switchport access vlan 1035
 switchport mode access
 spanning-tree portfast
end

SWRTSR(config)#do sh run int gi2/0/6
Building configuration...

Current configuration : 143 bytes
!
interface GigabitEthernet2/0/6
 description WINNODE1-iSCSI
 switchport access vlan 1038
 switchport mode access
 spanning-tree portfast
end

SWRTSR(config)#do sh int gig1/0/6 | inc output drop              
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 42826285
SWRTSR(config)#do sh int gig2/0/6 | inc output drop
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 44942947

I increased the qos queue-softmax-multiplier to 200 and now presently I do not see any drops other than these two interfaces:

 

Current configuration : 143 bytes
!
interface GigabitEthernet1/0/6
 description WINNODE1-iSCSI
 switchport access vlan 1035
 switchport mode access
 spanning-tree portfast
end

SWRTSR(config)#do sh run int gi2/0/6
Building configuration...

Current configuration : 143 bytes
!
interface GigabitEthernet2/0/6
 description WINNODE1-iSCSI
 switchport access vlan 1038
 switchport mode access
 spanning-tree portfast
end

SWRTSR(config)#do sh int gig1/0/6 | inc output drop              
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 42826285
SWRTSR(config)#do sh int gig2/0/6 | inc output drop
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 44942947
 
 
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card