cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
922
Views
0
Helpful
16
Replies

Can you use any ports for HSRP peers of 4507r+e

alison.hou
Beginner
Beginner

I tried to use ports not in suppervisor modules for HSRP peers of two 4507r+e switches and could not bring the ports up.  can you tell me why? do i have to use ports on the sups. 

please provide docs if possible. i could not find any.

 

thanks,

Alison

16 Replies 16

Mark Malone
Mentor
Mentor
Hi
No you dont have to use the sup ports
HSRP config is same on any pair of switches in terms of config its standard accross all platforms , can you post what you have in place on each switch the config specific to HSRP , also make sure the layer 2 path is there if going thorough another switch the vlan must be allowed

https://www.networkstraining.com/cisco-router-hsrp-configuration/

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

You should not see any issue here using other ports, can you post show version and configuration to review.

 

would be nice to see logs.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

here is the config on A switch. the B is the same with .3 address. 

 

interface Vlan201
description 2nd FLOOR
ip address 10.80.4.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 201 ip 10.80.4.1
standby 201 priority 110
standby 201 preempt
standby 201 authentication H$h$rP
!
interface Vlan202
description 2nd FLOOR
ip address 10.80.5.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 202 ip 10.80.5.1
standby 202 priority 110
standby 202 preempt
standby 202 authentication H$h$rP
!
interface Vlan203
description 2nd FLOOR
ip address 10.80.6.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 206 ip 10.80.6.1
standby 206 priority 110
standby 206 preempt
standby 206 authentication H$h$rP
!
interface Vlan205
description Controllers & APs
ip address 10.80.25.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 205 ip 10.80.25.1
standby 205 priority 110
standby 205 preempt
standby 205 authentication H$h$rP
!
interface Vlan210
description NET-CLIENT_TEST_01-10.82.255.0/26
ip address 10.82.255.2 255.255.255.192
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 210 ip 10.82.255.1
standby 210 priority 110
standby 210 preempt
standby 210 authentication H$h$rP
!
interface Vlan599
description VC UNITS
ip address 10.80.99.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 99 ip 10.80.99.1
standby 99 priority 110
standby 99 preempt
standby 99 authentication H$h$rP
!
interface Vlan900
description Interswitch VLAN
ip address 10.80.19.53 255.255.255.252
!
interface Vlan1201
description FL2-WESTSIDE-VOIP
ip address 10.80.104.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 104 ip 10.80.104.1
standby 104 priority 110
standby 104 preempt
standby 104 authentication H$h$rP
!
interface Vlan1202
description FL2-EASTSIDE-VOIP
ip address 10.80.105.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 105 ip 10.80.105.1
standby 105 priority 110
standby 105 preempt
standby 105 authentication H$h$rP
!
interface Vlan3909
description L3 Link To 7018-A e17/5
bandwidth 10000000
ip address 10.80.19.18 255.255.255.252
!
interface Vlan3910
description L3 Link To 7018-B e17/5
bandwidth 10000000
ip address 10.80.19.22 255.255.255.252
!
interface Vlan3999
no ip address
shutdown
!
!
router eigrp 2
network 10.0.0.0
passive-interface Vlan201
passive-interface Vlan202
passive-interface Vlan203
passive-interface Vlan1201
passive-interface Vlan1202
passive-interface Vlan599
passive-interface Vlan210
passive-interface Vlan205
eigrp stub connected summary
!

 

interswitch port:

interface GigabitEthernet5/5
switchport trunk native vlan 99
switchport trunk allowed vlan 201-203,205,210,599,900,1201,1202
switchport mode trunk

 

 

 

 

 

US-NYME1-S4507-2A#show ver
Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500e-IPBASEK9-M), Version 15.1(2)SG1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Tue 23-Jul-13 08:08 by prod_rel_team

ROM: 12.2(44r)SG10
US-NYME1-S4507-2A uptime is 5 years, 43 weeks, 4 days, 12 hours, 37 minutes
Uptime for this control processor is 2 years, 10 weeks, 13 hours, 46 minutes
System returned to ROM by SSO Switchover
System restarted at 21:37:46 EDT Fri May 19 2017
System image file is "bootflash:cat4500e-ipbasek9-mz.151-2.SG1.bin"
Darkside Revision 4, Nexu Revision 12, Fortooine Revision 1.40

Last reload reason: Reload command

 

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C4507R+E (MPC8548) processor (revision 12) with 524288K bytes of memory.
Processor board ID FXS1651Q35X
MPC8548 CPU at 1GHz, Supervisor 6L-E
Last reset from Reload
13 Virtual Ethernet interfaces
248 Gigabit Ethernet interfaces
4 Ten Gigabit Ethernet interfaces
511K bytes of non-volatile configuration memory.

Configuration register is 0x2102

US-NYME1-S4507-2A#

here is the config on A switch. the B is the same with .3 address. 

 

interface Vlan201
description 2nd FLOOR
ip address 10.80.4.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 201 ip 10.80.4.1
standby 201 priority 110
standby 201 preempt
standby 201 authentication H$h$rP
!
interface Vlan202
description 2nd FLOOR
ip address 10.80.5.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 202 ip 10.80.5.1
standby 202 priority 110
standby 202 preempt
standby 202 authentication H$h$rP
!
interface Vlan203
description 2nd FLOOR
ip address 10.80.6.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 206 ip 10.80.6.1
standby 206 priority 110
standby 206 preempt
standby 206 authentication H$h$rP
!
interface Vlan205
description Controllers & APs
ip address 10.80.25.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 205 ip 10.80.25.1
standby 205 priority 110
standby 205 preempt
standby 205 authentication H$h$rP
!
interface Vlan210
description NET-CLIENT_TEST_01-10.82.255.0/26
ip address 10.82.255.2 255.255.255.192
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 210 ip 10.82.255.1
standby 210 priority 110
standby 210 preempt
standby 210 authentication H$h$rP
!
interface Vlan599
description VC UNITS
ip address 10.80.99.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 99 ip 10.80.99.1
standby 99 priority 110
standby 99 preempt
standby 99 authentication H$h$rP
!
interface Vlan900
description Interswitch VLAN
ip address 10.80.19.53 255.255.255.252
!
interface Vlan1201
description FL2-WESTSIDE-VOIP
ip address 10.80.104.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 104 ip 10.80.104.1
standby 104 priority 110
standby 104 preempt
standby 104 authentication H$h$rP
!
interface Vlan1202
description FL2-EASTSIDE-VOIP
ip address 10.80.105.2 255.255.255.0
ip helper-address 10.80.13.22
ip helper-address 10.80.13.21
ip helper-address 10.18.6.23
ip helper-address 10.18.6.27
standby 105 ip 10.80.105.1
standby 105 priority 110
standby 105 preempt
standby 105 authentication H$h$rP
!
interface Vlan3909
description L3 Link To 7018-A e17/5
bandwidth 10000000
ip address 10.80.19.18 255.255.255.252
!
interface Vlan3910
description L3 Link To 7018-B e17/5
bandwidth 10000000
ip address 10.80.19.22 255.255.255.252
!
interface Vlan3999
no ip address
shutdown
!
!
router eigrp 2
network 10.0.0.0
passive-interface Vlan201
passive-interface Vlan202
passive-interface Vlan203
passive-interface Vlan1201
passive-interface Vlan1202
passive-interface Vlan599
passive-interface Vlan210
passive-interface Vlan205
eigrp stub connected summary
!

 

interswitch port:

interface GigabitEthernet5/5
switchport trunk native vlan 99
switchport trunk allowed vlan 201-203,205,210,599,900,1201,1202
switchport mode trunk

 

 

 

 

 

US-NYME1-S4507-2A#show ver
Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500e-IPBASEK9-M), Version 15.1(2)SG1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Tue 23-Jul-13 08:08 by prod_rel_team

ROM: 12.2(44r)SG10
US-NYME1-S4507-2A uptime is 5 years, 43 weeks, 4 days, 12 hours, 37 minutes
Uptime for this control processor is 2 years, 10 weeks, 13 hours, 46 minutes
System returned to ROM by SSO Switchover
System restarted at 21:37:46 EDT Fri May 19 2017
System image file is "bootflash:cat4500e-ipbasek9-mz.151-2.SG1.bin"
Darkside Revision 4, Nexu Revision 12, Fortooine Revision 1.40

Last reload reason: Reload command

 

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C4507R+E (MPC8548) processor (revision 12) with 524288K bytes of memory.
Processor board ID FXS1651Q35X
MPC8548 CPU at 1GHz, Supervisor 6L-E
Last reset from Reload
13 Virtual Ethernet interfaces
248 Gigabit Ethernet interfaces
4 Ten Gigabit Ethernet interfaces
511K bytes of non-volatile configuration memory.

Configuration register is 0x2102

US-NYME1-S4507-2A#

Hi what state is the HSRP in now is it active each side , can you post the show hsrp standby or brief

is the spanning tree for these vlans in FWD state , check that too , show spanning-tree vlan x , the trunk needs to be forwarding on both sides or there will be HSRP issues forming

During my change on Saturday, i tried to use g5/5 (WS-X4548-GB-RJ45V)  on both switches, but could not bring them up, i tried to change cables and another port g7/20, nothing worked. Both ports were shown down and down.  So  I changed to T4/1 which was one of the sup ports, than it worked. The currect state is good with port T4/1s as trunk ports on both side.  HSRP configuration is not issue. 

 

I was wandering why the HSRP peers could not be brought up using non sup ports.  

 

Do you have a live network with HSRP configured using non-sup ports?  

thanks,

yes 100s of switches setup using HSRP globally in many regions , its a basic feature theres not much in it really few commands and make sure the layer 2 setup is not being blocked inpath between the devices, most;y we use it between vlans rather than physical ports where VSS is not available in campus

if your port was down/down its nothing to do with HSRP feature , its a layer 1 issue , you need to fix that first before thinking about a protocol thats in layer 2 , start from where the problem is work up through teh layers , down down is layer 1 , either cables , speed duplex or sfps depending on physical setup but all layer 1 issues

can you replicate the issue and take some outputs we should be able to see whats gone wrong when connected to the line cards ?

thank you for confirming. i will setup a lab to test it. 

 

Alison

what does "the layer 2 setup is not being blocked inpath between the devices" mean?

thanks,

Alison

the ips are part of a vlan with a subnet , say example Vlan205 you have in your config.
that vlan exists at layer 2 and layer 3 the SVI where the HSRP config is,
at layer 2 you have allowed it on the trunk interface between the switches
now that can be blocked automatically by spanning tree in the background if it sees a layer 2 issue , it must be in FWD mode in STP, not all HSRP connections are direct between switches they can go through multiple switches as long as the vlan is allowed and the path is there at layer 2 , the physical path/interfaces/switches the frames would pass through

so to check that you would need to the trunk link between the switches using command --- show spanning-tree interface x/x

but before fixing any layer 2 issues layer 1 must be up , so the interfaces cannot be down/down

example
sh spanning-tree interface po2

Vlan Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
VLAN0002 Desg FWD 1 128.4097 (vPC) P2p

VLAN0010 Desg FWD 1 128.4097 (vPC) P2p

VLAN0011 Desg FWD 1 128.4097 (vPC) P2p

it is very helpful, Mark.  i will check them out after i make sure the physical is up. 

 

i think i might figure out why the ports showed dead. Now I remeber we did have spanning-tree bpdugard enable in global. I think the peer ports could be err-disabled as soon as I connected them. Even though i disable bpdugard, but the interfaces were  disabled, i think... 

 

thanks,

 

 

Great sounds like you might have it alright , glad i could help bit

it is very helpful, Mark.  i will check them out after i make sure the physical is up. 

 

i think i might figure out why the ports showed dead. Now I remeber we did have spanning-tree bpdugard enable in global. I think the peer ports could be err-disabled as soon as I connected them. Even though i disable bpdugard, but the interfaces were  disabled, i think... 

 

thanks,

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers