cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
357
Views
0
Helpful
4
Replies
markrichard
Beginner

Cannot ping between two vlans on CBS250-8T-E-2G with IPv4 Routing Enable

Cannot ping between two vlans on CBS250-8T-E-2G with IPv4 Routing Enable

 

from a laptop connect to a trunk port...

I can ping between the Vlans & ping out via the static route to the uplink ISP only via the CBS220 switch portal ping...

 

Ipv4 Interface 

IPv4 Routing: Enable

Interface Iptyp   IPAdr Mask   Status

Vlan 1     Static 10.1.0.1/24   Valid

Vlan 2     Static  10.2.0.1/24   Valid

 

laptop in Trunk Port GI6 10.2.0.9 

laptop in Trunk Port GI8 10.1.0.10

 

Port Vlan Membership

GI6 Trunk 1U,2-4T,5-2094I  1U,2-4T

GI8 Trunk 1U,2-4T,5-2094I  1U,2-4T

 

IPv4 Static Routes - None defined

 

IPv4 Forwarding Table

Des IP          Route Type    Next Hop    Route Owner                Outgoing Interface 

10.1.0.0 /24 local             10.1.0.1       directly connected        VLAN1

10.2.0.0/24  local             10.2.0.1        directly connected       VLAN2

 

 

According to SG300 Tech video  turning on IPv4 route enable ... traffic should be able to ping between vlans...

 

The CBS250 is the only switch in the network... tyring to create a test network to test  two VLans traffic then next stepis to route to an uplink vlan to new ISP

 

This test network should work...

Attempting to capture startup file to attach to post ...

 

 

 

 

 

4 REPLIES 4
balaji.bandi
VIP Master

sure you have mentioned you configured layer3, make sure you check that option again :

:https://www.cisco.com/c/en/us/td/docs/switches/lan/csbms/CBS_250_350/Administration-Guide/cbs-250-ag/vlan-management.html?bookSearch=true

 

post-show run to look at the config

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

 

 

Show Run ..............................


switch52247f#show run
config-file-header
switch52247f
v3.1.0.57 / RCBS3.1_930_871_059
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
!
unit-type-control-start
unit-type unit 1 network gi uplink none
unit-type-control-end
!
vlan database
vlan 2-4
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone
voice vlan oui-table add 00036b Cisco_phone
voice vlan oui-table add 00096e Avaya
voice vlan oui-table add 000fe2 H3C_Aolynk
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone
voice vlan oui-table add 00e075 Polycom/Veritel_phone
voice vlan oui-table add 00e0bb 3Com_phone
bonjour interface range vlan 1
hostname switch52247f
username ospadmin password .......... privilege 15
ip ssh server
ip telnet server
!
interface vlan 1
ip address 10.1.0.1 255.255.255.0
no ip address dhcp
!
interface vlan 2
name voip
ip address 10.2.0.1 255.255.255.0
!
interface vlan 3
name public
ip address 10.3.0.1 255.255.255.0
!
interface vlan 4
name Uplink
ip address 10.22.22.1 255.255.255.0
!
interface GigabitEthernet1
switchport access vlan 4
switchport trunk native vlan 4
!
interface GigabitEthernet3
switchport access vlan 2
switchport trunk native vlan 2

!
interface GigabitEthernet5
switchport mode trunk
!
interface GigabitEthernet6
switchport mode trunk
!
interface GigabitEthernet7
switchport mode trunk
!
interface GigabitEthernet8
switchport mode trunk
!
interface GigabitEthernet9
switchport access vlan 2
!
exit
ip default-gateway 10.22.22.2
ip route 10.1.1.0 /24 10.22.22.2
ip route 10.2.1.0 /24 10.22.22.2
ip route 10.3.0.0 /24 10.22.22.2
ip route 10.220.220.0 /24 10.22.22.2

I would suggest looking at this video for access port and trunk.

 

https://www.youtube.com/watch?v=ob-bFIKY150

 

ip default-gateway 10.22.22.2  <-- this means this is Layer 2 Only.
ip route 10.1.1.0 /24 10.22.22.2
ip route 10.2.1.0 /24 10.22.22.2
ip route 10.3.0.0 /24 10.22.22.2
ip route 10.220.220.0 /24 10.22.22.2

 

Note: the Interface VLAN only comes up and is active when any device in the VLAN port is connected.

 

show ip interface brief,  give you is this interface up and running

 

Not sure is this command accept here in this model, lets try.

 

config t

!

no ip default-gateway 10.22.22.2
no ip route 10.1.1.0 /24 10.22.22.2
no ip route 10.2.1.0 /24 10.22.22.2
no ip route 10.3.0.0 /24 10.22.22.2
no ip route 10.220.220.0 /24 10.22.22.2

!

ip routing 

!

ip route 0.0.0.0 0.0.0.0 10.22.22.2   <-- not sure what is this IP is this for your DSL router ?

!

end

 

once this is done, check are you able to reach another VLAN IP address?

 

Still isue 

 

post again modified config :

 

show run

show ip interface brief

show ip route.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

In this edition of Tech Talks, we'll show how to configure port to VLAN Interface settings on a CBS 250/350 series switch through the Command Line Interface ...

Hello

Suggest you remove all static routes and apply a default static route towards your egress wan rtr, Also connect the laptop to an access port not a trunk port and assigned to a vlan it.
You should then be able to ping from the laptops the L3 svi interfaces on the switch and any host residning on any other access port on the switch providing they have the correct ip addressing 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future