cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
723
Views
0
Helpful
6
Replies
mitard
Beginner

Cat. 9200 PoE operational state remains 'faulty' for a notconnected interface

Hi,

 

I have a strange behavior on a Catalyst 9200 (Running IOS-XE 16.12.4). In the log the following recurrent set of message prints out :

Feb 24 07:43:35.611: %ILPOWER-5-IEEE_DISCONNECT: Interface Gi1/0/5: PD removed
Feb 24 07:43:36.602: %ILPOWER-5-DETECT: Interface Gi1/0/5: Power Device detected: IEEE PD
Feb 24 07:43:37.611: %ILPOWER-5-IEEE_DISCONNECT: Interface Gi1/0/5: PD removed
Feb 24 07:43:37.614: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Gi1/0/5: Power Controller reports power Imax error detected

As I understand it means the device plugged-in port Gi1/0/5 required more power than negociated, but where it comes tricky is there is no device attached the interface at all :

#show interfaces g1/0/5 status

Port Name Status Vlan Duplex Speed Type
Gi1/0/5 notconnect 162 auto auto 10/100/1000BaseTX

And the PoE operationnal state remains 'faulty' :

#show power inline g1/0/5 detail
Interface: Gi1/0/5
Inline Power Mode: auto
Operational status: faulty
Device Detected: no
Device Type: n/a
IEEE Class: n/a
Discovery mechanism used/configured: Ieee and Cisco
Police: off

Power Allocated
Admin Value: 30.0
Power drawn from the source: 0.0
Power available to the device: 0.0

Actual consumption
Measured at the port: 0.0
Maximum Power drawn by the device since powered on: 0.0

Absent Counter: 0
Over Current Counter: 0
Short Current Counter: 0
Invalid Signature Counter: 0
Power Denied Counter: 0

Power Negotiation Used: None
LLDP Power Negotiation --Sent to PD-- --Rcvd from PD--
Power Type: - -
Power Source: - -
Power Priority: - -
Requested Power(W): - -
Allocated Power(W): - -

Four-Pair PoE Supported: No
Spare Pair Power Enabled: No
Four-Pair PD Architecture: N/A

I assume the issue happened previously and the device was maybe moved to another port. I tried to shutdown/no shutdown the interface but it remains the same. Does anyone know how to get rid of these error messages which fill-up the logs.

 

Thanks for you help, regards, Vincent

 

1 ACCEPTED SOLUTION

Accepted Solutions

Sure if this not the burning issue, you can wait for the proper release and upgrade as per convinient.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

6 REPLIES 6
balaji.bandi
VIP Master

 

Operational status: faulty

Not sure at this stage Port is faulty or not, what is the outcome if you connect PC or Laptop to that port is that works?

 

check some troubleshooting tips :

 

https://www.cisco.com/c/en/us/support/docs/switches/catalyst-9200-series-switches/215636-troubleshooting-power-over-ethernet-poe.html

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hi Balaji,

 

In fact the switch is on a remote location thus I cannot easily plugin a device and I was looking for some remote debug tips to clear the error. If there is no other option I'll ask for some onsite assistance to connect to the faulty port and I'll check out the outcome and I'll keep you posted.

 

Regards, Vincent

Leo Laohoo
VIP Community Legend

IOS-XE version 16.12.X has many PoE bugs and this affects any appliance with PoE, including 3650/3850 as well as 9200 and 9300. 

The workaround is to reboot the switch/stack.  
In some of the PoE bugs I have encountered, TAC has recommended 16.12.5 as the fix version.  

NOTE:  Currently testing 16.12.5 for the last 3 weeks but I will not be able to make any conclusion until after 12 weeks of no-fault uptime.

Hi Leo,

 

Thanks for sharing your experience. Since this is not a blocking issue on my side I will wait for 16.12.5 to be the Cisco recommended release before upgrading the equipement.

 

Regards, Vincent

Sure if this not the burning issue, you can wait for the proper release and upgrade as per convinient.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

cmarva
Enthusiast

there could be something attached. a device will draw poe via pins 7 and 8. The link status comes from 1,2,3,and 6. 

so if this is at a remote site, you may want to have someone recon this for you.