cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2060
Views
0
Helpful
4
Replies

Catalyst 3560 DHCP

jefft
Beginner
Beginner

I have a 3560 setup to dish out DHCP to clients.

Everyone gets DHCP Correctly with the exception of Windows7 machines.Windows 2000 and XP obtain IP addresses without an issue, but Windows 7 machines do not get an IP address at all.  If the Windows 7 machine is moved to a differant subnet where DHCP is offered through our server then the machines get IP's without a problem.

here is my config:

!
ip dhcp pool franklin-admin
   network 192.168.9.0 255.255.255.0
   netbios-node-type h-node
   default-router 192.168.9.1 255.255.255.0
   dns-server 172.26.253.10 192.168.1.60
   netbios-name-server 172.26.253.10
   domain-name meriden.k12.ct.us
   lease 60

!

4 Replies 4

glen.grant
Advisor
Advisor

   On all "user"ports on the 3560 make sure you have implemented the  "switchport host"  command  and then retry your test.

Glen,

Thank you, does that apply even if there are no hosts on this switch but on the upstream switch which is uplinked with a x-over cable?

Jeff

  Apply it on the switch where the win 7 clients are attached but they can't pull an address...

terry.wolf
Beginner
Beginner

We had a similar problem with Window 7 clients.  DHCP is being provided by 2811 routers.  Same problem is occurring at several sites.  What we found is that the statement default-router 192.168.9.1 255.255.255.0 had to be modified to default-router 192.168.9.1  (with no subnet mask).

Apparently, Windows 7 hosts do not accept the DHCP offer when the subnet mask is included in this statement.  We could see the DHCP Discover and DHCP Offer occurring over and over again, but the client would not use the address.  Can anyone else confirm this fix?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: