cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
453
Views
0
Helpful
6
Replies

catalyst 4500 won't create another trunk int

silverstr8p
Beginner
Beginner

I've somehow been able to get gi2/2 to pass multiple vlan's over a trunk, but now can't seem to duplicate steps on gi2/3, here are the steps I'm trying:

Switch#show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi2/2       on               802.1q         trunking      1
Gi2/5       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi2/2       90,98
Gi2/5       90,98

Port        Vlans allowed and active in management domain
Gi2/2       90,98
Gi2/5       90,98

Port        Vlans in spanning tree forwarding state and not pruned
Gi2/2       90,98
Gi2/5       90,98
config t Switch(config)#interface gi2/3 Switch(config-if)#shut Switch(config-if)#switchport mode trunk Switch(config-if)#switchport trunk encapsulation dot1q Switch(config-if)#switchport trunk allowed vlan 90,98 Switch(config-if)#no shut Switch(config-if)#end Switch# 02:19:15: %SYS-5-CONFIG_I: Configured from console by console Switch#show interfaces trunk Port Mode Encapsulation Status Native vlan Gi2/2 on 802.1q trunking 1 Gi2/5 on 802.1q trunking 1 Port Vlans allowed on trunk Gi2/2 90,98 Gi2/5 90,98 Port Vlans allowed and active in management domain Gi2/2 90,98 Gi2/5 90,98 Port Vlans in spanning tree forwarding state and not pruned Gi2/2 90,98 Gi2/5 90,98

For some reason gi2/3 doesn't show passing the two vlan's, just vlan 1:

Switch#show vlan b

VLAN Name                             Status    Ports
---- -------------------------------- --------- -
1    default                          active    Gi1/2, Gi2/3, Gi2/4,
...
90   vlan90                           active    
97   vlan97                           active    Gi2/1
98   vlan98                           active    
 

What am I missing?

6 Replies 6

Jon Marshall
Hall of Fame
Hall of Fame

 

I know you did a "no shut" but is the interface actually showing as up/up ("sh ip int br"). 

 

It has to be up to be seen in the "sh int trunk" output. 

 

Jon

silverstr8p
Beginner
Beginner
Switch#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol  
GigabitEthernet1/1     unassigned      YES NVRAM  administratively down down    
GigabitEthernet1/2     unassigned      YES unset  down                  down    
GigabitEthernet2/1     unassigned      YES unset  down                  down    
GigabitEthernet2/2     unassigned      YES unset  up                    up      
GigabitEthernet2/3     unassigned      YES unset  down                  down    
GigabitEthernet2/4     unassigned      YES unset  down                  down    
GigabitEthernet2/5     unassigned      YES unset  up                    up      

I can plug something into it and see. But why would it still show up under vlan1 in sh vlan b?

I agree that you should connect 2/3 to another switch and see if that does not make a difference. The output of show interface status would be helpful in addition to show interface trunk.

HTH

Rick

 

By default all ports are in vlan 1. 

 

A trunk port (when it is up/up) does not show up in "sh vlan" as belonging to any vlan but if the trunk is not up it just defaults to being in vlan 1. 

 

The port is down which is why you are not seeing it, connect something to it and it will then show up in your "sh int trunk" output. 

 

Jon

silverstr8p
Beginner
Beginner

@Richard Burtshere's the output:

Switch#show interfaces status 

Port      Name               Status       Vlan       Duplex  Speed Type
Gi1/1                        disabled     routed       full   1000 1000BaseSX
Gi1/2                        notconnect   1            full   1000 1000BaseSX
Gi2/1                        notconnect   9          auto   auto 10/100/1000-TX
Gi2/2                        connected    trunk      a-full a-1000 10/100/1000-TX
Gi2/3                        notconnect   1            auto   auto 10/100/1000-TX
Gi2/4                        notconnect   1            auto   auto 10/100/1000-TX
Gi2/5                        connected    trunk      a-full a-1000 10/100/1000-TX

I can't get back to the site to hook something up to the ports for awhile, but will report back.

Thanks for the update with the output of show interface status. Please do update again after you are able to connect 2/3 to another switch.

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: