cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

263
Views
0
Helpful
5
Replies
Highlighted
Beginner

Catalyst 9200 QoS

Dear Friends, i trying to test qos based on vlan on the C9200L-48T-4X with iosxe version 16.9.3. First i created this scheme

Hypervisor 1 <> Switch <> Hypervisor 2, then i set marking settings on the hypervisors.
Next step for test i enable autocos on each port by executing auto qos trust cos, switch generate class-maps and policy-maps and apply these in input and output direction.

output match counters not incrementing. i trying to monitor traffic via span and wireshark. I see 802.1q priority exists on the frame.

Why counters not incrementing? 

I assume that outgoing queues not working, how to debug?

 

show platform hardware fed switch active qos dscp-cos counters interface gi 1/0/2
Ingress COS0 3509416       0
Ingress COS1 0             0
Ingress COS2 0             0
Ingress COS3 0             0
Ingress COS4 0             0
Ingress COS5 124429        0
Ingress COS6 0             0
Ingress COS7 0             0

Egress COS0 3086581                   0
Egress COS1 0                         0
Egress COS2 0                         0
Egress COS3 0                         0
Egress COS4 0                         0
Egress COS5 231392                    0
Egress COS6 0                         0
Egress COS7 0                         0

 

sh policy-map interface gi 1/0/xx
  Service-policy input: AutoQos-4.0-Trust-Cos-Input-Policy

    Class-map: class-default (match-any)
      58301 packets
      Match: any
      QoS Set
         cos cos table AutoQos-4.0-Trust-Cos-Table

  Service-policy output: AutoQos-4.0-Output-Policy

    queue stats for all priority classes:
      Queueing
      priority level 1

      (total drops) 0
      (pkts output) 15874

    Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
      0 packets
      Match:  dscp cs4 (32) cs5 (40) ef (46)
      Match: cos  5
      Priority: 30% (300000 kbps), burst bytes 7500000,

      Priority Level: 1

...
...
 
    Class-map: class-default (match-any)
      0 packets
      Match: any
      Queueing

      (total drops) 0
      (pkts output) 57651
      bandwidth remaining 25%
      queue-buffers ratio 25

 

My interfaces config

interface GigabitEthernet1/0/1
 switchport trunk native vlan 10
 switchport mode trunk
 auto qos trust cos
 service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
 service-policy output AutoQos-4.0-Output-Policy
end
interface GigabitEthernet1/0/2
 switchport trunk native vlan 10
 switchport mode trunk
 auto qos trust cos
 service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
 service-policy output AutoQos-4.0-Output-Policy

 

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: Catalyst 9200 QoS

Answer founded here, https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9200/software/release/16-10/configuration_guide/qos/b_1610_qos_9200_cg/configuring_qos.html#concept_fph_3db_p1b

 

Classification counters have the following specific restrictions:

Classification counters count packets instead of bytes.

Filter-based classification counters are not supported

Only QoS configurations with marking or policing trigger the classification counter.

As long as there is policing or marking action in the policy, the class will have classification counters.

Classification counters are not supported on pure queuing policies under any class-map.

When there are multiple match statements in a class, the traffic counter is cumulative for all the match statements in the class.

The device supports a total of eight table maps for policer exceed markdown and eight table maps for policer violate markdown.

View solution in original post

5 REPLIES 5
Highlighted
Enthusiast

Re: Catalyst 9200 QoS

Hi,

 

The Packet Counter will increased only during congestion. There, you may refer to the Byte/Output Counter when there is no congestion. 

 

Counter Explanation

28621 packets, 7098008 bytesThe number of packets which match the criteria of the class. This counter increments whether or not the interface is congested.
(pkts matched/bytes matched) 28621/7098008The number of packets which match the criteria of the class when the interface was congested. In other words, the interface transmit ring was full, and the driver and the L3 processor system worked together to queue the excess packets in the L3 queues, where the service policy applies. Packets that are process-switched always go through the L3 queuing system and thus increment the "packets matched" counter.
Class-map: B (match-all) (1301/4)These numbers define an internal ID used with the CISCO-CLASS-BASED-QOS-MIB Management Information Base (MIB). They no longer appear in the show policy-map output in current releases of Cisco IOS.
5 minute offered rate 0 bps, drop rate 0 bpsUse the load-interval command to change this value and make it a more instantaneous value. The lowest value is 30 seconds; however, statistics displayed in the show policy-map interface output are updated every 10 seconds. Since the command effectively provides a snapshot at a specific moment, the statistics may not reflect a temporary increase in queue size.

 

 


sh policy-map interface gi 1/0/xx
  Service-policy input: AutoQos-4.0-Trust-Cos-Input-Policy

    Class-map: class-default (match-any)
      58301 packets
      Match: any
      QoS Set
         cos cos table AutoQos-4.0-Trust-Cos-Table

  Service-policy output: AutoQos-4.0-Output-Policy

    queue stats for all priority classes:
      Queueing
      priority level 1

      (total drops) 0
      (pkts output) 15874

    Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
      0 packets
      Match:  dscp cs4 (32) cs5 (40) ef (46)
      Match: cos  5
      Priority: 30% (300000 kbps), burst bytes 7500000,

      Priority Level: 1

...
...
 
    Class-map: class-default (match-any)
      0 packets
      Match: any
      Queueing

      (total drops) 0
      (pkts output) 57651
      bandwidth remaining 25%
      queue-buffers ratio 25

 


 

Ref: https://www.cisco.com/c/en/us/support/docs/quality-of-service-qos/qos-congestion-avoidance/10107-showpolicy.html

 

 

Highlighted
Beginner

Re: Catalyst 9200 QoS

Thx, for reply. Based on your information , I see my interfaces not congested but class-map counter “packets” is zero - not incrementing and “pkts output” increments - this tell is congestion occurred . I am confused, in documentation “ Packets counter increments whether or not the interface is congested” but my interfaces has zero , your answer is " The Packet Counter will increased only during congestion. There, you may refer to the Byte/Output Counter when there is no congestion"

what is true?

 

Highlighted
Cisco Employee

Re: Catalyst 9200 QoS

One of the way to check if there are counters incrementing in ingress and egress would be to get the output of, 

"show platform hardware fed switch active qos queue stats interface <int>" 

 

This will show the counters for queues and also shows any possible drops for each queue. 

Highlighted
Beginner

Re: Catalyst 9200 QoS

result of show platform hardware fed switch active qos queue stats interface

DATA Port:5 Enqueue Counters
---------------------------------------------------------------------------------------------
Q Buffers          Enqueue-TH0          Enqueue-TH1          Enqueue-TH2             Qpolicer
  (Count)             (Frames)             (Frames)             (Frames)             (Frames)
- ------- -------------------- -------------------- -------------------- --------------------
0       0                    0                 1124                  347                    0
1       0                    0                    0                    0                    0
2       0                    0                    0                    0                    0
3       0                    0                    0                    0                    0
4       0                    0                    0                    0                    0
5       0                    0                    0                    0                    0
6       0                    0                    0                    0                    0
7       0                    0                    0                 2377                    0
Highlighted
Beginner

Re: Catalyst 9200 QoS

Answer founded here, https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9200/software/release/16-10/configuration_guide/qos/b_1610_qos_9200_cg/configuring_qos.html#concept_fph_3db_p1b

 

Classification counters have the following specific restrictions:

Classification counters count packets instead of bytes.

Filter-based classification counters are not supported

Only QoS configurations with marking or policing trigger the classification counter.

As long as there is policing or marking action in the policy, the class will have classification counters.

Classification counters are not supported on pure queuing policies under any class-map.

When there are multiple match statements in a class, the traffic counter is cumulative for all the match statements in the class.

The device supports a total of eight table maps for policer exceed markdown and eight table maps for policer violate markdown.

View solution in original post

CreatePlease to create content
Content for Community-Ad