cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
188
Views
0
Helpful
3
Replies
Highlighted
Enthusiast

Catalyst - Nexus HSRP

Hi there,

Thanks for reading.  I have a  WS-C3850-48P-S which is acting as a core/backbone, hosting the network's SVI vlan interfaces.  It was a temporary solution.  Now that the permanent Nexus switch has arrived (N3K-C3548P-10GX), I need to integrate it in the network and move SVIs with as little interruption as possible.

 

My thinking was to establish HSRP and move the primary role to the Nexus.

 

Can HSRP run between these dissimilar chasses?  I'm seeing that NXOS supports HSRP v1 & v2 but I'm not seeing a command to verify versioning in the 3850 Catalyst.  I intend to keep the redundancy running only long enough to move the SVIs since the 3850 has its own permanent role elsewhere in the network.

 

Thanks again!

Bob

Everyone's tags (2)
3 REPLIES 3
Engager

Re: Catalyst - Nexus HSRP

Hi @Bob Greer,

 

Theoretically, the result of the #show standby command indicates when version 2 is configured.

 

HSRP.jpg

 

Regards

 

 

Hall of Fame Master

Re: Catalyst - Nexus HSRP

Bob asked sort of a 2 part question: can HSRP run successfully on dissimilar chassis and about a command to verify versioning. Luis has supplied the answer about the command to verify versioning. So let me answer the first part. Yes HSRP should run on dissimilar chassis with no problem.

 

HTH

 

Rick

VIP Advisor

Re: Catalyst - Nexus HSRP

Hello

Just for clarity --  IOS,<>NX-0S

 

IOS
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
standby version 2
standby 12 ip 10.1.12.100
standby 12 priority 150
standby 12 preempt

 

sh standby fastEthernet 0/0 all
FastEthernet0/0 - Group 12 (version 2)
State is Active
11 state changes, last state change 00:03:30
Virtual IP address is 10.1.12.100
Active virtual MAC address is 0000.0c9f.f00c
Local virtual MAC address is 0000.0c9f.f00c (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.600 secs
Preemption enabled
Active router is local
Standby router is 10.1.12.10, priority 100 (expires in 9.944 sec)
Priority 150 (configured 150)
Group name is "hsrp-Fa0/0-12" (default

 

sh standby brief | in Fa
Fa0/0 12 150 P Active local 10.1.12.10 10.1.12.100

 

 

 

NX-OS

feature hsrp
interface Ethernet2/1
ip address 10.1.12.10/24
no shutdown
hsrp version 2
hsrp 12
preempt
ip 10.1.12.100

sh hsrp interface eth2/1 all detail
Ethernet2/1 - Group 12 (HSRP-V2) (IPv4)
Local state is Standby, priority 100 (Cfged 100), may preempt
Forwarding threshold(for vPC), lower: 1 upper: 100
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.771000 sec(s)
Virtual IP address is 10.1.12.100 (Cfged)
Active router is 10.1.12.1, priority 150 expires in 1.364000 sec(s)
Standby router is local
Authentication text "cisco"
Virtual mac address is 0000.0c9f.f00c (Default MAC)
10 state changes, last state change 00:09:44
IP redundancy name is hsrp-Eth2/1-12 (default)


sh hsrp standby brief | in Eth
Eth2/1 12 100 P Standby 10.1.12.1 local 10.1.12.100



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad