cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
662
Views
20
Helpful
7
Replies
Highlighted
Beginner

Catalyst switch not coming up on all VLAN interfaces

I have a 3650 switch that I am trying to uplink to a 3850.
The link comes up, but not all of my VLANs are communicating properly.

Below are the interface configs for the two switches, and further below is the output on the 3650 when the uplink is plugged in.
Only interfaces vlan1 and vlan7 come up, but 200 is my main config vlan.

 

Any thoughts on what is misconfigured?

 


ws-3850-x

interface TenGigabitEthernet1/0/7
description IDF1
switchport trunk allowed vlan 1,7,20,31,80,102,107,200
switchport mode trunk
auto qos trust dscp
spanning-tree guard root
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
!

ws-3650-24td

interface TenGigabitEthernet1/1/3
description UPLINK PORT
switchport trunk allowed vlan 1,7,20,31,80,102,107,200
switchport mode trunk
!
interface Vlan200
description Corp Vlan
ip address 172.16.15.237 255.255.240.0
!

Output from 3650

*Nov 28 19:01:57.481: %PLATFORM_PM-6-MODULE_INSERTED: SFP module inserted with interface name Te1/1/3
*Nov 28 19:02:01.818: %LINK-3-UPDOWN: Interface TenGigabitEthernet1/1/3, changed state to up
*Nov 28 19:02:03.818: %LINEPROTO-5-UPDOWN: Line protocol on Interface TenGigabitEthernet1/1/3, changed state to up
*Nov 28 19:02:34.815: %LINK-3-UPDOWN: Interface Vlan1, changed state to up
*Nov 28 19:02:34.816: %LINK-3-UPDOWN: Interface Vlan7, changed state to up
*Nov 28 19:02:35.815: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
*Nov 28 19:02:35.815: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan7, changed state to up

 

I also connected a laptop to one of the access ports which should land on VLAN 200, and it cannot communicate with the rest of the devices on that VLAN

 

interface GigabitEthernet1/0/4
 description ACCESS PORT
 switchport trunk native vlan 200
 switchport trunk allowed vlan 7,200
 switchport mode trunk
 spanning-tree portfast
 spanning-tree bpduguard enable
!

 

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: Catalyst switch not coming up on all VLAN interfaces

Hello

 

On the both switches:

vlan 200

exit

 

On each switch interconnect:

Switchport  trunk native vlan 200

 

Access port

ddefault interface x/x

switchport mode access

switchport access vlan 200

switchport voice vlan 7

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
7 REPLIES 7
VIP Mentor

Re: Catalyst switch not coming up on all VLAN interfaces

Hello,

 

what is the purpose of the interface below ? It is not an access port, and if it is supposed to be a trunk, it won't work either because you have set the native VLAN to 200 (in order for that to work, the native VLAN on ALL trunks needs to be set to 200).

 

interface GigabitEthernet1/0/4
description ACCESS PORT
switchport trunk native vlan 200
switchport trunk allowed vlan 7,200
switchport mode trunk
spanning-tree portfast
spanning-tree bpduguard enable

 

An access port typically looks like this:

 

interface GigabitEthernet1/0/4
description ACCESS PORT
switchport mode access vlan 200
spanning-tree portfast

Beginner

Re: Catalyst switch not coming up on all VLAN interfaces

That interface needs to be untagged for VLAN200 for corporate and tagged for VLAN7 for voice

 

But just as important is the VLAN200 interface with IP 172.16.15.237 is not reachable from the rest of the network. Which leads me to suspect an issue with the uplink config.

VIP Mentor

Re: Catalyst switch not coming up on all VLAN interfaces

Hello,

 

what is the output of 'show vlan' on both switches ?

Beginner

Re: Catalyst switch not coming up on all VLAN interfaces

 

3850

corp-1-c1#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Te2/0/2, Te2/0/15, Te2/0/19
                                                Te2/0/20, Te2/0/23
7    IpPhone                          active
20   Emc                              active
31   Cashless                         active
40   VMotion                          active
41   NFS                              active
80   vendor                           active
101  Chassy management                active
102  Config                           active
107  WifiConfig                       active
200  Corp                             active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

3650

corp-1-d1#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/1, Gi1/0/2, Gi1/0/3
                                                Gi1/0/4, Gi1/0/5, Gi1/0/6
                                                Gi1/0/7, Gi1/0/8, Gi1/0/9
                                                Gi1/0/10, Gi1/0/11, Gi1/0/12
                                                Gi1/0/13, Gi1/0/14, Gi1/0/15
                                                Gi1/0/16, Gi1/0/17, Gi1/0/18
                                                Gi1/0/19, Gi1/0/20, Gi1/0/21
                                                Gi1/0/22, Gi1/0/23, Gi1/1/1
                                                Gi1/1/2, Te1/1/3
7    VLAN0007                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

 

 

 

VIP Mentor

Re: Catalyst switch not coming up on all VLAN interfaces

Hello,

 

VLAN 200 doesn't exist on the 3650. Manually create the Vlan:

 

3650(config)#vlan 200

Contributor

Re: Catalyst switch not coming up on all VLAN interfaces

It looks like you will want to setup many VLANs. Are you using VTP? If not, set the VTP mode to transparent, and create all of the VLANs on the new switch.

vtp mode server.

George shared vlan command above.

 

Thanks,

Alex

 

Please mark helpful posts.

 

VIP Advisor

Re: Catalyst switch not coming up on all VLAN interfaces

Hello

 

On the both switches:

vlan 200

exit

 

On each switch interconnect:

Switchport  trunk native vlan 200

 

Access port

ddefault interface x/x

switchport mode access

switchport access vlan 200

switchport voice vlan 7

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards