cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

892
Views
0
Helpful
7
Replies
Highlighted
Beginner

Cisco 1141 WAP won't work with Auto Diagnostic tool

We just replaced our Cisco 1240 AP in one of our shops with a Cisco 1141 AP.  This is not controller based.

We use several wireless (infrastructure mode) auto diagnostic tools which connect to the AP.  We also have many laptops which run the diagnostic software.

We had no problems with our 1240AP.  With our 1141, we cannot connect to the wireless tools if both the laptop and the tools are connected to the 1141.  If I connect one to the 1240 and one to the 1141, they can see each other and work fine.  IF they are both connected to the 1141, they show up as connected in the AP, they can ping each other, but the software does not communicate. 

It is similiar to this:

https://supportforums.cisco.com/thread/2048621

However, none of his suggestions worked.

What do I need to do different so these connect?

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Cisco 1141 WAP won't work with Auto Diagnostic tool

Hi,

As per your exsisting configuration you dont need those command, so i was suggesting to remove them. I wasn't hoping that this will fix the issue :-)

As per your initial description when both devices are on 1141 AP's you are able to ping between the devices but the software doesn't communicate. Do you have any idea if this software uses multicast by any chance?

To address your problem, have you checked if igmp snopping is enable (by default it is enabled)? Please verify it with below command.

show ip igmp snooping

If it is enabled try disabling it with below command and verify the diagnostic tool if that works.

conf t

no ip igmp snooping

Regards

Najaf

Please rate when applicable or helpful !!!


7 REPLIES 7
Rising star

Cisco 1141 WAP won't work with Auto Diagnostic tool

Hi,

Could you please share both AP's running configurations?

Regards

Najaf

Beginner

Cisco 1141 WAP won't work with Auto Diagnostic tool

Here is the one for the 1141.  Currently the 1240 AP is at another location.

Current configuration : 2037 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname

!

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

!

aaa session-id common

!

!

no dot11 igmp snooping-helper

dot11 syslog

!

dot11 ssid Service

   authentication open

   authentication shared

   guest-mode

   no ids mfp client

!

dot11 ids mfp generator

!

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 40bit 7 120632578FCC transmit-key

encryption mode wep mandatory

!

ssid Service

!

channel 2447

station-role root

beacon period 20

no dot11 qos mode

infrastructure-client

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address

no ip route-cache

!

ip default-gateway

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/ea

ip radius source-interface BVI1

no cdp run

radius-server attribute 32 include-in-access-req format %h

radius-server vsa send accounting

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

Rising star

Cisco 1141 WAP won't work with Auto Diagnostic tool

Hi,

Is this the configuration which is not working? I dont see any ip address on BVI interface so just wondering how this is setup?

If this is the working configuration try disabling infrastructure-client under the radio with below command

confi t

int dot0

no infrastructure-client

also disable dot11 ids mfp generator globally with below command

config t

no dot11 ids mfp generator

Regards

Najaf 

Please rate when applicable or helpful !!!

Beginner

Cisco 1141 WAP won't work with Auto Diagnostic tool

This is the one that does not work.  I have removed the IP addresses for security purposes

Beginner

Cisco 1141 WAP won't work with Auto Diagnostic tool

Also, neither of those commands fixed the issue

Rising star

Cisco 1141 WAP won't work with Auto Diagnostic tool

Hi,

As per your exsisting configuration you dont need those command, so i was suggesting to remove them. I wasn't hoping that this will fix the issue :-)

As per your initial description when both devices are on 1141 AP's you are able to ping between the devices but the software doesn't communicate. Do you have any idea if this software uses multicast by any chance?

To address your problem, have you checked if igmp snopping is enable (by default it is enabled)? Please verify it with below command.

show ip igmp snooping

If it is enabled try disabling it with below command and verify the diagnostic tool if that works.

conf t

no ip igmp snooping

Regards

Najaf

Please rate when applicable or helpful !!!


Beginner

Cisco 1141 WAP won't work with Auto Diagnostic tool

This was the problem.  All working good now.  Thanks!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards