cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
699
Views
0
Helpful
10
Replies
Highlighted
Beginner

Cisco 1841 Setup (Totally Lost)

I've recently acquired a Cisco 1841 from a school that was upgrading their network. Although, I have a computing background, I am totally new to networking.

I can't seem to get this thing set up. I can't find a manual online, just a brochure and a few very specific guides here and there. I've managed to reset the router (I think) and enter the initial configuration, but I can't seem to be able to save the configuration or get any further. I can only access it with one of those blue console cables.

Basically what I want to do:

Configure FastEthernet0/0 to connect to a cable modem or other wan (like an apartment ethernet jack) that uses dhcp.

Configure FastEthernet0/1 to act as a router/gateway/dhcp server for a personal class c network.

Make it moderately secure for a home network, but nothing fancy.

If at all possible, I also want to do:

Configure port forwarding to a server on my network.

Configue Dynamic DNS.

I want to use the 1841 to replace a wrt54g as my home router and use the wrt54g as an access point.

I know it's annoying to be asked to explain this in layman's terms, but I don't know where else to turn. I appreciate any help.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner


It possibly could be that you have hard coded your speed and duplex on your WAN interface.

Try setting them back to auto.

Interface fa 0/1
Speed auto
Duplex auto



If you can't set this on both sides for the cable I would recommend that you leave it on auto/auto.

I'm not sure what your LAN interface connects to but unless it is hard coded on the other side you should change it back

You might have just gotten lucky that your Netgear router was able to negotiate the speed. But at the same time it might have defaulted to 10/half because it tried to negotiate but didn't hear anything from the other side.

Let me know how this works. If you need some help with basic CBAC firewall configuration let me know.

Elton



Sent from Cisco Technical Support iPhone App

View solution in original post

10 REPLIES 10
Highlighted
Enthusiast

Hello Alex,

There is a much more detailed configuration guide available at:

http://www.cisco.com/en/US/partner/docs/routers/access/1800/1801/software/configuration/guide/scg.html

It includes sections on setting up the DHCP server and your WAN connection.

Hopefully that will tell you what you need to know,

Christopher Ebert

Network Support Engineer - Cisco Small Business Support Center

Highlighted
Frequent Contributor

Highlighted
Beginner

Chris,

Please let us know how far you have got and I can help walk you through problems you are having.

Thanks, Elton



Sent from Cisco Technical Support iPhone App

Highlighted
Beginner

Actually, my config was good. For some reason the modem would not play nice with eachother. I connected a cheap netgear home router with a class c net to the modem, then switched my 1841 to class b before connecting it to the cheap router. I can get an internet connection now, but I had to put the netgear in between. Any ideas why?

Highlighted

Could you post your configuration? I have a feeling something isn't quite right and if it is I can hopefully lead you in the right direction. An 1841 router should connect to a modem just fine.

What kind of modem is it?

Elton

Sent from Cisco Technical Support iPhone App

Highlighted

Surfboard SB5101

[code]

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname STARDOCK

!

boot-start-marker

boot-end-marker

!

no logging console

enable secret 5 XXXXXXXXXXXXXXXXXXXXXX

enable password XXXXXXXXXXX

!

ip subnet-zero

no ip finger

ip dhcp excluded-address

192.168.1.1

192.168.1.10

!

ip dhcp pool SPACEDOCKDHCP

network

192.168.1.0

255.255.255.0

default-router

192.168.1.1

dns-server

8.8.8.8

8.8.4.4

4.2.2.66

!

!

!

username XXXXXXXXX privilege 15 password 0 XXXXXXXXX

archive

log config

hidekeys

!

!

interface FastEthernet0/1

description WANPORT

ip address dhcp

ip nat outside

speed 100

full-duplex

!

interface FastEthernet0/0

description LANPORT

ip address

192.168.1.1

255.255.255.0

ip nat inside

speed 100

full-duplex

!

interface Serial0/0/0

no ip address

no ip route-cache

shutdown

no fair-queue

!

!

ip nat inside source list 1 interface FastEthernet0/1 overload

ip classless

ip http server

ip http authentication local

ip http secure-server

!

access-list 1 permit

192.168.1.0

0.0.0.255

!

!

line con 0

line aux 0

line vty 0 4

password XXXXXXXXXX

login

!

end

[/code]

Highlighted
Beginner


It possibly could be that you have hard coded your speed and duplex on your WAN interface.

Try setting them back to auto.

Interface fa 0/1
Speed auto
Duplex auto



If you can't set this on both sides for the cable I would recommend that you leave it on auto/auto.

I'm not sure what your LAN interface connects to but unless it is hard coded on the other side you should change it back

You might have just gotten lucky that your Netgear router was able to negotiate the speed. But at the same time it might have defaulted to 10/half because it tried to negotiate but didn't hear anything from the other side.

Let me know how this works. If you need some help with basic CBAC firewall configuration let me know.

Elton



Sent from Cisco Technical Support iPhone App

View solution in original post

Highlighted

I have since moved to my dorm so I'm using their wan. I had the same problem until I just tried what you showed me. Works fine now thanks. I think I will hold off a while on a firewall. My only concern is keeping school personel out. Housing posseses a key, and my router has been tampered with before. I need to get my other switches wotking first.

Highlighted

I would recommend that you add local authentication to your console port. Similar to what you did on the VTY lines for telnet access.

Another recommendation I can make for this is to create an access list for your VTY lines only allowing access from your local LAN. This way you can only relent to the router from your local LAN and someone from the outside, on the campus WAN couldn't connect to the router.

Currently anyone with a console cable could come and plug into the router and have access to it.

Let me know of you need help with this

Elton

Sent from Cisco Technical Support iPhone App

Highlighted

I think I can figure it out. Thank you for your help.

Content for Community-Ad