cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
429
Views
0
Helpful
7
Replies
Pratik Prajapati
Beginner

Cisco 1941 router and SMB SG500 configuration issue

Hi,

I am trying to configure a Cisco 1941 router with SMB SG500 switch. Configuration is fairly simple. I am using 802.1q subinterfaces on the router with vlans 1 and 10. VLAN 10 is voice vlan. Below is the config for both router and switch. I cannot get the phone to get an IP address via DHCP from the router. Not sure what I am missing. Please help!

Current configuration : 1507 bytes
!
! Last configuration change at 14:35:11 UTC Mon Jul 14 2014
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname GW_RTR_MAIN
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$wB.Y$xqn1Dm294oQ8BOS5QZlAU0
!
no aaa new-model
!
ip cef
!
!
!
!
ip dhcp pool VOICE
 network 10.1.10.0 255.255.255.0
 default-router 10.1.10.1
 dns-server 8.8.8.8 8.8.4.4
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941/K9 sn FTX182482GA
!
!
!
redundancy
!
!
!
!

!
!
!
!
!
interface Loopback0
 ip address 199.199.199.199 255.255.255.255
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.5
 description USER VLAN
 encapsulation dot1Q 1 native
 ip address 10.1.5.1 255.255.255.0
!
interface GigabitEthernet0/1.10
 description VOICE VLAN
 encapsulation dot1Q 10
 ip address 10.1.10.1 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server

 

SWITCH CONFIG is in the attached screenshots.

The router is connected on port 24 of the switch.

Thanks.

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions

In the last picture you uploaded (capture.png), vlan 10 is listed as forbidden on port 24. Is it supposed to be like that? I think it should say tagged or allowed. Check the configuration of that port.

HTH.

Regards,

RS.

View solution in original post

Emmanuel Valdez
Participant

Hi,

On switch port 24 you have to tag the VLAN id, so change you settings from forbidden to tag like the other ports, when you connect the ip phone to the port it assigned the VLAN 10 and it is tagged for that reason the IP phone doesn´t acquired IP address.

If it was useful please rate.

Regards.

View solution in original post

7 REPLIES 7
Rajeev Sharma
Cisco Employee

Hey,

Try configuring service dhcp on router.

HTH.

Regards,

RS.

DHCP is configured on the router

In the last picture you uploaded (capture.png), vlan 10 is listed as forbidden on port 24. Is it supposed to be like that? I think it should say tagged or allowed. Check the configuration of that port.

HTH.

Regards,

RS.

View solution in original post

That did the trick! Actually I had port 24 excluded because I was following the below article. and i knew something was wrong with it since it didnt make sense to me either. 

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-switches/885-cisco-switches-sg500-52p.html

Thanks.

:)

Regards,

RS.

So I changed the Data VLAN to VLAN 5 on interface g0/1.5 and entered the command "encapsulation dot1q 5 native" Now again the phone doesnt get the IP address. I untagged all VLAN 5 traffic on the switch. But nothing worked. What am I missing?

Emmanuel Valdez
Participant

Hi,

On switch port 24 you have to tag the VLAN id, so change you settings from forbidden to tag like the other ports, when you connect the ip phone to the port it assigned the VLAN 10 and it is tagged for that reason the IP phone doesn´t acquired IP address.

If it was useful please rate.

Regards.

View solution in original post