cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1317
Views
0
Helpful
0
Replies
curtiscline01
Beginner

Cisco 1941 router, dual internet connections, issue with failover internet connection taking over. Need HELP!

Cisco 1941 router, dual internet connections, issue with failover internet connection taking over.

If I remove "ip nat inside source route-map ISP1-NAT interface GigabitEthernet0/0 overload "  my backup internet connection on G0/1 comes right up.  When I pull the Primary "ISP1" connection, my ip route statement is removed and my backup ip route appears.

I've tried several different configurations based on examples on-line but none of them seem to work.

Here are parts of the config, any help would be appriciated.


!
interface GigabitEthernet0/0
description Primary 5MB Ethernet Handoff$ETH-WAN$$FW_OUTSIDE$
bandwidth 40960
ip address 209.XX.XXX.XX4 255.255.255.248
ip access-group 100 in
ip nat outside
ip virtual-reassembly in
zone-member security out-zone
duplex full
speed auto
!
interface GigabitEthernet0/1
description Backup-ComCast$FW_OUTSIDE$
ip address 216.XX.XX.XX6 255.255.255.248
ip nat outside
ip virtual-reassembly in
zone-member security out-zone
duplex full
speed auto
!
ip nat inside source route-map ISP1-NAT interface GigabitEthernet0/0 overload
ip nat inside source route-map ISP2-NAT interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 209.XX.XXX.XX3 track 1
ip route 0.0.0.0 0.0.0.0 216.XX.XX.XX5 200
!
!
ip sla 1
icmp-echo 216.XX.XX.XX6 source-interface GigabitEthernet0/0
threshold 300
timeout 500
frequency 5
ip sla schedule 1 life forever start-time now

access-list 10 remark outside access
access-list 10 permit 192.168.2.0 0.0.0.255
access-list 10 permit 192.168.10.0 0.0.0.255
access-list 10 permit 10.10.11.0 0.0.0.255
access-list 10 permit 192.168.12.0 0.0.0.255
access-list 10 permit 192.168.13.0 0.0.0.255
access-list 11 remark outside access
access-list 11 permit 192.168.2.0 0.0.0.255
access-list 11 permit 192.168.10.0 0.0.0.255
access-list 11 permit 10.10.11.0 0.0.0.255
access-list 11 permit 192.168.12.0 0.0.0.255
access-list 11 permit 192.168.13.0 0.0.0.255
!
!

route-map ISP1-NAT permit 10
match ip address 10
set interface GigabitEthernet0/0
!
route-map ISP2-NAT permit 11
match ip address 11
match interface GigabitEthernet0/1
!

track 1 ip sla 1 reachability

thank you

0 REPLIES 0