cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

205
Views
5
Helpful
15
Replies
Highlighted

Cisco 2801 Router Interface Up; Line Protocol Down

I have two 2801 routers, when I connect them with a CAT-5 cable to each other, then show  up / down.  When I connect them to a switch, it shows up/up.  Everything is set to auto on the interfaces.  I have read some of the posts about nothing being plugged into the ports, but I have a Router connected to Router with a DTE/DCE cable and FastEthernet cable into F0/0.  Has anyone seen this before?

 

Thank You for any help

1 ACCEPTED SOLUTION

Accepted Solutions
Rising star

Re: Cisco 2801 Router Interface Up; Line Protocol Down

OK, so you are saying you have the EXACT same setup with multiple pairs of 2801 routers?  You are linking the FE0/0 interfaces together using a standard 10/100BaseT cross-over cable (1&2 to 3&6) and this is the only pair that don't get a connection?  Swap the cable with one that works between two other 2801 routers.  If that doesn't work and its the same configuration then I suspect there is something physically broken.  Sounds very odd though?


@RichardBurrows6005 wrote:

Listen, I am not trying to Wind people up.  We have over 14 routers and switches that we have up and running.  This is the only set that has this issue.  We put everything the same.  I know we need a crossover to work on the Routers.  As you can see in the Configs, everything is up and turned on.  We are not getting any link lights on the Routers when we connect them.  Line Protocol is not coming up as you can see on the Serial Interfaces.  We have all the correct cables plugged in.  Once we swap out the cables and plug in to the switch, they light up.  Does that make since?


 

15 REPLIES 15
Beginner

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Hi,

Im a little confused, at the very beginning you saying that you connected routers to each other with cat5 cable but at the end you talking about routers are conected via DTE/DCE cable?

If up/down is for DTE/DCE cable did you set a clock rate on both ends to the same?
If up/down is for cat5 cable is it crossover cable? Is speed and duplex set to auto? Are you sure you connecting both ends of the cable to correct interfaces?

Re: Cisco 2801 Router Interface Up; Line Protocol Down

There is two connections on the Router that are being used.  One is HWIC2T with a serial interface and one is F0/0 on the router. So both routers are connected by one Serial Interface and FastEhternet Connection. Both Speed and Duplex are set to auto.  The connections are going from S0/0/0 to S0/0/0 and F0/0 to F0/0.

VIP Advisor

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Can you post the output and confifuration of the inteface.

 

BB
*** Rate All Helpful Responses ***

Re: Cisco 2801 Router Interface Up; Line Protocol Down

BB,

 

I will once I return back to work and pull those configs from each router.

VIP Expert

Re: Cisco 2801 Router Interface Up; Line Protocol Down

I don't recall the 2801 supporting auto-MDI on its Ethernet port. Without it, for router-to-router Ethernet you'll need a cross-over cable.

As to it working when you connect a router's Ethernet port to a switch's Ethernet port, that normally should work with a straight through cable (or the switch might support auto-MDI, which would allow it to work with either kind of Ethernet cable).

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Hey Joseph,

 

For some reason, the Routers I am working on to work with both types.  Unless for some reason someone went in and disabled Auto Sensing on the router itself.

Rising star

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Auto speed and duplex are different to Auto-MDIX.  Google is your friend here...

I think Joseph is correct in that the 2801's Ethernet interfaces do not support Auto-MDIX so directly connecting two of these together via Ethernet will require a 10/100Mbps Ethernet cross-over cable.

Hall of Fame Community Legend

Re: Cisco 2801 Router Interface Up; Line Protocol Down

The only time I saw an output like that the router link was undergoing a BER test and the link was put into a "loop" by the carrier.

Re: Cisco 2801 Router Interface Up; Line Protocol Down

So here are my Configs from each router.  They both are showing the same issue.

 

Router9#show run
Building configuration...


Current configuration : 1502 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router9
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$lTA8$iXX3Y/9pOTW2aj0gqcfWd.
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated

!
voice-card 0
!
archive
log config
hidekeys
!
!
!
interface FastEthernet0/0
escription Connection to Router10
ip address 178.16.0.33 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description Connection to S9
ip address 192.148.0.17 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
description Connection to Router8
ip address 5.2.6.34 255.255.255.252
encapsulation ppp
clock rate 125000
!
interface Serial0/0/1
description Connection to Router10
ip address 5.2.6.37 255.255.255.252
encapsulation ppp
clock rate 125000
!
router ospf 100
log-adjacency-changes
 network 5.2.6.36 0.0.0.3 area 0
network 5.2.6.40 0.0.0.3 area 0
network 172.16.0.0 0.0.0.255 area 0
network 192.148.0.32 0.0.0.31 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
banner motd ^CNot^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password navy
login
line vty 5 15
password navy
login
!
scheduler allocate 20000 1000
end

 

Here is the Interface Brief from that same Router

Router9#sho ip int bri
Interface IP-Address                  OK? Method Status Protocol
FastEthernet0/0 172.18.0.32     YES manual        up down
FastEthernet0/1 192.148.0.17    YES manual       up up
Serial0/0/0 5.2.6.34                   YES manual       up up
Serial0/0/1 5.2.6.37                   YES manual       down down

 

Here is the Other Router

Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 19-Jun-09 15:13 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Rupert10 uptime is 1 week, 1 hour, 35 minutes
System returned to ROM by reload at 14:18:55 UTC Tue Jul 16 2019
System image file is "flash:c2800nm-adventerprisek9-mz.124-24.T1.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2811 (revision 53.50) with 249856K/12288K bytes of memory.
Processor board ID FTX1140A12S
2 FastEthernet interfaces
2 Serial(sync/async) interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Rupert10#show run
Building configuration...


Current configuration : 1598 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rupert10
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$KoeQ$Rlry8JUbd6mxhtVuGs5xl0
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
voice-card 0
!
!
!
!
!
archive
log config
hidekeys
!
!
!
interface FastEthernet0/0
description Connection to Router9
ip address 178.16.0.33 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description Connection to Switch
ip address 192.148.0.33 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0/0
description Connection to Router11
ip address 5.2.6.41 255.255.255.252
encapsulation ppp
clock rate 2000000
!
interface Serial0/0/1
description Connection to Router9
ip address 5.2.6.38 255.255.255.252
encapsulation ppp
!
router ospf 100
log-adjacency-changes
network 5.2.6.36 0.0.0.3 area 0
network 5.2.6.40 0.0.0.3 area 0
network 172.16.0.0 0.0.0.255 area 0
network 192.148.0.32 0.0.0.31 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
!
!
banner motd ^CConfig by Brimberry^C
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password navy
login
line vty 5 15
password navy
login
!
scheduler allocate 20000 1000
end

Rupert10#

Rupert10#sh ip int bri
Interface IP-Address                  OK? Method Status Protocol
FastEthernet0/0 178.16.0.33      YES manual      up down
FastEthernet0/1 192.148.0.33    YES manual      up down
Serial0/0/0 5.2.6.41                   YES manual      down down
Serial0/0/1 5.2.6.38                   YES manual      up up
Rupert10#

Rising star

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Your editing of the configurations didn't quite work as they both have the same IPv4 address on FE0/0 - 178.16.0.33/24?

 

https://en.wikipedia.org/wiki/Ethernet_crossover_cable

 

 

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Good point,  The top one was suppose to be .32/24 and bottom .33/24,  had both up and swapping back and forth on the notepad.  In the router itself they are correct. As you can see I have an IP address in both routers and Line Protocol shows its down with a cable plugged in.  Now if I take that same cable, and plug it into a switch, the ports come up.  Does not make any since to us.

Rising star

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Please read the replies or are you trying to wind people up?

Connecting the two routers together with Ethernet requires an Ethernet cross-over cable - DTE-to-DTE.  The 2801 does not support Auto-MDIX so cannot cross the pairs automatically.  You need to cross the transmit & receive pairs over in the cable.  A straight cable WILL NOT WORK...

Re: Cisco 2801 Router Interface Up; Line Protocol Down

Listen, I am not trying to Wind people up.  We have over 14 routers and switches that we have up and running.  This is the only set that has this issue.  We put everything the same.  I know we need a corssover to work on the Routers.  As you can see in the Configs, everything is up and turned on.  We are not getting any link lights on the Routers when we connect them.  Line Protocol is not coming up as you can see on the Serial Interfaces.  We have all the correct cables plugged in.  Once we swap out the cables and plug in to the switch, they light up.  Does that make since?

Rising star

Re: Cisco 2801 Router Interface Up; Line Protocol Down

OK, so you are saying you have the EXACT same setup with multiple pairs of 2801 routers?  You are linking the FE0/0 interfaces together using a standard 10/100BaseT cross-over cable (1&2 to 3&6) and this is the only pair that don't get a connection?  Swap the cable with one that works between two other 2801 routers.  If that doesn't work and its the same configuration then I suspect there is something physically broken.  Sounds very odd though?


@RichardBurrows6005 wrote:

Listen, I am not trying to Wind people up.  We have over 14 routers and switches that we have up and running.  This is the only set that has this issue.  We put everything the same.  I know we need a crossover to work on the Routers.  As you can see in the Configs, everything is up and turned on.  We are not getting any link lights on the Routers when we connect them.  Line Protocol is not coming up as you can see on the Serial Interfaces.  We have all the correct cables plugged in.  Once we swap out the cables and plug in to the switch, they light up.  Does that make since?


 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards