cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
535
Views
0
Helpful
9
Replies

Cisco 2960 Switch Not sending traffic

Hi Guys , 

 

we have hosted some of our applications in  multiple servers and these servers are connected to 2 switches .

These 2 switches are having a connection with a router . These 2 switches are configured as active and standby for these Servers . But we have observed that most of the traffic is coming from Switch 2 . Could you please guide that how we can configure these devices so traffic should be load balanced from both switches .

 

Regards ,

Muddy.

9 REPLIES 9
VIP Engager

Re: Cisco 2960 Switch Not sending traffic

Hi,

How to configured switches in the Active passive mode? which protocol or technology has applied? 

 

Regards,

Deepak Kumar 

Regards,
Deepak Kumar,
Resume duty after a long holiday
Highlighted

Re: Cisco 2960 Switch Not sending traffic

Hi Deepak , 

 

There is no stacking done for these 2 switches , same level of vlan and port configuration is done for both switches . 

 

Regards ,

Muddy.

VIP Engager

Re: Cisco 2960 Switch Not sending traffic

HI,

There is no Stack so I am looking that you have configured Interface teaming on the server as Switch-Unware. So this is normal behaviour.

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Resume duty after a long holiday
VIP Advisor

Re: Cisco 2960 Switch Not sending traffic

HI there,

From your description it sounds like your servers have a pair of NICs in active/ standby configuration.

 

Are the pair of 2960 switches stacked  together. If not you are stuck with this topology.

If they are in a stack together, then you should configure an etherchanel between the switches to the two server NICs. You should also configure the etherchannel load balancing algorithm to use src-dst-ip and not MAC address.

 

Please share you switch config and a brief topology diagram showing switch/server connections if you need further detail.

 

Cheers,

Seb.

Re: Cisco 2960 Switch Not sending traffic

Hi Seb , 

 

Thanks a lot for your reply , please find the attached switches configuration .

 

Regards ,

Muddy

Beginner

Re: Cisco 2960 Switch Not sending traffic

You'd have to stack or load balance naturally with the placement of servers to equal out the traffic. Unfortunately, I do not believe there is much more you can do in this situation. 

 

 

VIP Advisor

Re: Cisco 2960 Switch Not sending traffic

Since your switches are not stacked a port-channel connected to both switches is not an option. This would be the ideal solution and you should look into it.

 

If you have more than two servers and want to distribute the traffic, you could make the second servers secondary NIC its Active interface. This would at least send all of its traffic via the second switch.

 

cheers,

Seb.

Beginner

Re: Cisco 2960 Switch Not sending traffic

A diagram may be useful for this situation, one of the ways I would do this is by working out the average traffic on each server, then connect them to each switch so it load balances naturally with the servers connected to each one. This means it is as simple as possible, with as little configuration. 

 

 

We also do this technique with IP addresses to naturally load balance them in the CORE for BGP, the way you do it is splitting the IP's depending on how many exits, so if you had a /24, for example, you'd half it into two /25's and assign a server to one range and then another server to the alternative range, this way you don't need any complicated configuration but just simply a design load balancing solution. 

 

 

VIP Mentor

Re: Cisco 2960 Switch Not sending traffic

Hello,

 

on a side note, if you have two switches, you could make one switch the primary root for one half of your VLANs, ane the other switch the primary root for the other half. If you do that, just make sure all configured VLANs are allowed on all interconnecting trunks...

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards