cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
409
Views
0
Helpful
5
Replies

Cisco 2960 switch ports flapping

This is the log and the config of the interface:

 

Interface 47 & 48 connected to a MERAKI MR24

 

Jun 24 08:51:46.547 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 08:51:47.546 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 08:51:50.231 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 08:51:51.237 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 09:59:55.553 GMT: %ILPOWER-3-CONTROLLER_PORT_ERR: Controller port error, Interface Gi1/0/48: Power Controller reports power Imax error detected
.Jun 24 09:59:56.794 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 09:59:57.800 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 10:00:07.958 GMT: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/48: Power granted
.Jun 24 10:00:12.317 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 10:00:13.316 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 10:00:28.636 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 10:00:29.640 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 10:00:32.279 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 10:00:33.282 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 10:04:34.743 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 48c7.96b2.c129 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 10:06:15.232 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 1c4d.702f.7164 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 10:09:57.591 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 9c2e.a1f9.9b5d in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/49
.Jun 24 10:10:40.979 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/47 and port Gi1/0/48
.Jun 24 10:25:26.416 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/47 and port Gi1/0/48
.Jun 24 10:35:52.404 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host d4c9.4bae.01bc in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48
.Jun 24 10:39:47.944 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host e4a4.71df.97ba in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 10:42:04.810 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/47 and port Gi1/0/48
.Jun 24 10:43:21.463 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host d4c9.4bae.01bc in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48
.Jun 24 11:59:42.766 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 11:59:43.770 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 11:59:46.489 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 11:59:47.489 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 12:15:29.995 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host b863.4d49.b94c in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48
.Jun 24 12:17:13.878 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host fc42.0388.eee5 in vlan 16 is flapping between port Gi1/0/47 and port Gi1/0/48
.Jun 24 12:25:56.308 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 2c0e.3dec.17c8 in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/47
.Jun 24 12:30:40.364 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host fc42.0388.eee5 in vlan 16 is flapping between port Gi1/0/47 and port Gi1/0/48
.Jun 24 12:54:59.153 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/47, changed state to down
.Jun 24 12:55:00.159 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/47, changed state to down
.Jun 24 12:55:02.875 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/47, changed state to up
.Jun 24 12:55:03.875 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/47, changed state to up
.Jun 24 13:01:19.664 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 48c7.96b2.c129 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 13:01:57.707 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 13:54:03.277 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 7840.e48d.35fd in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 14:30:20.402 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 9c2e.a1f9.9b5d in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/49
.Jun 24 15:33:55.548 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 15:33:56.551 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to down
.Jun 24 15:33:59.229 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 15:34:00.228 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to up
.Jun 24 16:48:54.458 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/47 and port Gi1/0/48
.Jun 24 16:50:05.872 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 8058.f861.5695 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/49
.Jun 24 17:15:05.798 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 17:20:42.721 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host bc98.dfa4.11ea in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48
.Jun 24 17:31:14.327 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 9ce3.3fca.0f81 in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48
.Jun 24 17:31:48.204 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48
.Jun 24 18:00:57.920 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 68c4.4d52.53bb in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 18:11:42.169 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 9ce3.3fca.0f81 in vlan 16 is flapping between port Gi1/0/47 and port Gi1/0/49
.Jun 25 10:36:13.260 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 48c7.96b2.c129 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 25 10:55:23.951 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to down
.Jun 25 10:55:24.957 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to down
.Jun 25 10:55:27.673 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/48, changed state to up
.Jun 25 10:55:28.677 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/48, changed state to up
.Jun 25 10:56:34.963 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/47, changed state to down
.Jun 25 10:56:35.970 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/47, changed state to down
.Jun 25 10:56:38.647 GMT: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/47, changed state to up
.Jun 25 10:56:39.650 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/47, changed state to up
.Jun 25 11:03:52.770 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host c81e.e7c2.0632 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 25 11:14:55.838 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 74e5.4325.1b9c in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48
.Jun 25 11:14:58.316 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 1c4d.702f.717d in vlan 16 is flapping between port Gi1/0/49 and port Gi1/0/48

----------------------------------------------------------------------

interface GigabitEthernet1/0/48
description AR/LIMA/Piso-11/V16/MerakiP11.2/Lado Centro
switchport access vlan 16
switchport mode access
spanning-tree portfast edge
end

--------------------------------------------------

interface GigabitEthernet1/0/47
description AR/LIMA/Piso-11/V16/MerakiP11/Lado Frente
switchport access vlan 16
switchport mode access
spanning-tree portfast edge
end

 

 

 

5 REPLIES 5
Rising star

Re: Cisco 2960 switch ports flapping

Nicolas,

 

Usually the flapping MAC address is an indication of a network loop. Can you please show what CDP neighbours you observe on the switch in question. 

VIP Mentor

Re: Cisco 2960 switch ports flapping

Hi
Just to add it can also be users connecting over wifi aps , then getting up and moving to another part of the building , and connecting again , same MAC is seen at 2 different switchports and already in the CAM table so switch logs a MAC flap notification

if you think you have loops this will show it , wher an how frequent
show spanning-tree detail | inc ieee|occurr|from|is exec

The switch is also telling you whatever is connected to that port is drawing more than allowed power which could also be the issue --- Controller port error, Interface Gi1/0/48: Power Controller reports power Imax error detected
Theres also known bugs for this alert but i would confirm what POE type there using , if its af or at and if the switch supports it

Re: Cisco 2960 switch ports flapping

AR-LI-UA-12-1#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
00180a26bf7a Gig 1/0/47 165 R S Meraki MR Port 0
AR-LI-CORE-1.xxxxx.com
Gig 1/0/49 137 R S I WS-C4506- Gig 3/1
00180a26c70c Gig 1/0/48 169 R S Meraki MR Port 0

 

Hall of Fame Expert

Re: Cisco 2960 switch ports flapping

Hello Nicolas,

interface descriptions for ports gi1/0/47 and gi1/0/48 say that you have connected two Meraki devices to them.

Are those Meraki devices acting as switches ?

Are the two Meraki devices connected between themselves ?

This would explain all the messages like

Jun 24 10:04:34.743 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 48c7.96b2.c129 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47
.Jun 24 10:06:15.232 GMT: %SW_MATM-4-MACFLAP_NOTIF: Host 1c4d.702f.7164 in vlan 16 is flapping between port Gi1/0/48 and port Gi1/0/47

 

These messages are caused by interface link state change the meraki will move traffic to the other available uplink port.

I would remove the following command

spanning-tree portfast edge

 

Because if the Meraki are switches and are also connected between them you are in the risk of creating bridging loop using portfast.

 

You can check if you can run Rapid PVST on the Meraki, but the logs provide evidence that the Meraki devices are also connected between them or have hosts dual homed to them.

 

Edit:

if the Meraki is a single device you should use a port channel to bundle interfaces gi1/0/47 and gi1/0/48 in addition to removing the portfast feature.

 

Edit2:

if the Meraki devices are access points follow the wise suggestions made by Mark. I missed the error about POE. So they are likely APs and not switches.

 

 

 

Hope to the help

Giuseppe

 

 

Highlighted
VIP Advisor

Re: Cisco 2960 switch ports flapping

The mac flapping is not happening that fast.  You have two APs.  So I think it as simple as you have some devices roaming between the APs.

 

Also it looks like the 2960 might be struggling to supply enough PoE power.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards