cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
340
Views
10
Helpful
6
Replies
rizkypahlevips
Beginner

Cisco 2960+ switches wont accept PoE device

Hello Community,

I have a problem regarding one of my device, in this case the Cisco 2960 Plus switch 48 port.  some of the ports on my switch randomly not accepting PoE, but when it comes to a non-PoE device (such as switches and laptops) the ports works normally. i've checked the power inline, but the power inline is still have sufficient power to run the PoE Device, when i check the interface with sh interface, it said notconnect. the port which have this problem is random. the configuration running in the ports is only switchport access vlan, bpdu guard enabled, and limit the power inline, which i've made sure the power was sufficient on the port to run PoE device. currently using 15.2 OS. i have a total of 40 switches running the same configuration (except the IP addresses) and the same OS, but only 1 which have this problem 

any advice on this problem?

6 REPLIES 6
Leo Laohoo
VIP Community Legend

Post the complete output to the following command: 

sh power inline <PORT>

here's the show power inline log, attached below

pieterh
VIP Collaborator

what kind of PoE devices are involved?
if you move the same device between different ports it "randomly" works or does not work?
-> check the logs, does it repeatedly show "powered device connected/removed" ?
It may be that on connect the device draws a larger current on power-up that needed in operation

the 2960 has a electronic safety circuit that shuts down the port when drawn power is too large
and tries to recover after a timeout, hence the repeated logs
our vendor of well-known professional IP-camera's investigated the issue we had, and concluded 
both behavior of the camera and the switch are not conflicting with the "standard" but result in an incompatibility

 

 

yes, when i moved the device to a working port, it worked, but when i switched the worked device to that "random" port, its not working.

and yes, the log said "PD Connected / PD removed", i have tried to set the power to limit the consumption accordingly to the device's needs but still not works, even i have set the power inline to auto again, but still not works

Post the complete output to the following commands: 

sh version
sh post
Leo Laohoo
VIP Community Legend

2960+ is a "FastEthernet" switch.  TDR will not work because this particular model will never test Pair "C", the PoE pair. 

My guess is Pair "C" is OPEN.