cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
304
Views
0
Helpful
5
Replies
Highlighted
Beginner

[Cisco 2960L-SM - Trunk Port Issues]

Hi!

 

I have configured a WS-C2960L-SM-48TS switch with multiple VLANs which are working fine.

Another switch which serves VLANs 10,40,50 has been connected to the 2960L switch on interface Gi0/46.

Interface Gi0/46 has been set as Trunk and VLANs 10,40,50 allowed with native VLAN set as 10.

When testing, only VLAN 10 traffic is working.

Traffic for VLANs 40 and 50 are not going through

 

Refer to below config and attachment.

 

!
interface GigabitEthernet0/46
switchport trunk allowed vlan 10,40,50
switchport mode trunk
spanning-tree portfast edge
ip dhcp snooping trust
!

 

 

5 REPLIES 5
Highlighted
VIP Mentor

Re: [Cisco 2960L-SM - Trunk Port Issues]

Hello,

 

--> Interface Gi0/46 has been set as Trunk and VLANs 10,40,50 allowed with native VLAN set as 10.

 

I don't see Vlan 10 as being set as the native Vlan on your trunk. If you need that, the config should be:

 

interface GigabitEthernet0/46
switchport trunk allowed vlan 10,40,50
switchport mode trunk

switchport trunk native vlan 10
spanning-tree portfast edge
ip dhcp snooping trust

 

That said, what is the configuration of the switchport on the other switch ?

Highlighted
Beginner

Re: [Cisco 2960L-SM - Trunk Port Issues]

Hi!

 

The other switch is a Netgear.

I have configured the uplink port 24 as follows:

VLAN 10 - Tagged

VLAN 40 - Tagged

VLAN 50 - Tagged

 

Please advise whether the above configuration is ok for the uplink from Netgear to Cisco switch

Highlighted
Contributor

Re: [Cisco 2960L-SM - Trunk Port Issues]

Hello, please show “show vlan”, and “show int trunk” from both switches.
--------------------------------------------------------------------------

Helping seriously ill children, all together. All information about this, is posted on my blog
Highlighted
Beginner

Re: [Cisco 2960L-SM - Trunk Port Issues]

Hi Oleg,

Can you perhaps send both the switches' interface configs...

 

We cannot troubleshoot with only half the info...

 

Ciao

JC

Highlighted

Re: [Cisco 2960L-SM - Trunk Port Issues]

You can configure the other interface same as the interface you configured 

Or

Configure the interface to allow all vlans

( Switchport allowed vlan all )

CreatePlease to create content
Content for Community-Ad