cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

683
Views
0
Helpful
2
Replies
Highlighted

Cisco 2960s Stack High availability issue

Hi All,

Recently we have deployed 2 2960s series switches with flexstack module, and configured as:

1) company-sw1#sh switch neighbors

  Switch #    Port 1       Port 2

  --------         -----          ------

      1            2              2 

      2            1              1

2)company-sw1#  sh switch

Switch/Stack Mac Address : 2401.c7ef.1300

Mac persistency wait time: Indefinite

                                           H/W   Current

Switch#  Role   Mac Address      Priority Version  State

---------------------------------------------------------------------------------

*1       Master  2401.c7ef.1300      14         1         Ready              

2       Member 2401.c7e5.7a00     2          1         Ready              

3       Member 0000.0000.0000     0          1         Provisioned

3) company-sw1# sh run

stack-mac persistent timer 0

interface Port-channel1

switchport mode access

!        

interface Port-channel2

switchport mode access

interface GigabitEthernet1/0/1

switchport mode access

spanning-tree portfast

channel-protocol lacp

channel-group 1 mode active

!        

interface GigabitEthernet1/0/2

switchport mode access

spanning-tree portfast

channel-protocol lacp

channel-group 2 mode active

interface GigabitEthernet2/0/1

switchport mode access

spanning-tree portfast

channel-protocol lacp

channel-group 1 mode active

!        

interface GigabitEthernet2/0/2

switchport mode access

spanning-tree portfast

channel-protocol lacp

channel-group 2 mode active

!        

AT the server side , we have configured teeming (bond) of eth0 and eth1 with 802.3ad protocol support for both the servers, teaming is working fine.

And started the ping from one server to other ,

1. And if i poweroff  the Master switch , there is no issue (no dropages in the icmp request/reply or Tcp ).

2. Even though  the Master switch comes back, the  member becomes Master , and stays as it is until the new master restarts.

3. But if i powerof the the new Master which is using the persistent mac of old master switch, i lose the atleast 3 icmp packet.

Pls reply....

Regards,

Ashraf

Everyone's tags (6)
2 REPLIES 2
VIP Expert

Cisco 2960s Stack High availability issue

Hi Ashraf,

With Portchannel, you loose what is already in the wire when you tun off the master or member.  If for example the server is using interface 2/0/2, you are not going to see any packet drops, because the packet is traversing the member switch. Now if the server using port 1/0/1, when you shut down the master, you will see a 1, 2 or 3 packet drops and that is what is in the wire.

If you want to know what port the switch is using to forward packet at any time use this command:

test etherchannel load-balance interface port-channel xx mac .......

HTH

Cisco 2960s Stack High availability issue

Many Thanks Reza,

i hve few quick questions.

1. Can we improve this process of portchannel with some configuration , so that i will not loose those 1,2 or 3 packet drops, is it possible....

2. Will there be any difference if i connect the Stack in Cisco 2960s , as port1 of switch1 to port 1 of switch2 and  port2 of switch1 to port2 of switch2  OR  port1 of switch1 to port2 of switch2 and port2 of switch1 to port1 of switch2.

Regards,

Ashraf

CreatePlease to create content
Content for Community-Ad