cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1510
Views
10
Helpful
22
Replies
vb543
Beginner

Cisco 3560G Slow Performance

I've been having some performance issues with one of my Cisco switches for a while now. I originally posted on Reddit seeking some help. Now that the issue continues, I wanted to see if anyone had some ideas over here.

I'm using a Cisco 3560G to handle some basic vlans/routing for a rack of servers. The switch has a gigabit uplink and I've recently only been getting a few MBps from external tests to various local servers as well as internally between systems across vlans.

My original configuration had a lot of secondary addresses on various vlans, after discovering that this wasn't best practice - I've offloaded a lot of the addressing for each vlan to a small ER-X. Unfortunately, that hasn't fully corrected the issue.

Here's my current config: https://pastebin.com/raw/dYaZ6q22

Any thoughts/advice would be appreciated!

22 REPLIES 22
Georg Pauwen
VIP Expert

Hello,

 

just a few things I can think of:

 

You don't need the default-gateway, since you already have ip routing enabled and a default route. So remove this line:

 

--> no ip default-gateway 124.124.124.241

 

Also, check if CEF is enabled. 

 

Switch1(config)#ip cef

 

The access ports are typically configured with 'spanning-tree portfast', you might want to add this:

 

interface GigabitEthernet0/3
switchport access vlan 542
switchport mode access

spanning-tree portfast

Regarding STP, beside portfast on access ports, you should configure rapid PVST on all switches in domain.

spanning-tree mode rapid-pvst

 

According to configuration - summarize all routes since next hop is the same address:

ip route 123.123.123.16 255.255.255.248 124.124.124.244
ip route 123.123.123.24 255.255.255.248 124.124.124.244
ip route 123.123.123.32 255.255.255.224 124.124.124.244
ip route 123.123.123.42 255.255.255.255 Null0
ip route 123.123.123.64 255.255.255.224 124.124.124.244
ip route 123.123.123.96 255.255.255.248 124.124.124.244
ip route 123.123.123.104 255.255.255.248 124.124.124.244
ip route 123.123.123.112 255.255.255.248 124.124.124.244
ip route 123.123.123.120 255.255.255.248 124.124.124.244
ip route 123.123.123.128 255.255.255.248 124.124.124.244
ip route 123.123.123.136 255.255.255.248 124.124.124.244
ip route 123.123.123.144 255.255.255.248 124.124.124.244
ip route 123.123.123.160 255.255.255.224 124.124.124.244
ip route 123.123.123.192 255.255.255.248 124.124.124.244
ip route 123.123.123.200 255.255.255.248 124.124.124.244
ip route 125.125.125.16 255.255.255.240 124.124.124.244
ip route 125.125.125.32 255.255.255.248 124.124.124.244
ip route 125.125.125.40 255.255.255.248 124.124.124.244
ip route 125.125.125.48 255.255.255.240 124.124.124.244

 

I've set rapid PVST on the switch. Hopefully this helps.

 

With regards to the routes - are you simply referring to combining routes? For example, taking two /29 subnets that are currently routed separately and routing them all together as a single /28?

Yes.

Thanks for the reply! I've removed the default gateway entry. 'ip cef' returns incomplete command, perhaps it's not enabled. Is this something I should consider enabling?

 

I still need to look into configuring each access port with spanning tree portfast.

 

 

Hello,

 

what are your options at 'ip cef' ?

ip cef ?

ip cef ?
  distributed         Distributed Cisco Express Forwarding
  linecard            CEF linecard commands
  load-sharing        Load sharing
  optimize            Optimizations
  traffic-statistics  Enable collection of traffic statistics
Predrag Jovic
Participant

Also, regarding IPv6, do you need 2 equal cost default routes?

ipv6 route ::/0 1234:F80:0:1000::3:1
ipv6 route ::/0 5678:1900::1

 

No reason for it, I've removed the extra route. Thanks!

Predrag Jovic
Participant

What is your internet connection type (cable, ADSL)?

It's just a gigabit Ethernet uplink to the DC.

Hello

 

Can also you post -

sh process cpu sort
show spanning-tree detail | in is|top|tran|Link|BPDU:
sh int  | in tx|rx|drops|error

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Here's the output of the requested commands:

https://pastebin.com/raw/dPkt7yiv

There is a lot of output drops on some interfaces. QoS or congestion avoidance (WTD) should be implemented. Implementing WTD would be fastest and it would prevent TCP global synchronization issue.

Catalyst 3560 - Chapter: Configuring QoS