cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2653
Views
0
Helpful
47
Replies
Highlighted
Beginner

Cisco 3620 and Internet access

I have a Cisco 3620 router and I am trying to get internet access. My isp is comcast. All modem lights seem to be operational. But I do not have internet access. I can ping anything other then the router and I am on a home network.

I have attached a config file. Please note I am a novice with cisco routers.

47 REPLIES 47
Highlighted

Hi Ray,

mac-address 000b.46cc.8fc1     (This is the mac addr of the E0/0 interface card)

no need to put this command on eth0/0 as it is already its MAC address and furthermore this interface is not connected to the modem.It won't do any bad  but it is unnecessary.

no ip route-cache

Don't enter this command, renable it with either ip cef global command or ip route-cache cef interface command and verify with sh cef interface command.

Your arp requests for the PC gateway( 192.168.3.1) are not replied by the router, can you try to purge the cache with arp -d * command on the PC and do a ping 192.168.3.1 and then see if you get the correct mapping in the cache.

But I would like to have the wireshark capture when PC connected directly to modem.

Regards.

Alain

Don't forget to rate helpful posts.
Highlighted

I removed the mac address from E0/0. And removed the no ip route.

(Note that "no ip route-cache" and "ip address dhcp" commands were added from the Cisco config link from about. That's why they were in the config.)

New wireshark file add. Info captured while pc was connected to the cable modem this time, and all pings were fine.

And updated config file attached also. I could not remove the " no ip mroute-cache" command.

Thanks Ray

Highlighted

Hi Ray,

Why did you remove the ip address dhcp command on eth0/1 ? reenter this command

if you don't get the default-gateway ( sh ip route) then try this :

ip route 0.0.0.0 0.0.0.0 dhcp

let us know.

Regards.

Alain


Don't forget to rate helpful posts.
Highlighted
Enthusiast

Hi Ray,

I just want to add something else to all the good advise you get from Alain.

This things needs to be performed in certain order, otherwise it won't work.

After you have changed mac address on router to match the mac on pc, and before you connect router to modem, make sure that you use a pin to reset modem to factory defaults, should have a small opening at the back.

After the modem is reset to factory defaults, plug in the router and no PC connected to router.

Eugen

Highlighted

Made all corrections, reset modem to defaults and still no internet.

Ran (sh ip route) and only e0/0 is returned. Pinged to router from pc is fine but ping 8.8.8.8 says no destination,(ping 8.8.8.8 from both pc and router).

When I tried to run (ip route 0.0.0.0 0.0.0.0 dhcp) it return, "Invalid input detected at dhcp". When I run

ip route 0.0.0.0 0.0.0.0 ?, there is no dhcp option.

Ray

Highlighted

Hi,

so the router is still not getting any IP from DHCP.

can you do a debug  dhcp client on the router and post output.

Regards.

Alain.

Don't forget to rate helpful posts.
Highlighted

Alain,

I ran the following command:

debug ip dhcp server packets

And it only returned the following:

DHCPD: checking for expired leases.

That staement was rturned about every 5 minutes.

Ray

Highlighted

Alian,

I ran the following command:

debug dhcp

And attached the output, sorry used the command from before.

But this stood out:

DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x529572B1%Unknown DHCP problem.. No allocation possible

Highlighted

Hi Ray,

Just a quick question.

Do you have dhcp server enabled on the router?

Highlighted

eugne,

I ran the "service dhcp" command and still no internet and can't ping 8.8.8.8

Below is my config:

version 12.2

no parser cache

no service pad

no service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ccefl

!

logging buffered 10000 debugging

enable password cisco

!

username ray privilege 15 password 0 cisco

username all

ip subnet-zero

ip cef

!

!

ip name-server 208.67.222.222

ip name-server 208.67.220.220

ip dhcp excluded-address 192.168.3.1

ip dhcp excluded-address 192.168.3.2

ip dhcp excluded-address 192.168.3.10

ip dhcp excluded-address 192.168.3.3

ip dhcp excluded-address 192.168.3.4

ip dhcp excluded-address 192.168.3.5

ip dhcp excluded-address 192.168.3.6

ip dhcp excluded-address 192.168.3.7

ip dhcp excluded-address 192.168.3.8

ip dhcp excluded-address 192.168.3.9

!

ip dhcp pool lan_ccefl

   import all

   network 192.168.3.0 255.255.255.0

   dns-server 208.67.222.222

   default-router 192.168.3.1

   lease 3

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Tunnel1

no ip address

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

ip nat inside

no ip mroute-cache

full-duplex

no cdp enable

!

interface Ethernet0/1

description exit

mac-address 0011.e398.dcc6

ip address 192.168.100.1 255.255.255.0

ip nat outside

no ip mroute-cache

full-duplex

no cdp enable

!

ip nat inside source list 1 interface Ethernet0/1 overload

ip classless

ip http server

ip http authentication local

ip http path flash

!

access-list 1 permit 192.168.3.0 0.0.0.255

access-list 199 permit icmp any any

no cdp run

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 3

password cisco

login local

line vty 4

password cisco

login local

transport input telnet

!

end

Highlighted

Hi Ray,

I may ask a silly question..

To what port in the modem are connecting your router? Also can you disable dhcp server on the router until you have your internet working "no dhcp server". You can give a static ip to the PC and LAN interface for testing. Can you post another show run output after you disable dhcp

Regards

Eugen

Highlighted

PC already has a static IP address.

"To what port in the modem are connecting your router?" It's connected to the rj-45 port, it's the only option.

Will do a sh run and disable dchp server next try.

Highlighted

Thats good. Can you also post the output of "sh version".

Highlighted

eugen,

I had to use the " no service dhcp" command, the "no dhcp server" did not work. And below are the two outputs of sh run and sh version:

Building configuration...

Current configuration : 1669 bytes

!

version 12.2

no parser cache

no service pad

no service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service dhcp

!

hostname ccefl

!

logging buffered 10000 debugging

enable password cisco

!

username ray privilege 15 password 0 cisco

username all

ip subnet-zero

ip cef

!

!

ip name-server 208.67.222.222

ip name-server 208.67.220.220

ip dhcp excluded-address 192.168.3.1

ip dhcp excluded-address 192.168.3.2

ip dhcp excluded-address 192.168.3.10

ip dhcp excluded-address 192.168.3.3

ip dhcp excluded-address 192.168.3.4

ip dhcp excluded-address 192.168.3.5

ip dhcp excluded-address 192.168.3.6

ip dhcp excluded-address 192.168.3.7

ip dhcp excluded-address 192.168.3.8

ip dhcp excluded-address 192.168.3.9

!

ip dhcp pool lan_ccefl

   import all

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 208.67.222.222

   lease 3

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Tunnel1

no ip address

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

ip nat inside

no ip mroute-cache

full-duplex

no cdp enable

!

interface Ethernet0/1

description exit

mac-address 0011.e398.dcc6

ip address dhcp

ip nat outside

no ip mroute-cache

full-duplex

no cdp enable

!

ip nat inside source list 1 interface Ethernet0/1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0/1

ip http server

ip http authentication local

ip http path flash

!

access-list 1 permit 192.168.3.0 0.0.0.255

access-list 199 permit icmp any any

no cdp run

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 3

password cisco

login local

line vty 4

password cisco

login local

transport input telnet

!

end

ccefl#sh version

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IS-M), Version 12.2(13b)M2,  RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Fri 08-Aug-03 18:39 by yiyan

Image text-base: 0x60008930, data-base: 0x61122000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

ccefl uptime is 13 minutes

System returned to ROM by power-on

System image file is "flash:Z12213BM2.POO"

cisco 3640 (R4700) processor (revision 0x00) with 126976K/4096K bytes of memory.

Processor board ID 29545610

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

2 Ethernet/IEEE 802.3 interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Highlighted

eugen,

Congrats on passing your test.

Ray

Content for Community-Ad