cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

26945
Views
20
Helpful
8
Replies
Highlighted
Beginner

Cisco 3650 INSTALL upgrade procedure broken?

Hi guys,

We have a whole bunch of Cisco WS-C3650-12X48UQ switches, which were shipped with a now deferred Denali IOS XE release.

Obviously we now need to upgrade. These switches were shipped with their IOS running in INSTALL mode. The upgrade process/commands for this mode is quite straightforward;

- copy image to flash

- run command "software install file flash:file.bin switch #"

- wait, save config, reload

However, the "software" commands are not present in privileged exec, nor configure terminal!

When attempting to run the BUNDLE mode to upgrade, it refuses to boot, and slings me out to the bootloader. I can restart the old IOS using the command "boot flash:packages.conf", but I'm back to square 1.

What is one supposed to do here?

I'd rather not use BUNDLE mode if possible, due to the additional memory constraints - but may have to if no other upgrade method works. Is this yet ANOTHER Denali bug?

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Community Legend

Kindly read the Release Notes

Kindly read the Release Notes carefully.  

Starting from Denali, the command to upgrade the IOS, using Install mode, has been changed.

Upgrading from Cisco IOS XE Denali 16.1.1 to 16.1.x, 16.2.x, or 16.3.x in Install Mode

View solution in original post

8 REPLIES 8
Hall of Fame Community Legend

Kindly read the Release Notes

Kindly read the Release Notes carefully.  

Starting from Denali, the command to upgrade the IOS, using Install mode, has been changed.

Upgrading from Cisco IOS XE Denali 16.1.1 to 16.1.x, 16.2.x, or 16.3.x in Install Mode

View solution in original post

VIP Expert

Good going Cisco.  With every

Good going Cisco.  With every version of IOS, they come up with some new command to confuse people.

Thanks for the link Leo!

Reza

Hall of Fame Community Legend

Hahaha ... No problem, Reza.

Hahaha ... No problem, Reza.  :)

VIP Expert

Leo,

Leo,

Cisco drives me crazy. Usually getting a PHD is good for life but If there was a PHD program for Cisco IOS, you would have to get one every year :-)

Reza

Enthusiast

Re: Leo,

can you go from 3.7 to 16.6

 

also getting the following...any thoughts...

 

software install file flash:cat3k_caa-universalk9.16.06.04a.SPA.bin on-reboot
Preparing install operation ...
[1]: Copying software from active switch 1 to switches 2,3
[1]: Finished copying software to switches 2,3
[1 2 3]: Starting install operation
[1 2 3]: Expanding bundle flash:cat3k_caa-universalk9.16.06.04a.SPA.bin
[1 2 3]: Copying package files
[1 2 3]: Package files copied
[1 2 3]: Finished expanding bundle flash:cat3k_caa-universalk9.16.06.04a.SPA.bin
[1 2 3]: Verifying and copying expanded package files to flash:
[1]: % flash: requires 401220 KB of free space, but only 192528 KB is available. Operation aborted.
[2]: % flash: requires 401220 KB of free space, but only 192512 KB is available. Operation aborted.
[3]: % flash: requires 401220 KB of free space, but only 237948 KB is available. Operation aborted.
[1]: % An internal error was encountered. Operation aborted.
[2]: % An internal error was encountered. Operation aborted.
[3]: % An internal error was encountered. Operation aborted.

Beginner

Re: Leo,

Leo,

 

You need to free up some space in the flash: directory

 

-Chris

Beginner

Thank you Leo.

Thank you Leo.

This wasnt very well publicised. When changing the upgrade procedure, it should be a bit less buried in the release notes!!

I will give this a try and let you know.

Hall of Fame Community Legend

When changing the upgrade

When changing the upgrade procedure, it should be a bit less buried in the release notes!!

Thanks for the ratings, Greg.  

Well, what can I say?  I don't know the logic behind this and you're not the first nor the last person to get caught by this.   

CreatePlease to create content
Content for Community-Ad