cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
339
Views
0
Helpful
12
Replies
Beginner

Cisco 3650 IOS 12.2 InterVLAN - Single Switch

Hello,

Was setting up Cisco 3560 switch VLAN , need help with InterVLAN routing using single L3 Switch.

config below:

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 switchport mode access
!
interface FastEthernet0/2
 switchport mode access
!
interface FastEthernet0/3
 switchport mode access
!
interface FastEthernet0/4
 switchport mode access
!
interface FastEthernet0/5
  switchport mode access
!
interface FastEthernet0/6
!Connected to Esxi switch 192.168.1.x - VLAN1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
 switchport mode access
!
interface FastEthernet0/8
! Connected to Esxi Switch 192.168.150.x - VLAN2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/9
 switchport mode access
!
interface FastEthernet0/10
 switchport mode access
!
interface FastEthernet0/11
 switchport mode access
!
interface FastEthernet0/12
 switchport mode access
!
interface GigabitEthernet0/1
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 ip address 192.168.150.254 255.255.255.0
!
!
router eigrp 1
 eigrp stub connected summary
 network 192.168.150.0 0.0.0.255
 network 192.168.1.0
!
ip classless
ip http server
!
!
control-plane

Was working fine with un-managed switch, replaced with cisco 3560

it worked with Dlink Unmanaged switch, facing issue with VLAN.

In Esxi virtual switch no Vlan ID is configured, left default.

 

If I ping any device in VLAN 2 , 192.168.150.2  from switch , there is reply.

If I configure my laptop which is connected to port in vlan with IP address of VLAN 2 (192.168.150.10) ,  Server on VLAN2 192.168.150.2 is reachable.

 

But if I change my laptop IP to VLAN1 IP - 192.168.1.10, I am able to ping switch IP, which 192.168.1.1 which is  Gateway for laptop, but not able to ping or reach server 192.168.150.2

 

Laptop in VLAN 1 with IP 192.168.1.10 should be able to connect to server on 192.168.150.20

 

Servers are on trunk port through another switch (L2)

 

Laptop is connected to interface

FastEthernet0/1

switchport mode access

 

Thank You

 

~Suds~
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

Hello All,

I  deleted configuration and again re configured 2 vlans (SVI) with single pc/laptop in each vlan

but still had issue, then realized !! my laptop is connected to internet through wifi, 

changed default gateway to router SVI IP, and it started working..

 

Issue was , when laptop connected to wifi (for Internet) it gets default gateway from dhcp, this clashes with lan default gateway previously set.

 

Thank You.. 

 

~Suds~
12 REPLIES 12
VIP Mentor

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

Hello,

 

I assume the clients in VLAN 2 are connected to this interface:

 

interface FastEthernet0/8
! Connected to L2 Switch 192.168.150.x - VLAN2
switchport trunk encapsulation dot1q
switchport mode trunk

 

Post the configuration of that L2 switch as well. 

Beginner

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

Trunk Ports are connected to another switch.

Client / laptop is connected to one of the ports assigned to default vlan 1

 

interface FastEthernet0/2

 

 

~Suds~
VIP Advisor

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

As per your configuration you have provide 2 Trunk interface in the switch as below

 

interface FastEthernet0/6
!Connected to L2 switch 192.168.1.x - VLAN1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
!
interface FastEthernet0/8
! Connected to L2 Switch 192.168.150.x - VLAN2
 switchport trunk encapsulation dot1q
 switchport mode trunk

 

but you have not provided other switch port and switch config.

Make sure you have same configuration other side ( or post other side switch configuration to confirm).

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

as I mentioned earlier, If I configure Laptop IP same range as server it works.

From cisco swith if I ping server IP it works.

only time it does not work, then Laptop is in IP sub net belonging to VLAN 1 (192.168.1.x)

Switch connected to Trunk port are working fine, those are not cisco, its VM Ware virtual switch.

I was using un-managed switch before, everything worked fine,  Un-managed switch was replaced with cisco 3560, created vlans for different networks.

 

~Suds~
VIP Mentor

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

Hello,

 

which access port is supposed to be in VLAN 2 ? By default, all access ports are configured for VLAN 1. You need to assign a Vlan to a port, e.g.:

 

interface FastEthernet0/9
switchport mode access

switchport access vlan 2

spanning-tree portfast

Beginner

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

Sorry for confusions.

Laptop or work stations will be in VLAN 1, with IP 192.168.1.x IP ,

Servers will be in VLAN 2  with IP 192.168.150.x IP , Servers are on Esxi.

So.. there will be no laptop/devices with IP Address range of VLAN2.

Therefore in switch interfaces are in Default VLAN1.

 

Devices in VLAN1 with IP Range 192.168.1.x, should be able to access severs on VLAN 2 with IP Range 192.168.150.x 

 

~Suds~
VIP Advisor

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

As per your reply

 

you have PC connected to Switch -- Switch connected to Trunk with VMWARE

 

here is the configuration as per the Vmware.

https://kb.vmware.com/s/article/1006628

 

if you connect same vlan2 - VMWARE server reachable

if you connect the PC to VLAN1 - Server not reachable.

 

Can you post show ip route from switch. ( want to check ip routing enabled ?)

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

IP routing is enables (configuration posted in first post)

 

show ip route: 

Gateway of last resort is not set

C 192.168.150.0/24 is directly connected, Vlan2
C 192.168.1.0/24 is directly connected, Vlan1

~Suds~
VIP Mentor

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

So which port is assigned to Vlan 2 ?

Beginner

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

show ip route: 

Gateway of last resort is not set

C 192.18.150.0/24 is directly connected, Vlan2
C 192.168.1.0/24 is directly connected, Vlan1

 

Interface connected to VLAN 2 - Esxi (truk mode)


interface FastEthernet0/8
! Connected to Esxi Switch 192.168.150.x - VLAN2
switchport trunk encapsulation dot1q
switchport mode trunk
===

 

#ping 192.168.150.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.150.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

#ping 192.168.1.91
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.91, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

GARNET-ESXI-LAN2#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.1.105 0 .-.6783 ARPA Vlan1
Internet 192.168.1.107 188 .-.58c1 ARPA Vlan1
Internet 192.168.1.101 42 .-.e922 ARPA Vlan1
Internet 192.168.150.2 0 .-.db7b ARPA Vlan2
Internet 192.168.1.1 - .-.b3c0 ARPA Vlan1
Internet 192.168.150.254 - .-.b3c1 ARPA Vlan2

Vlan2 is up, line protocol is up
Hardware is EtherSVI, address is b862.1f83.b3c1 (bia b862.1f83.b3c1)
Internet address is 192.168.150.254/24

~Suds~
Highlighted
Hall of Fame Guru

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

 

So on the ESXi switch you have not configured a vlan ID ? 

 

If so try adding this to the fa0/8 configuration on your switch - 

 

int Fa0/8
switchport trunk native vlan 2

 

or configure a vlan ID of 2 on the ESXi switch. 

 

Jon

Beginner

Re: Cisco 3650 IOS 12.2 InterVLAN - Single Switch

Hello All,

I  deleted configuration and again re configured 2 vlans (SVI) with single pc/laptop in each vlan

but still had issue, then realized !! my laptop is connected to internet through wifi, 

changed default gateway to router SVI IP, and it started working..

 

Issue was , when laptop connected to wifi (for Internet) it gets default gateway from dhcp, this clashes with lan default gateway previously set.

 

Thank You.. 

 

~Suds~
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards