Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

Cisco 3750-X switch freezes after IOS update

Hi all.

I have a 2 member 3750-x switch stack that was upgraded to 15.2 today via CNA. All the files were transfered and expanded correctly and it got to the step where the switches needed to be reloaded but on reload they froze.

I connected a console cable and power cycled the stack. I see the flash initialize and then the IOS image start to load. Lots of @ symbols and then nothing. It just sits there. The system light on the switches, while flashing green during the load, is now off. No light at all. But fans are running and the process will repeat itself if power cycled.

Any thoughts?

Reza Sharifi
Hall of Fame Expert


When you console to the switch stack, are you connecting to the master switch?

Can you turn off the switches, connect the console cable to the master and then turn on the switches and post the output?


Hi Reza.

I have tried both switches. I have also disconnected the switches and tried it stand-alone so the one I am connected to is the master (as there is nothing else connected). I have the console connected and I see the same thing each time. The flash file system initializes and then it starts to load the IOS file. Then pages of the @ as it loads the file, then nothing. It just stops mid-line. No loaded text or anything else after the @@@@@@@@@.

As another test, I loaded the c3750e-universalk9-mz.150-2.SE2.bin file on a usb drive (formatted to FAT16) and ran "boot usbflash0:c3750e-universalk9-mz.150-2.SE2.bin" and I get the same thing.

Thinking it might be a corrupted file on the flash drive, I formatted the flash file system with "format flash:" and then loaded the iso bin off the USB drive. Same result.

So I am starting to question the .bin file. But I have the full .tar and ran checksum on it and it matched. So the file "should" be fine.

Hi Jeff,

I agree, you may just have a corrupted IOS file.  Can you download 150-1.SE instead and see if you have the same issue?

I have 150-1 on a few 3750X switches and they seem to be running fine.


Let me guess ... You're upgrading FROM 12.2(5X)SE to 15.0(2)SE?

If this is so then you are probably witnessing the bootstrap upgrade.  Can take a heart-stopping 25 minutes. 

It turned out to be a corrupted IOS bin. Even with checksum matched, it choked and the switch would not boot beyond loading the file. Luckily I had backed up the original IOS file and was able, after many hours and time with Cisco on the phone, to bring it back to the original IOS level.

Now I have to go grab a correct IOS file and hope it's not corrupted too,

Thanks for the help.


Any one can know the solution for c3750x switch ios is freezing above 15.0.1 version. its get stuck at @@@@@@@ in the middle. i have tried the all version above 15.0.1 but the none of them is working, its get stopped at @@@@@ here and the same image is work with another switch so there is no doubt for corrupted the file because i download from cisco website .I tried with all above 15.0.1 version isn't working But below all version are working perfectly fine.


can anybody help me for this?