cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

469
Views
0
Helpful
0
Replies
Highlighted
Beginner

Cisco 3850-XS traffic shaping

Hi community,

 

I am trying to configure shaping of traffic as it egresses out of a switchport. I have configured the ACL, class-map and policy-map and have applied it to the interface using the service-policy command, but I receive the error below. What I am trying to do is limit the amount of bandwidth towards the destinations defined in the ACLs.

 

"Invalid queuing class-map!!! Queuing actions supported only with dscp/cos/qos-group/precedence/exp based classification!!!"

 

IP SUBNETS
-----------

ip access-list extended abc
remark Permits all traffic to abc subnets defined below
permit ip any 10.40.0.0 0.0.255.255
permit ip any 10.41.0.0 0.0.255.255
permit ip any 10.42.0.0 0.0.255.255
permit ip any 10.44.0.0 0.0.255.255
permit ip any 10.190.0.0 0.1.255.255
permit ip any 10.192.0.0 0.63.255.255


ip access-list extended xyz
remark Permits all traffic to xyz subnets defined below
permit ip any 10.58.0.0 0.0.255.255
permit ip any 10.59.0.0 0.0.255.255
permit ip any 10.60.0.0 0.0.255.255


CLASS-MAPS
-----------

class-map match-any CM-abc
match access-group name abc
!
class-map match-any CM-xyz
match access-group name xyz

 

POLICY-MAP
-----------

policy-map PM-RESTRICT-abc-xyz-6GBPS-OUT
description Restricts all abc and xyz bandwidth to 3Gbps each
class CM-abc
shape average 3000000000
class CM-xyz
shape average 3000000000
class class-default

 

Can somebody please advise where I am going wrong and what I need to do to achieve the shaping?

 

The egress interface is a layer 2 dot1q trunk port. Layer 3 connectivity between the two 3850s is provided using SVIs, with the Vlan permitted over the trunk.

 

Thanks!

Everyone's tags (2)
CreatePlease to create content
Content for Community-Ad