cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
574
Views
0
Helpful
3
Replies

Cisco 831 RIP Issues

danielcummins
Level 1
Level 1

I am trying to create a small network to test the functionality of my Cisco 831 routers.  I've designed the following infrastructure:

HostA (192.168.2.2/24)

Connected to:

e0 (192.168.2.1/24) Router1 (172.16.1.2/24) e1

Connected to:

Switch

Connected to:

e1 (172.16.1.1/24) Router2 (192.168.1.1/24) e0

Connected to:

HostB (192.168.1.2/24)

For some reason, the HostB network is not being detected by Router1 and HostA is not being detected by Router2.  It seems that RIP might be the problem.

Here are the sh run outputs for both routers:

Router1

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

ip ips po max-events 100

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

ip address 192.168.2.1 255.255.255.0

!

interface Ethernet1

ip address 172.16.1.2 255.255.0.0

duplex auto

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

router rip

version 2

network 172.16.0.0

network 192.168.0.0

no auto-summary

!

no ip classless

!

ip http server

no ip http secure-server

ip nat inside source list 101 interface Ethernet1 overload

!

!

access-list 100 permit ip any any

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

!

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

!

!

ip cef

!

!

!

!

!

no crypto isakmp enable

!

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

!

interface Ethernet1

ip address 172.16.1.1 255.255.0.0

duplex auto

!

interface Ethernet2

no ip address

shutdown

!

interface FastEthernet1

duplex auto

speed auto

!

interface FastEthernet2

duplex auto

speed auto

!

interface FastEthernet3

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

router rip

version 2

network 172.16.0.0

network 192.168.0.0

no auto-summary

!

no ip classless

ip http server

no ip http secure-server

!

ip nat inside source list 101 interface Ethernet1 overload

!

access-list 101 permit ip any any

!

control-plane

!

!

line con 0

no modem enable

transport output all

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.2.1 255.255.255.0
!
interface Ethernet1
ip address 172.16.1.2 255.255.0.0
duplex auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
router rip
version 2
network 172.16.0.0
network 192.168.0.0
no auto-summary
!
no ip classless
!
ip http server
no ip http secure-server
ip nat inside source list 101 interface Ethernet1 overload
!
!
access-list 100 permit ip any any
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end
!

Router2

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
no crypto isakmp enable
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
!
interface Ethernet1
ip address 172.16.1.1 255.255.0.0
duplex auto
!
interface Ethernet2
no ip address
shutdown
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
router rip
version 2
network 172.16.0.0
network 192.168.0.0
no auto-summary
!
no ip classless
ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Ethernet1 overload
!
access-list 101 permit ip any any
!
control-plane
!
!
line con 0
no modem enable
transport output all
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end

1 Accepted Solution

Accepted Solutions

John Blakley
VIP Alumni
VIP Alumni

The first thing that I notice is that your network statements don't seem to be correct.

Router1:

router rip

version 2

network 172.16.0.0

network 192.168.0.0   <<<----- Should be 192.168.2.0

no auto-summary

Router2:

router rip

version 2

network 172.16.0.0

network 192.168.0.0

no auto-summary

router rip

version 2

network 172.16.0.0

network 192.168.0.0  <<<----- Should be 192.168.1.0

no auto-summary

Your switch should be set with:

router rip

version 2

network 172.16.0.0

network 192.168.0.0 <<< ---- Should be 192.168.2.0

no auto-summary

HTH,

John

*** Please rate helpful posts ****

HTH, John *** Please rate all useful posts ***

View solution in original post

3 Replies 3

John Blakley
VIP Alumni
VIP Alumni

The first thing that I notice is that your network statements don't seem to be correct.

Router1:

router rip

version 2

network 172.16.0.0

network 192.168.0.0   <<<----- Should be 192.168.2.0

no auto-summary

Router2:

router rip

version 2

network 172.16.0.0

network 192.168.0.0

no auto-summary

router rip

version 2

network 172.16.0.0

network 192.168.0.0  <<<----- Should be 192.168.1.0

no auto-summary

Your switch should be set with:

router rip

version 2

network 172.16.0.0

network 192.168.0.0 <<< ---- Should be 192.168.2.0

no auto-summary

HTH,

John

*** Please rate helpful posts ****

HTH, John *** Please rate all useful posts ***

Thanks!  That fixed it.

Glad I could help

HTH, John *** Please rate all useful posts ***
Review Cisco Networking for a $25 gift card