cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1536
Views
3
Helpful
5
Replies

Cisco 877 as DHCP relay to local server

Nick Sinyakov
Level 1
Level 1

Hi.

Could you help me to setup cisco router 877 as DHCP relay to the server, so for example PC (VM on Hyper-V) from vlan 44 will get IP from DHCP scope 192.168.44.1/24

Server has only 1 IP 192.168.10.30 and VLAN ID 10 (Hyper-V), but it has 3 DHCP scoups

There are 3 vlans on the router:

     1. vlan 10 - 192.168.10.11/24

     2. vlan 33 - 192.168.33.11/24

     3. vlan 44 - 192.168.44.11/24

I'm using unmanaged switch.

Current config:

...

interface FastEthernet0

switchport access vlan 3

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

switchport access vlan 10

switchport trunk allowed vlan 1,2,10-1005

switchport mode trunk

!

interface Vlan3

ip address xxx.xxx.xxx.xxx 255.255.255.224

ip nat outside

ip virtual-reassembly

!

interface Vlan10

ip address 192.168.10.11 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan33

ip address 192.168.33.11 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan44

ip address 192.168.44.11 255.255.255.0

ip nat inside

ip virtual-reassembly

!

Thanks,

Nick

1 Accepted Solution

Accepted Solutions

blau grana
Level 7
Level 7

Hello Nick,

Just under Vlan33 and 44 interfaces configure

ip helper-address IP_addr_DHCP_server

Vlan10 interface do not have to be configured with this command, cause DHCP seerver is from local subnet.

In your case:

interface Vlan33

ip helper-address 192.168.10.30

interface Vlan44

ip helper-address 192.168.10.30

Example:

http://cisconet.com/tcpip/dhcp/107-how-to-use-ip-helper-address-to-connect-remote-dhcp-server.html

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

View solution in original post

5 Replies 5

blau grana
Level 7
Level 7

Hello Nick,

Just under Vlan33 and 44 interfaces configure

ip helper-address IP_addr_DHCP_server

Vlan10 interface do not have to be configured with this command, cause DHCP seerver is from local subnet.

In your case:

interface Vlan33

ip helper-address 192.168.10.30

interface Vlan44

ip helper-address 192.168.10.30

Example:

http://cisconet.com/tcpip/dhcp/107-how-to-use-ip-helper-address-to-connect-remote-dhcp-server.html

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

Hi Blau,

Thanks for reply. Still no luck. I've added suggested helper-address, but only Vlan 10 is getting IP from DHCP server.

On port FA2 physical Laptop connected. On port FA3 - Hyper-V.

interface FastEthernet0

!

interface FastEthernet1

shutdown

!

interface FastEthernet2

switchport trunk native vlan 33

switchport mode trunk

!

interface FastEthernet3

switchport trunk native vlan 44

switchport mode trunk

!

interface Vlan1

ip address xxx.xxx.xxx.xxx 255.255.255.0

ip nat outside

ip virtual-reassembly

!

interface Vlan10

ip address 192.168.10.11 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan33

ip address 192.168.33.11 255.255.255.0

ip helper-address 192.168.10.30

ip nat inside

ip virtual-reassembly

!

interface Vlan44

ip address 192.168.44.11 255.255.255.0

ip helper-address 192.168.10.30

ip nat inside

ip virtual-reassembly

!

All vlans are allowed on interfaces fa2 and fa3:

yourname#show interfaces f3 trunk

Port      Mode         Encapsulation  Status        Native vlan

Fa3       on           802.1q         trunking      44

Port      Vlans allowed on trunk

Fa3       1-4095

Port      Vlans allowed and active in management domain

Fa3       1,10,33,44

Port      Vlans in spanning tree forwarding state and not pruned

Fa3       1,10,33,44

yourname#show interfaces f2 trunk

Port      Mode         Encapsulation  Status        Native vlan

Fa2       on           802.1q         trunking      33

Port      Vlans allowed on trunk

Fa2       1-4094

Port      Vlans allowed and active in management domain

Fa2       1,10,33,44

Port      Vlans in spanning tree forwarding state and not pruned

Fa2       1,10,33,44

In previous config Vlans 33 and 44 were not in the VLAN database. Current Database:

yourname#show vlan-switch brief

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0, Fa1

10   VLAN0010                         active

33   VLAN0033                         active

44   VLAN0044                         active

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

Is it necessary for Fa2 and Fa3 to be trunks? Try to convert them to access ports.

Can you try from both Vlans, 33 and 44 ping their gateways, other Vlan's gateways an then IP address of DHCP. Was ping successful? - you can try this with Fa2 and Fa3 in trunk and access mode.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

It's weird.

interface FastEthernet2

switchport access vlan 44

!

interface FastEthernet3

switchport access vlan 44

Laptop on FastEthernet2 getting DHCP IP for the server but for VLAN 10, like 192.168.10.100, not 192.168.44.100.

Also with this settings DHCP server can't ping its gateway. Maybe I should add access-list rule?

Got it. Now I can receive DHCP response from any VLAN using Hyper-V VLAN ID. The working config is below:

....

interface FastEthernet0

!

interface FastEthernet1

shutdown

!

interface FastEthernet2

switchport mode trunk

!

interface FastEthernet3

switchport mode trunk

!

interface Vlan1

ip address xxx.xxx.xxx.xxx 255.255.255.0

ip nat outside

ip virtual-reassembly

!

interface Vlan10

ip address 192.168.10.11 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan33

ip address 192.168.33.11 255.255.255.0

ip helper-address 192.168.10.30

ip nat inside

ip virtual-reassembly

!

interface Vlan44

ip address 192.168.44.11 255.255.255.0

ip helper-address 192.168.10.30

ip nat inside

ip virtual-reassembly

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card