cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1605
Views
0
Helpful
3
Replies

Cisco 877 router adsl Telia

Hi All

I have a C877 router that i would connect to a telia (big ISP of sweden) adsl connection. The router should recieve a dynamic ip address on the ATM interface.

From the ISP i get this information on what to configure

Router

Enet/Encap, routing, LLC based, VP8/VC35 (UBR)

When i debug the dhcp recuests i get this error messages.

Unknown DHCP problem.. No allocation possible

Here is the config (trunked)

dot11 syslog
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1
!
ip dhcp pool ccp-pool
   import all
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   lease 0 2
!
!
no ip domain lookup
ip domain name yourdomain.com
!
multilink bundle-name authenticated
!
!
username kalle privilege 15 secret 5 $1$Q0Zn$WHDgbE9GljNFMYEz4TNWT1
!
!        
archive
log config
  hidekeys
!
!
!
!
!
interface ATM0
no ip address
no ip unreachables
no ip proxy-arp
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.35 point-to-point
ip address dhcp
ip flow ingress
ip nat outside
ip virtual-reassembly
pvc 8/35
  encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 192.168.10.1 255.255.255.0
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ATM0.35
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
!
control-plane

Everyone's tags (3)
3 REPLIES 3
Highlighted
Hall of Fame Master

Re: Cisco 877 router adsl Telia

Please include the complete debug output, "show version", show interface, show atmv pvc 8/35.

Highlighted

Re: Cisco 877 router adsl Telia

Hi, The solution is as posted below.

interface ATM0
no ip address
no ip unreachables
no ip proxy-arp
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.2 point-to-point
ip address dhcp
ip nat outside
ip virtual-reassembly
atm route-bridged ip
pvc 8/35
  encapsulation aal5snap
!
!

Now the router recieves an dynamic dhcp adress from the ISP (telia adsl).

/Magnus

Highlighted
Hall of Fame Master

Re: Cisco 877 router adsl Telia

Very good, please note that the commands put under atm0, are not effective, because the interface is not processing IP.

CreatePlease to create content
Content for Community-Ad