cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco 887VA no internet access on vlans.

bens00003
Beginner
Beginner

I am fairly new to cisco routers so I'm not 100% sure what I am doing wrong.

I have setup my router so that it connects to the internet, and I can successfuly ping from the router. 

I have also setup my vlans, and I can successfully ping the router. But I cannot ping the internet from these vlans.

I'm not quite sure if my routing is correct. Any help is appreciated.

Below is my attached configuration:

 

service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
service sequence-numbers
!
hostname adsl
!
boot-start-marker
boot-end-marker
!
logging count
logging userinfo
logging buffered 131000 debug
enable secret
!
no aaa new-model
!
!clock timezone ESTime 10
!clock save interval 8
!
ip cef
no ip bootp server
!ip domain list <Domain.local>
!ip domain name <Domain.local>
!ip name-server <DNSServer>
login block-for 600 attempts 3 within 60
login delay 7
login quiet-mode access-class aclQuietMode
login on-failure log
!
username cisco privilege 15 secret 0 cisco
!
archive
 log config
  hidekeys
 path flash:$h
 write-memory
!
crypto key generate rsa
!
ip ssh version 2
!

interface ATM0
 description ADSL Interface to ISP
 no ip address
 no shutdown
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
 no snmp trap link-status
 no ip route-cache cef
 no ip route-cache
 load-interval 30
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5mux ppp dialer
  tx-ring-limit 3
  dialer pool-member 1
  dsl operating-mode auto
  ppoe-client dial-pool-number 1
!
interface FastEthernet0
 switchport access vlan 100
!
interface FastEthernet1
 switchport mode trunk
 switchport trunk native vlan 100
!
interface FastEthernet2
 no shutdown
!
interface FastEthernet3
 no shutdown
!
interface Vlan100
 description Wired LAN interface
 no shutdown
 ip address 10.10.100.3 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan1
 description Wired LAN interface
 no shutdown
 ip address 10.10.100.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Dialer0
 description WAN Interface
 no shutdown
 ip address negotiated
 ip access-group aclInternetInbound in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip inspect CBAC-FW out
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip mtu 1492
 ip tcp adjust-mss 1452
 dialer pool 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname cisco@direct.telstra.net
 ppp chap password 0 1111
 ppp pap sent-username cisco@direct.telstra.net password 0 1111
 ppp ipcp dns request
 ppp ipcp route default
 ppp ipcp address accept

! port fwd settings
!PC1
ip nat inside source static tcp 10.10.101.13 3389 interface dialer 0 3030
!PC2
ip nat inside source static tcp 10.10.101.14 3389 interface dialer 0 3031
!PC3
ip nat inside source static tcp 10.10.101.15 3389 interface dialer 0 3032
!pc80
ip nat inside source static tcp 192.168.1.90 80 interface dialer 0 80
!pc22
ip nat inside source static tcp 192.168.1.90 22 interface dialer 0 22
!pc3306
ip nat inside source static tcp 192.168.1.90 3306 interface dialer 0 3306
!cam51
ip nat inside source static tcp 192.168.1.51 80 interface dialer 0 1051

! Static Routes
!servers
ip route 10.10.101.0 255.255.255.0 10.10.100.10
!rnd
ip route 10.10.3.0 255.255.255.0 10.10.100.10
!salesadmin
ip route 10.10.2.0 255.255.255.0 10.10.100.10
!guest
ip route 172.16.1.0 255.255.255.0 10.10.100.10
!training
ip route 10.10.4.0 255.255.255.0 10.10.100.10
!testnetwork192
ip route 192.168.1.0 255.255.255.0 10.10.100.10


!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip dns server
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
logging trap debugging
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 login local
!
scheduler max-task-time 5000
ntp server au.pool.ntp.org

 

1 REPLY 1

kcnajaf
Rising star
Rising star

Hi,

Not sure why you are using the same ip address range for two vlans (ie. vlan 100 and vlan 1 is using ip range on 10.10.100.x) as below.

interface Vlan100
 description Wired LAN interface
 no shutdown
 ip address 10.10.100.3 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan1
 description Wired LAN interface
 no shutdown
 ip address 10.10.100.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly

For testing make configuration changes as below.

config terminal

int vlan 1

shutdown

access-list 101 permit ip 10.10.100.0 0.0.0.255 any

ip nat inside source list 101 interface dialer 0 overload

 

Check internet from host after applying above configurations.

Hope that helps.

Regards

Najaf

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: