cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
542
Views
0
Helpful
8
Replies
Highlighted
Beginner

cisco 891-w nat issue

Hello, I have a Cisco router 891-w and I'm trying to use it at home, but it does not login to the internet, this is my configuration.

any help, please ?

 

 

Router#sh running-config

Building configuration...

 

Current configuration : 2611 bytes

!

version 15.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot config usbflash0:CVO-BOOT.CFG

boot-end-marker

!

!

!

no aaa new-model

service-module wlan-ap 0 bootimage autonomous

!

!

!

!

!

!        

!

!

!

!

 

 

!

ip dhcp excluded-address 192.168.20.1

!

ip dhcp pool voice

 network 192.168.20.0 255.255.255.0

 option 150 ip 192.168.20.1

 default-router 192.168.20.1

!

!

!

ip cef

no ipv6 cef

!

!

!

!        

!

multilink bundle-name authenticated

!

!

!

!

!

!

license udi pid CISCO891W-AGN-A-K9 sn FTX1529816S

!

!

!

redundancy

!

!

!

!

interface FastEthernet0

 no ip address

!

interface FastEthernet1

 no ip address

!

interface FastEthernet2

 no ip address

!

interface FastEthernet3

 no ip address

!

interface FastEthernet4

 no ip address

!

interface FastEthernet5

 no ip address

!        

interface FastEthernet6

 no ip address

!

interface FastEthernet7

 no ip address

!

interface FastEthernet8

 ip address 192.168.1.65 255.255.255.0

 ip nat outside

 ip virtual-reassembly in

 duplex auto

 speed auto

!

interface GigabitEthernet0

 ip address dhcp

 duplex auto

 speed auto

!

interface wlan-ap0

 no ip address

 arp timeout 0

! !

interface Wlan-GigabitEthernet0

 no ip address

!

interface Vlan1

 ip address pool voice

 ip nat inside

 ip virtual-reassembly in

!

interface Async1

 no ip address

 encapsulation slip

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip nat inside source list 101 interface FastEthernet8 overload

ip route 0.0.0.0 0.0.0.0 FastEthernet8

!

!

!

access-list 101 permit ip 192.168.20.0 0.0.0.255 any

!        

control-plane

!

!

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!

mgcp profile default

!

!

!

!

!

!

!

telephony-service

 max-ephones 4

 max-dn 4

 ip source-address 192.168.20.1 port 2000

 cnf-file perphone

 max-conferences 0 gain -6

transfer-system full-consult

 create cnf-files version-stamp 7960 Jun 01 2019 07:12:16

!

!

ephone-dn  1

 number 1010

!

!

ephone-dn  2

 number 2020

!

!

ephone  1

 device-security-mode none

 mac-address 40F4.ECEE.78D0

 type 7975

 button  1:1

!

!

!

ephone  2

 device-security-mode none

 mac-address 000F.3493.FA40

type 7960

 button  1:2

!

!

!

!

line con 0

line 1

 modem InOut

 speed 115200

 flowcontrol hardware

line 2

 no activation-character

 no exec

 transport preferred none

 transport input all

 transport output pad telnet rlogin udptn ssh

line aux 0

line vty 0 4

 login

 transport input none

!

!

!

end

8 REPLIES 8
Highlighted
VIP Advisor

Hi @moelsaid ,

 

I think it is necessary to configure the 192.168.20.0 network in an interface, besides, that interface must be left as ip nat inside.

 

Regards

Highlighted

hello @luis_cordova 

thank you for your response but can you explain more, I'm kinda confused  

thank you 

  
Collaborator
Re: cisco 891-w nat issue

Hi @moelsaid ,

 

I think it is necessary to configure the 192.168.20.0 network in an interface, besides, that interface must be left as ip nat inside.

 

Regards

 
 
Everyone's tags (0)
  • Data Classification:
  • Cisco Public
 
Accept as Solution
 
 

 

 
 
 
Highlighted

Hi  @moelsaid ,

 

You have the output interface configured (FastEthernet8).

You have the nat configured to translate the 192.168.20.0 network, but, you do not have that network configured in any interface.

In addition, you must indicate that this interface will be the input interface after the translation.

Maybe:

 

FastEthernet7

ip address 192.168.20.1 255.255.255.0

ip nat inside 

 

 

Regards

 

Highlighted

hello @luis_cordova 

I already did that on interface VLAN 1  and make to nat inside, Does the nat inside should be in phycial interface, not VLAN interface ??

 

Router(config)#do sh ip interface brief

Interface                  IP-Address      OK? Method Status                Protocol

Async1                     unassigned      YES unset  down                  down    

FastEthernet0              unassigned      YES unset  up                    up      

FastEthernet1              unassigned      YES unset  down                  down    

FastEthernet2              unassigned      YES unset  up                    up      

FastEthernet3              unassigned      YES unset  down                  down    

FastEthernet4              unassigned      YES unset  down                  down    

FastEthernet5              unassigned      YES unset  down                  down    

FastEthernet6              unassigned      YES unset  down                  down    

FastEthernet7              unassigned      YES unset  up                    up      

FastEthernet8              192.168.1.65    YES NVRAM  up                    up      

GigabitEthernet0           unassigned      YES NVRAM  down                  down    

NVI0                       192.168.1.65    YES unset  up                    up      

Vlan1                      192.168.20.1    YES NVRAM  up                    up      

Wlan-GigabitEthernet0      unassigned      YES unset  up                    up      

wlan-ap0                   unassigned      YES NVRAM  up                    up      

Router(config)#

Highlighted

Hi
No it can be either logical or physical depending on setup , you need an inside NAT and outside on the public interface , the modem connected must also be in bridge mode so it pulls the external IP address back onto the Cisco router and basically just becomes dumb terminal

example in this link ,with wireless config setup too

 

https://community.cisco.com/t5/wireless-mobility-documents/configuration-example-of-861w-881w-891w-series-isr-s/ta-p/3112716

Highlighted

interface vlan 1

ip address 192.168.20.1 255.255.255.0

no shutdown

 

Highlighted

Hi @Hulk8647 ,

 

If the network 192.168.20.0 is in the interface vlan1, it is expected that the devices will be associated with that vlan.
Within the interface vlan1, you must indicate that this will be the input interface for the NAT:

 

interface vlan 1

ip address 192.168.20.1 255.255.255.0

ip nat inside

no shutdown

 

Regards

 

 

Highlighted
VIP Mentor

Hello

 

conf t
Interface vlan 1
ip address 192.168.20.1 255.255.255.0

ip route-cache

no ip route 0.0.0.0 0.0.0.0 FastEthernet8
ip route 0.0.0.0 0.0.0.0 FastEthernet8 192.168.1.X  (next hop ip address)

Access-ports
int x/x
switchport mode access
spanning-tree portfast



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Content for Community-Ad