cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
333
Views
0
Helpful
4
Replies

Cisco Business 250 (CBS250-8T-D) Mainswitch -> Trunk -> VLAN? HowTo?

humpix
Level 1
Level 1

Hello everyone,
After a day of trying, I just can't get any further. Perhaps one of you has an idea...

I have c2960x switches with one of the ports set to trunk:

interface GigabitEthernet1/0/3
description Trunk Port IT Office
switchport trunk allowed vlan 1,10,12
switchport mode trunk
switchport nonegotiate
storm-control broadcast level 40.00 30.00
storm-control multicast level 40.00 30.00
storm-control action shutdown
!

The CBS250, whose uplink port 8 is also set to trunk, is connected to this port.
The other ports on the CBS250 are either on VLAN1 (clients) or VLAN12 (printers)
Management should take place via VLAN10.

I have reached the point where I can ping and manage the switch on its VLAN10 IP via the uplink. However, I cannot get the devices on VLAN1 or 12 to communicate with the rest of the network via the uplink.

Here the complete config of the CBS250:

config-file-header
switchac4052
v3.4.0.17 / RCBS3.4_950_377_325
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
!
unit-type-control-start
unit-type unit 1 network gi uplink none
unit-type-control-end
!
no spanning-tree
vlan database
vlan 10,12
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone
voice vlan oui-table add 00036b Cisco_phone
voice vlan oui-table add 00096e Avaya
voice vlan oui-table add 000fe2 H3C_Aolynk
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone
voice vlan oui-table add 00e075 Polycom/Veritel_phone
voice vlan oui-table add 00e0bb 3Com_phone
bonjour interface range vlan 1
hostname switchac4052
passwords aging 180
username admin password encrypted $blablablablabla== privilege 15
ip telnet server
!
interface vlan 1
name Clients
!
interface vlan 10
name Management
ip address 10.7.88.35 255.255.255.0
!
interface vlan 12
name Printer
!
interface GigabitEthernet6
switchport access vlan 12
!
interface GigabitEthernet7
switchport access vlan 12
!
interface GigabitEthernet8
switchport mode trunk
switchport trunk native vlan none
switchport trunk allowed vlan 1,10,12
!
exit
ip default-gateway 10.7.88.1

Does anyone have any idea how this needs to be set. I've been trying for 12 hours and I'm on the verge of despair...

BR and thx, Mathias

1 Accepted Solution

Accepted Solutions

humpix
Level 1
Level 1

I think I have solved the problem.
If I don't set an IP as above and the switch gets one via DHCP, everything works. If I then just create a new IP in VLAN 10, enter the gateway via Telnet and then delete the DHCP entry in the IPv4 setting, everything works.
The config then looks exactly the same as above, with the only difference that it then works with the correct procedure.
I'm pretty sure it's a bug. But at least I now have a workaround.
Thanks again Rick, the experiments with the IPs have finally brought me to the goal

BR, Mathias

View solution in original post

4 Replies 4

Richard Burts
Hall of Fame
Hall of Fame

There is much about this environment that we do not know. But one thing stands out in the posted config: neither vlan interface for vlan 10 or 12 has an IP address. Configure appropriate IP addresses on those vlan interfaces and tell us if the behavior changes.

HTH

Rick

humpix
Level 1
Level 1

Hello Rick,
Thanks for the tip. It must have something to do with the IPs. If I set everything VLAN related the same, but don't play around with the IPs at all, everything works. Now the CBS250 just pulls a IP from the DHCP over VLAN1 and everything works.
Further IPs on the other VLANs are not required.
As soon as I set a fixed IP instead of DHCP (btw. in the same VLAN1 and same range), nothing works and I have to reset the switch because I can't even access it from the same Network. The aim was that all switches (including this ones) are only accessible from VLAN 10 which is our management VLAN. At least I can now continue to build my network. However, this is very annoying, as the small CBS250 behave very differently to the bigger and older ws-c2960x-48ts-l ones...

Maybe there's another trick (I probably need to invest more time here), otherwise I'll have to replace them in the long term. The question will then be what to replace them with and whether Cisco is still suitable for our requirements.

BR and thanks!
Mathias

humpix
Level 1
Level 1

I think I have solved the problem.
If I don't set an IP as above and the switch gets one via DHCP, everything works. If I then just create a new IP in VLAN 10, enter the gateway via Telnet and then delete the DHCP entry in the IPv4 setting, everything works.
The config then looks exactly the same as above, with the only difference that it then works with the correct procedure.
I'm pretty sure it's a bug. But at least I now have a workaround.
Thanks again Rick, the experiments with the IPs have finally brought me to the goal

BR, Mathias

Mathias

Thanks for the update. Glad to know that you have a solution.

HTH

Rick
Review Cisco Networking for a $25 gift card