cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
336
Views
0
Helpful
10
Replies
Highlighted

Cisco catalyst 3750-X port questions

I have a Catalyst 3750-X that is managing a selection of Windows XP and Windows 7 machines as part of a separate network from our main one.

It seems that there are 12 ports (13-24) that will not accept the machines when they are plugged in through patch panels and give a warning of 'limited or no connectivity' and give a 169 address.

I have plugged a windows 10 laptop directly into the ports in question and I am able to get a 192 address without any issues. When I move one of the machines that are in a port that works into one of the ones that doesn't, it's gets the same error, and when I move a machine that was in the error giving ports into one of the working ports then it starts to work.

I have turned of firewalls and AV and still doesn't work.

I have included the running config from the switch.

If anyone has any ideas as to what might be causing it I would appreciate any help.

 

Thank you

David Kernaghan

10 REPLIES 10
Highlighted
Rising star

Hi, first of all remove username and password from the config attached.

I checked the config of the ports and I see some different configurations:

 

interface GigabitEthernet1/0/1   >>> trunk in vlan 200
description uplink to catalyst
switchport
switchport access vlan 1  <<< probably is not necessary
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 200
switchport mode trunk

 

interface GigabitEthernet1/0/2 <<<< access port in vlan 200
switchport
switchport access vlan 200
switchport trunk encapsulation negotiate
switchport mode access

 

interface GigabitEthernet1/0/3  to 48 <<< access negotiated in vlan 200
switchport
switchport access vlan 200
switchport trunk encapsulation negotiate

 

If on this port you must connect only PC, force the port in access mode

switchport mode access

and check again.

 

Check also POST log to see if all ports work correctly.

 

Let us know your results.

Regards.

Highlighted
VIP Mentor

Hello,

 

--> spanning-tree portfast disable

 

Enable this feature on your ports, as it usually is to blame when no DHCP address is being obtained

Highlighted
VIP Mentor

Hello

 

 

 


@DavidKernaghan2470 wrote:

I have a Catalyst 3750-X that is managing a selection of Windows XP and Windows 7 machines as part of a separate network from our main one.

It seems that there are 12 ports (13-24) that will not accept the machines when they are plugged in through patch panels and give a warning of 'limited or no connectivity' and give a 169 address.

I have plugged a windows 10 laptop directly into the ports in question and I am able to get a 192 address without any issues.



So any machine connected through the patch panels DONT work or is this just XP/wK7 pcs?

If the the former, Then I would suggest you check your cable management ?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Hall of Fame Community Legend


@DavidKernaghan2470 wrote:

I have plugged a windows 10 laptop directly into the ports in question and I am able to get a 192 address without any issues.


Plug a few machines back to they are presented on the patch panel.  

Next, cable them up to the switch.  

NOTE:  Pray the switch isn't running an ancient IOS version!

Do the following: 

1.  Command:  test cable tdr interface <PORT>;

2.  Wait for about 5 to 7 seconds for the command to process; 

3.  Command:  sh cable tdr interface <PORT>; and 

4.  Post the complete output to #3. 

Can I also request if you can post the complete output to the command "sh version"?

Highlighted

Leo,

Thank you for all your help here, I really appreciate it. I've attached two files, the SH Version output and the TDR tests from half of the affected ports as I'm pretty sure that they will be the same with the other half.

I also tested the command with a port that I am able to get an IP address from and it had the same output, so I'm not sure what that means.

The SH version shows a SW version that doesn't match exactly with the model type, could this be an issue?

 

Thanks

David Kernaghan

Highlighted
Hall of Fame Community Legend

Sadly, the uptime of the switch is >1 year and there is a bug with the TDR when the uptime >1 year.
Highlighted

Update:

I did some cabling tests, I plugged one of the cables from a port that does work and put it into a port that doesn't and the machine was unable to get an IP.

So I don't think it is the cabling. I used a cable tester and was able to get an active link from all of the ports (13-24) but when it tried to do a ping test and get a DHCP address they all failed.

 

With regards to the commands from the switch, will that cause any problems for the machines that are plugged in?

 

Thanks for all the responses,

David Kernaghan

Highlighted
Hall of Fame Community Legend


@DavidKernaghan2470 wrote:

With regards to the commands from the switch, will that cause any problems for the machines that are plugged in?

 


If the machines are not working, there is nothing "worst" that can happen.  I just want to see the output to ensure it's not a cabling issue. 

NOTE:  Some cheap "cable testers" will only test two of the four ports (contrary to advertised).

Highlighted

Leo,

there are other machines plugged into the switch that are working and I would like not to have anything happen to them as they are used to record sensitive data and cannot be interrupted.

 

David Kernaghan

Highlighted

Sorry, ignore the above. Just realised what the command is doing. I'm new to some aspects of infrastructure and learning on the go!
Thanks

David Kernaghan
Content for Community-Ad