cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

225
Views
0
Helpful
4
Replies
Highlighted
Beginner

Cisco Catalyst 3850 not routing

I have configured my cisco 3850 swtich for L3 Routing and have followed many online resources from Cisco about proper configuration, but am not able to get the inter-vlan routing to work.  I have checked all of my commands several times and going through them step at a time, but nothing.  I have read and re-read many online troubleshooting articles concerning routing and have another L3 switch (a 3750x) configuration that I followed as well (for a guide).  I am still not having any luck routing between vlans.  I also have a Windows DHCP server and an IP-HELPER address setup, but nothing there either.  I'm sure that the routing is not functional.  Any help would be appreciated.

 

The core switch configuration is:

 


!
! Last configuration change at 15:47:07 UTC Sat Jul 20 2019 by admin
!
version 16.6
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
!
hostname Core-Switch
!
!
vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
enable secret 5 $1$wEUy$iJ.U37OqiVLaORCJ2n5GG0
!
no aaa new-model
switch 1 provision ws-c3850-24p
!
!
!
!
ip routing
!
ip domain name aaota.org
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-939288410
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-939288410
revocation-check none
rsakeypair TP-self-signed-939288410
!
!
crypto pki certificate chain TP-self-signed-939288410
certificate self-signed 01 nvram:IOS-Self-Sig#2.cer
!
!
!
diagnostic bootup level minimal
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
username admin password 7 08751E1A5D4B5C46
!
redundancy
mode sso
!
!
transceiver type all
monitoring
!
!
class-map match-any system-cpp-police-topology-control
description Topology control
class-map match-any system-cpp-police-sw-forward
description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
description DHCP Snooping, EWLC control, EWCL data
class-map match-any system-cpp-police-sys-data
description Learning cache ovfl, Crypto Control, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
description L2 LVX control packets
class-map match-any system-cpp-police-forus
description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
description MCAST END STATION
class-map match-any system-cpp-police-multicast
description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
description L2 control
class-map match-any system-cpp-police-dot1x-auth
description DOT1X Auth
class-map match-any system-cpp-police-data
description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
description Routing control
class-map match-any system-cpp-police-protocol-snooping
description Protocol snooping
class-map match-any system-cpp-police-system-critical
description System Critical and Gold
!
policy-map system-cpp-policy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
shutdown
speed 1000
negotiation auto
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/3
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/4
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/5
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/6
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/7
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/8
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/9
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/10
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/11
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/12
switchport trunk native vlan 10
switchport mode trunk
!
interface GigabitEthernet1/0/13
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/22
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/23
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/24
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 172.16.0.254 255.255.255.0
ip helper-address 172.16.0.5
!
interface Vlan100
ip address 172.16.10.254 255.255.255.0
ip helper-address 172.16.0.5
!
interface Vlan110
ip address 172.16.12.254 255.255.255.0
ip helper-address 172.16.0.5
!
interface Vlan200
ip address 172.16.20.254 255.255.255.0
ip helper-address 172.16.0.5
!
interface Vlan210
ip address 172.16.22.254 255.255.255.0
ip helper-address 172.16.0.5
!
interface Vlan300
ip address 172.16.30.254 255.255.255.0
ip helper-address 172.16.0.5
!
interface Vlan310
ip address 172.16.32.254 255.255.255.0
ip helper-address 172.16.0.5
!
interface Vlan600
ip address 172.16.60.254 255.255.255.0
ip helper-address 172.16.0.5
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.16.0.1
ip ssh version 2
!
!
!
!
!
control-plane
service-policy input system-cpp-policy
!
!
line con 0
password 7 1443405F5856737A
logging synchronous
login
stopbits 1
line aux 0
password 7 1443405F5856737A
login
stopbits 1
line vty 0 4
password 7 135145465F5E5D7B
logging synchronous
login local
transport input all
line vty 5 15
password 7 135145465F5E5D7B
logging synchronous
login local
transport input all
!
!
mac address-table notification mac-move
!
!
!
!
!
end

Everyone's tags (1)
4 REPLIES 4
VIP Mentor

Re: Cisco Catalyst 3850 not routing

Hello,

 

how are the clients in the other (other than VLAN 10) Vlans connected to the 3850 ? Make sure any trunk link has set the native Vlan set to 10 on any switches connected to the 3850...

Beginner

Re: Cisco Catalyst 3850 not routing

 I will be using Ubiquiti AP's on the trunk ports.. I do have one attached now to Gi1/0/3 and it does get a proper IP address for the device.  I have several VLANS associated with respectives SSID's and none of them are working.  As you can see with my configuration file, I do have IP-HELPER addresses configured, but as I said on the OP the only DHCP assignments that I am getting is on the Native VLAN 10.  I have also configured a switchport (such as Gi1/0/15) and set it to a different native vlan (associated with a different subnet for instance 172.16.30.0 - and corresponding DHCP zone on the Window server at IP address of 172.16.0.5).  Finally i manually set a static IP address of 172.16.30.30 on this switchport, but still it fails to communicate with anyone except I can ping the gateway address of 172.16.30.254.

Beginner

Re: Cisco Catalyst 3850 not routing

Hi,

I have few questions:
1. can you paste show ip route?
2. do have configured seperate pools for seperate vlans on Windows DHCP server?
3. Did you tried set IPs manually on hosts in different vlans and ping dhcp server?

Beginner

Re: Cisco Catalyst 3850 not routing

Hi.. Thanks for the replies.  Somehow this thread was marked as SPAM and was unable to update it yesterday, so I started a new one.  Please go here: https://community.cisco.com/t5/switching/newly-configured-catalyst-3850-l3-switch-not-routing-ip-helper/m-p/3894210 to see the information that you have requested.  Thanks again - Bill

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards