cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
11836
Views
10
Helpful
6
Replies
Highlighted
Beginner

Cisco catalyst 3850 switch won't take command: "switchport mode trunk encapsulation dot 1q"

Hi all,

    I'am working on this switch's configuration. when I typed "switchport mode trunk encapsulation dot 1q", I got an error " invavid input". I'm guessing that this model already set encapsulation type to dot 1q, and that's why the switch won't take it, right? 

   Please help!

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Guru

According to the documents it supports both.

You are however using the wrong command, it should be -

"switchport trunk encapsulation dot1q"

ie. no "mode" keyword.

If it doesn't take that then do a "sh int <x> capabilities" and it should show you which encapsulation methods are supported.

Jon

View solution in original post

6 REPLIES 6
Highlighted

Hi

You don't put the word 'mode' in there.

Remember, the ? key is the only command you need to know when configuring Cisco kit :-)

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Highlighted

Hi Aaron,

 

    your are right. comes to CLI,  "? key" should be my best friend. I don't have to remember hundreds of command any more. hehe.

 

Thank you for the tip!

Take care

 

 

Highlighted
Hall of Fame Guru

According to the documents it supports both.

You are however using the wrong command, it should be -

"switchport trunk encapsulation dot1q"

ie. no "mode" keyword.

If it doesn't take that then do a "sh int <x> capabilities" and it should show you which encapsulation methods are supported.

Jon

View solution in original post

Highlighted

Hi Jon!

Actually I don´t have that option.

 

SW-CORE-MCO(config-if)#switchport trunk ?
allowed   Set allowed VLAN characteristics when interface is in trunking mode
native      Set trunking native characteristics when interface is in trunking
mode
pruning   Set pruning VLAN characteristics when interface is in trunking mode

Highlighted
Beginner

hey, Jon

how are you?

Thank you for your tip again!

 

 

Highlighted
Beginner

You are right it is set by default......

you don't have to run this command anymore.

You can see with show interface x/x switchport , once its sets to trunk that's enough.


for example; sh int gi0/1 switchport

Access Port should have these option;
Administrative Mode: static access
Negotiation of Trunking: Off

***Trunk Port should have these option;
Administrative Mode: trunk
Negotiation of Trunking: On

Content for Community-Ad