cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

9731
Views
5
Helpful
6
Replies
Highlighted
Beginner

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Hello Folks,

I have gone through many topics/discussion on this forum and found out that many users faced this problem before, and the answers to these problems never reached to a solution.

I am hit by the same problem.

I have a Cisco 6500 which has two VLANs defined

VLAN 30 for Data VLAN

VLAN 31 for Voice VLAN

I have two Cisco 3750 switches.

both switches are connected to IP Phones.

the configuration of Cisco 6500 Trunk Port to Cisco 3750 is

Interface Gigabit0/1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan add 31

switchport trunk native vlan 30

On Cisco 3750, the trunk port to 6500 has the configuration

interface Gigabit 0/1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk allowed vlan add 31

switchport trunk native vlan 30

The IP Phones connected to the Cisco 3750 are 7911,7979, 7940, 7961.

All the Ports have following configuration

Interface Fast 0/1-0/24

switchport mode trunk

switchport trunk allowed vlan add 31

switchport trunk native vlan 30

switchport trunk encapsulation dot1q

All phone are working fine, the phones get their ip address from voice vlan, and systems connected to phones get from data vlan, except 7940/7960.

these two models of IP Phones remain on Configuring IP, and when you check the IP Settings, it gives Data VLAN IP, which does not have a TFTP.

once you manually enter TFTP address in the field, it registers instantly, due to ip routing in the network.

these phones were working fine before, but suddenly few days back they went out of the network, and still are in Configuring IP state.

I also tried to convert these ports connected to 7940/7960 to access ports

switchport mode access

switchport access vlan 30

switchport voice vlan 31

but still the IP is taken from the Access Vlan (30).

Even If you configure a single VLAN on these ports, the IP phones then never get the IP.

Does any one have a solution to it?

Regards

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Syed,

No there is NO lldp support for 7940/60 with any software update

LLDP is supported on

LLDP-MED supports the following Cisco Unified IP phone models:

7906G

7911G

7931G

7941G/7941G-GE

7942G

7945G

7961G/7961G-GE

7962G

7965G

7970G/ 7971G-GE

7975G

If you are unable to use CDP on a non Cisco switch then you will need to

configure the voice vlan manually on the 7940/60

On the phone

Press the

Settings button

Select

"Network Configuration"

Go down to

"Admin VLAN ID"

Type

**# (This unlocks the setting)

Edit 

Type in the VOICE VLAN ID e.g.

708

Validate 

Save

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

View solution in original post

6 REPLIES 6
Advocate

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Syed,

7940/60s are old model phones.

They rely on CDP to find their voice vlan numbers.

Can you ensure that CDP is running on the 7940/60 ports

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Beginner

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Hello acampbell,

All ports are running CDP, and when we connect 7911 or 7970 to the same port, they register instantly.

I had a non-Cisco PoE switch which has LLDP-MED instead of CDP.

we have configured the same configuration on that switch, and connected all these ip phones to it.

On that switch also, 7911 and 7970 gets registered, and 7941/7960 does not takes IP from Voice VLAN.

Does 7941/7960 support LLDP?

Regards

Advocate

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Syed,

NO

7940/60s do not support LLDP

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Beginner

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Hi acampbell,

does upgrading the Firmware of 7940/7960 can resolve this problem?

or LLDP/LLDP-MED is not supported at all at any firware level?

Advocate

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Syed,

No there is NO lldp support for 7940/60 with any software update

LLDP is supported on

LLDP-MED supports the following Cisco Unified IP phone models:

7906G

7911G

7931G

7941G/7941G-GE

7942G

7945G

7961G/7961G-GE

7962G

7965G

7970G/ 7971G-GE

7975G

If you are unable to use CDP on a non Cisco switch then you will need to

configure the voice vlan manually on the 7940/60

On the phone

Press the

Settings button

Select

"Network Configuration"

Go down to

"Admin VLAN ID"

Type

**# (This unlocks the setting)

Edit 

Type in the VOICE VLAN ID e.g.

708

Validate 

Save

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

View solution in original post

Beginner

Cisco IP Phones 7960/7940 Getting Data VLAN IP

Thanks Alex,

You are right, I checked with other vendors as well, 7940/7960 will never automatically take the ip from voice vlan.

Thanks.

CreatePlease to create content
Content for Community-Ad