ā09-22-2015 07:56 AM - edited ā03-08-2019 01:54 AM
I have wake on lan working on a network with 2 segments, connected with a 2801 router configured to forward broadcasts (udp port 7) from wol-server to wol-client network.
WOL command from WOL Server Network
-------------------------------------------------------------------------------------------------------------------
WolCmd.exe D4CEFC8F71E5 255.255.255.255 255.255.255.255 7
Wake On Lan signal sent to Mac Address D4CEFC8F71E5 via Broadcast Address 255.255.255.255 on port 7
-------------------------------------------------------------------------------------------------------------------
WOL package being forwarded from one network to the other
-------------------------------------------------------------------------------------------------------------------
RouterWOL#debug ip udp
Sep 22 14:04:06.439: UDP: rcvd src=10.10.2.34(1652), dst=255.255.255.255(7), length=110
Sep 22 14:04:06.439: UDP: forwarding packet 255.255.255.255(1652) to 10.10.103.255(7)
Sep 22 14:04:06.439: UDP: forwarding packet 255.255.255.255(1652) to 10.10.103.255(7)
Sep 22 14:04:06.439: UDP: forwarded broadcast 7 from 10.10.2.34 to 255.255.255.255 on FastEthernet0/1
RouterWOL#
-------------------------------------------------------------------------------------------------------------------
Router WOL configuration
-------------------------------------------------------------------------------------------------------------------
RouterWOL#show running-config
Building configuration...
.
ā¦
interface FastEthernet0/0
description WOL-ServerNetwork
ip address 10.10.2.249 255.255.255.0
ip access-group 122 in
ip helper-address 10.10.103.255
duplex auto
speed auto
ā¦
interface FastEthernet0/1
description Wol-ClientNetwork
ip address 10.10.100.1 255.255.252.0
ip access-group 123 in
ip directed-broadcast 110
duplex auto
speed auto
ā¦
ip forward-protocol udp echo
ā¦
ip access-list extended WolCmdACL
permit udp any any eq echo log
ā¦
access-list 110 permit udp host 10.10.2.34 any eq echo log
access-list 122 permit udp host 10.10.2.34 any eq echo log
access-list 122 permit udp any any eq ntp log
access-list 122 permit tcp any any eq 22 log
access-list 123 permit tcp any any eq 22 log
access-list 123 permit icmp any any echo
access-list 123 permit icmp any any echo-reply
ā¦
-------------------------------------------------------------------------------------------------------------------
On the PC I receive the WOL - Magic Packet and the computer wakes on.
Here is a sample of the package received by the client PC
-------------------------------------------------------------------------------------------------------------------
Frame: Number = 180, Captured Frame Length = 144, MediaType = ETHERNET
- Ethernet: Etype = Internet IP (IPv4),DestinationAddress:[FF-FF-FF-FF-FF-FF],SourceAddress:[00-19-E7-91-DC-51]
- DestinationAddress: *BROADCAST [FF-FF-FF-FF-FF-FF]
Rsv: (111111..)
UL: (......1.) Locally Administered Address
IG: (.......1) Group address (multicast)
- SourceAddress: Cisco Systems 91DC51 [00-19-E7-91-DC-51]
Rsv: (000000..)
UL: (......0.) Universally Administered Address
IG: (.......0) Individual address (unicast)
EthernetType: Internet IP (IPv4), 2048(0x800)
- Ipv4: Src = 10.10.2.34, Dest = 255.255.255.255, Next Protocol = UDP, Packet ID = 11561, Total IP Length = 130
- Versions: IPv4, Internet Protocol; Header Length = 20
Version: (0100....) IPv4, Internet Protocol
HeaderLength: (....0101) 20 bytes (0x5)
- DifferentiatedServicesField: DSCP: 0, ECN: 0
DSCP: (000000..) Differentiated services codepoint 0
ECT: (......0.) ECN-Capable Transport not set
CE: (.......0) ECN-CE not set
TotalLength: 130 (0x82)
Identification: 11561 (0x2D29)
- FragmentFlags: 0 (0x0)
Reserved: (0...............)
DF: (.0..............) Fragment if necessary
MF: (..0.............) This is the last fragment
Offset: (...0000000000000) 0
TimeToLive: 127 (0x7F)
NextProtocol: UDP, 17(0x11)
Checksum: 24586 (0x600A)
SourceAddress: 10.10.2.34
DestinationAddress: 255.255.255.255
- Udp: SrcPort = 1699, DstPort = Echo(7), Length = 110
SrcPort: 1699
DstPort: Echo(7)
TotalLength: 110 (0x6E)
Checksum: 35915 (0x8C4B)
- UDPPayload: SourcePort = 1699, DestinationPort = 7
UDPPayloadData: Binary Large Object (102 Bytes)
-------------------------------------------------------------------------------------------------------------------
ā¦And everything is working fineā¦
Now I need to replace the RouterWOL (Cisco C2801) by a C9504 Cisco NEXUS, but unfortunately it seems that NXOS (ver 6.1(2)I3(2)) does not support some functions like;
ip forward-protocol udp echo
ip helper-address 10.10.103.255
Any Ideas on how I can transfer the UDP redirect/forward from the Router to the NEXUS?
Regards
Nuno
ā09-19-2017 08:31 AM
Hello...
Anyone knows if Release 7 allows for WOL configuration?
Thank you
Nuno
ā06-21-2019 04:09 PM
Hello Pedro,
In this case definitely based on my research regarding a case, I admit this feature is not available for Nexus 9k, currently Nexus 9k chassis does not support such functionality.
This said, please be advised that supportability need was already raised to development team and tracked under enhancement request CSCuu60491< https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuu60491/?reffering_site=dumpcr>;;; (N9K:NX-OS-allow any udp broadcast with ip helper-address just like IOS). WoL will not work in "broadcast mode" because "ip forward protocol" is not supported. But you can work with ādirectly broadcast modeā. For WOL to work on Nexus in "directed broadcast mode", you need to meet following requirements: 1) Configure the WOL server to send packets to network broadcast address rather than all network broadcast address 2) Configure "ip directed broadcast" on the user vlans where the machines need to woken up.
Josue Campos
Data Center Routing and Switching Cisco TAC
ā08-08-2019 03:30 AM
Hello,
Am I missing something?
<sender of wol packet>
Wake On Lan signal sent to Mac Address 020040404f50
via Broadcast Address 172.22.2.255 on port 7
cisco Nexus9000 C9504
interface VlanServer<sender of wol packet>
no ip redirects
ip address 172.22.2.252/24
no ipv6 redirects
ip dhcp relay address 172.22.103.255
interface VlanUsers<receiver of wol packet>
no ip redirects
ip address 172.22.103.252/22
ip directed-broadcast
no ipv6 redirects
Thank you
ā08-08-2019 06:35 AM
Based on what I see you have applied the ip directed-broadcast command under the proper SVI, that should be good enough as per previous statement as a workaround.
ā03-04-2020 06:11 AM - edited ā03-04-2020 06:27 AM
Dear Josue Campos,
Thanks for your reaction
WoL will not work in "broadcast mode" because "ip forward protocol" is not supported. But you can work with ādirectly broadcast modeā. For WOL to work on Nexus in "directed broadcast mode", you need to meet following requirements: 1) Configure the WOL server to send packets to network broadcast address rather than all network broadcast address
You mean the WOL server should send packets to the server VLAN's broadcast address , correct ?
Thanks and Regards
Sander
ā08-08-2019 08:17 AM
IP Helper command is 'ip dhcp relay address xx.xx.xx.xx' in NXOS. I don't believe that the ip forward-protocol udp echo is needed in NXOS.
Thanks,
Kevin
ā03-27-2020 07:06 PM
I'm having the exact same issue as others have posted about
Using WOLCMD.exe to send magic packet to workstations and servers to power them for maintenance.
Prior to network upgrades this worked perfectly for years. Now, we upgraded to nexus 9000 and this is broken. We're being told this is not possible in the 9000 series. Am I being told correctly? In 2020 a Cisco switch cannot support a WOL magic packet?
Someone has to know of a work around. I simply refuse to believe this hasn't been solved by someone somehow.
If you know how to get around this, please post the solution in specific instructions. I am not the strongest at this and need to know exactly what to do to resolve this ASAP.
Thanks much
Jimm "I can't send my magic packet" Panik
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide