cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4974
Views
5
Helpful
3
Replies
Heiko Kelling
Beginner

Cisco Nexus connection problem

Hi all,

I try to connect 2 Nexus 5000 switches with 4 Nexus 2000 fabric extender, with this configuration:

feature telnet

cfs eth distribute

feature interface-vlan

feature lacp

feature vpc

feature lldp

feature fex

username admin password 5 xxx  role network-admin

no password strength-check

banner motd #Nexus 5000 Switch

#

ip domain-lookup

class-map type qos class-fcoe

class-map type queuing class-fcoe

  match qos-group 1

class-map type queuing class-all-flood

  match qos-group 2

class-map type queuing class-ip-multicast

  match qos-group 2

class-map type network-qos class-fcoe

  match qos-group 1

class-map type network-qos class-all-flood

  match qos-group 2

class-map type network-qos class-ip-multicast

  match qos-group 2

fex 101

  pinning max-links 1

  description "FEX101"

  type N2232P

fex 102

  pinning max-links 1

  description "FEX102"

  type N2232P

fex 103

  pinning max-links 1

  description "FEX103"

  type N2232P

fex 104

  pinning max-links 1

  description "FEX104"

  type N2232P

slot 101

  provision model N2K-C2232P

slot 102

  provision model N2K-C2232P

slot 103

  provision model N2K-C2232P

slot 104

  provision model N2K-C2232P

snmp-server user admin network-admin auth md5 0x7e89dcf3cd9ffca751e0e54996ceb845

priv 0x7e89dcf3cd9ffca751e0e54996ceb845 localizedkey

vrf context management

vlan 1

spanning-tree mode mst

spanning-tree pathcost method long

spanning-tree mst configuration

  name dc1

  revision 3

  instance 1 vlan 1-4093

vpc domain 1

  role priority 110

  peer-keepalive destination 192.168.0.2 source 192.168.0.1 interval 500 timeout 3

port-profile default max-ports 512

interface Vlan1

interface port-channel10

  description 5k1-to-5k2

  switchport mode trunk

  spanning-tree port type network

  speed 10000

  vpc peer-link

interface port-channel101

  switchport mode fex-fabric

  fex associate 101

  vpc 101

interface port-channel102

  switchport mode fex-fabric

  fex associate 102

  vpc 102

interface port-channel103

  switchport mode fex-fabric

  fex associate 103

  vpc 103

interface port-channel104

  switchport mode fex-fabric

  fex associate 104

  vpc 104

interface Ethernet1/1

  switchport mode fex-fabric

  fex associate 101

  channel-group 101

interface Ethernet1/2

  switchport mode fex-fabric

  fex associate 101

  channel-group 101

interface Ethernet1/3

  switchport mode fex-fabric

  fex associate 102

  channel-group 102

interface Ethernet1/4

  switchport mode fex-fabric

  fex associate 102

  channel-group 102

interface Ethernet1/5

  switchport mode fex-fabric

  fex associate 103

  channel-group 103

interface Ethernet1/6

  switchport mode fex-fabric

  fex associate 103

  channel-group 103

interface Ethernet1/7

  switchport mode fex-fabric

  fex associate 104

  channel-group 104

interface Ethernet1/8

  switchport mode fex-fabric

  fex associate 104

  channel-group 104

interface Ethernet1/9

  switchport mode trunk

  channel-group 10

interface Ethernet1/10

  switchport mode trunk

  channel-group 10

When I connect the fabric extenders with the Nexus 5000 I get the following errors and the fabric extenders are booting:

2009 Feb 26 12:54:03 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX101-2-SATCTRL: FEX-101 Module 1: Cold boot

2009 Feb 26 12:54:19 Nexus5000-h60 %$ VDC-1 %$ %PFMA-2-FEX_STATUS: Fex 101 is online

2009 Feb 26 12:53:59 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX101-2-SOHMS_DIAG_ERROR: FEX-101 System minor alarm on power supply 1: failed

2009 Feb 26 12:54:19 Nexus5000-h60 %$ VDC-1 %$ %NOHMS-2-NOHMS_ENV_FEX_ONLINE: FEX-101 On-line

2009 Feb 26 12:54:19 Nexus5000-h60 %$ VDC-1 %$ %PFMA-2-FEX_STATUS: Fex 101 is online

2009 Feb 26 12:54:32 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX101-2-SOHMS_DIAG_ERROR: FEX-101 Module 1: Runtime diag detected major event: Voltage failure on power supply: 1

2009 Feb 26 12:54:32 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX101-2-SOHMS_DIAG_ERROR: FEX-101 System minor alarm on power supply 1: failed

2009 Feb 26 12:54:46 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX101-2-SOHMS_ENV_ERROR: FEX-101 Module 1: Check environment alarms.

2009 Feb 26 12:54:20 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX103-2-SATCTRL: FEX-103 Module 1: Cold boot

2009 Feb 26 12:54:37 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX103-2-SOHMS_DIAG_ERROR: FEX-103 System minor alarm on power supply 1: failed

2009 Feb 26 12:54:58 Nexus5000-h60 %$ VDC-1 %$ %PFMA-2-FEX_STATUS: Fex 103 is online

2009 Feb 26 12:54:58 Nexus5000-h60 %$ VDC-1 %$ %NOHMS-2-NOHMS_ENV_FEX_ONLINE: FEX-103 On-line

2009 Feb 26 12:54:58 Nexus5000-h60 %$ VDC-1 %$ %PFMA-2-FEX_STATUS: Fex 103 is online

2009 Feb 26 12:55:08 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX103-2-SOHMS_DIAG_ERROR: FEX-103 Module 1: Runtime diag detected major event: Voltage failure on power supply: 1

2009 Feb 26 12:55:08 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX103-2-SOHMS_DIAG_ERROR: FEX-103 System minor alarm on power supply 1: failed

2009 Feb 26 12:55:24 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX103-2-SOHMS_ENV_ERROR: FEX-103 Module 1: Check environment alarms.

2009 Feb 26 12:53:43 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX104-2-SATCTRL: FEX-104 Module 1: Cold boot

2009 Feb 26 12:53:56 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX104-2-SOHMS_DIAG_ERROR: FEX-104 System minor alarm on power supply 1: failed

2009 Feb 26 12:54:12 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX104-2-SOHMS_DIAG_ERROR: FEX-104 Module 1: Runtime diag detected major event: Voltage failure on power supply: 1

2009 Feb 26 12:54:12 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX104-2-SOHMS_DIAG_ERROR: FEX-104 System minor alarm on power supply 1: failed

2009 Feb 26 12:55:06 Nexus5000-h60 %$ VDC-1 %$ %SATCTRL-FEX104-2-SOHMS_ENV_ERROR: FEX-104 Module 1: Check environment alarms.

2009 Feb 26 12:55:29 Nexus5000-h60 %$ VDC-1 %$ %PFMA-2-FEX_STATUS: Fex 104 is online

2009 Feb 26 12:55:29 Nexus5000-h60 %$ VDC-1 %$ %NOHMS-2-NOHMS_ENV_FEX_ONLINE: FEX-104 On-line

2009 Feb 26 12:55:29 Nexus5000-h60 %$ VDC-1 %$ %PFMA-2-FEX_STATUS: Fex 104 is online

All fabric extenders are affiliated on only 1 power supply.

Does anybody know if this is normal, a bug or something with the config is wrong?

3 REPLIES 3
balla-zoltan
Beginner

We have four 5580s and four 2232s. The configuration is a bit different but we don't have this issue. We don't have vpcs configured and this is how the port-channel configuration looks like:

interface port-channel103

  switchport mode fex-fabric

  fex associate 103

When I do a sh inv this is what I see:

NAME: "FEX 103 CHASSIS", DESCR: "N2K-C2232PP-10GE  CHASSIS"

PID: N2K-C2232PP-10GE  , VID: V03 , SN: SSI1519003B

NAME: "FEX 103 Module 1", DESCR: "Fabric Extender Module: 32x10GE, 8x10GE Supervisor"

PID: N2K-C2232PP-10GE  , VID: V03 , SN: FOC15241F45

NAME: "FEX 103 Fan 1", DESCR: "Fabric Extender Fan module"

PID: N2K-C2232-FAN     , VID: N/A , SN: N/A

NAME: "FEX 103 Power Supply 1", DESCR: "Fabric Extender AC power supply"

PID: N2200-PAC-400W    , VID: V02 , SN: LIT15170QFH

NAME: "FEX 103 Power Supply 2", DESCR: "Fabric Extender AC power supply"

PID: N2200-PAC-400W    , VID: V02 , SN: LIT15170QHV

We have only one 2232 connnected to one 5580, two 5580s are connected to each other and to the core 6509s.

Oleksandr Nesterov
Cisco Employee

Hi Heiko

Please check following bugs:

CSCtl77867

CSCtz84683

They depend on NX-OS release.

Also try to reset one of your FEX and see whether after reload bot power sup will come up.

If no - please open a TAC case to let us assis you with the issue .

HTH,

Alex

Hi guys,

So this looks to be an old discussion but I've found the same behaviour in system: version 5.2(1)N1(1b) although according to the bug tool, it should've been fixed in 5.2(1)N1(1) and above.

Has anyone else encountered anything similar? And have we got a definitive answer rather than a stab-in-the-dark upgrade?

Kind Regards,

Allan