cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
312
Views
0
Helpful
7
Replies
Decibel 83
Beginner

Cisco SG350X two stacks connected by uplink: ports continuously going down and up

Hi,

I'm having some issues on two Cisco stacks build with SG350X switches and connected together with a MLAG LACP connection:

Switches connections diagram.png

I'm having the issue that many Grandstream VoIP phones connected to the SG350X-48P units are disconnecting suddenly and themselves without any human intervention, and I see many ports going down and up after 3-5 seconds on all 4 x SG350X-48P units:

 

Screenshot 2021-06-10 at 09.00.43.png

 

VoIP phone are connected to ports untagged to a separate VLAN, but this happens on PCs on VLAN 1 too, so this problem is not restricted to VoIP phones only.

 

This behaviour does not happens on 2 x SG350X-24 units (on which only servers and infrastructure devices are connected).

 

Could you help me to understand why so many ports are continuously keeping disconnecting and reconnecting?

 

Thank you very much!

Bye

7 REPLIES 7
marce1000
VIP Advisor

 

 - Show port configuration for the Voip phones, you may want to disable any SPT-protocols (spanning-tree) , and or make sure they are access/host-mode ports , look at the interface counters for those ports too , look for anomalies if any.

 M.

Thanks marce1000.

I identified an example VoIP phone which is flapping every 8-10 seconds:

Screenshot 2021-06-10 at 15.31.46.png

 

This phone is connected on the port gi1/0/39 of the swich1 stack which is access and untagged + PVID on VLAN14:

 

Screenshot 2021-06-10 at 15.33.44.png

 

Screenshot 2021-06-10 at 15.34.20.png

Screenshot 2021-06-10 at 15.34.12.png

 

 What I realised is that this port is not listed as going down and up into the switch logs.

 

Spanning tree is configured like this:

Screenshot 2021-06-10 at 15.35.48.png

 

Screenshot 2021-06-10 at 15.36.01.pngScreenshot 2021-06-10 at 15.36.10.png

 

RSTP is configured like this:

Screenshot 2021-06-10 at 15.36.28.pngScreenshot 2021-06-10 at 15.36.39.png

 

The STP root port is on the LAG8 which is the Link Aggregation between stacks.

Thank you!

balaji.bandi
VIP Master

From the switch you having issue, post show run from command level.

 

is this port set as access port or trunk  ? (or smart port ?)

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

This is the port gi1/0/39 on which is attached a flapping VoIP phone.

interface GigabitEthernet1/0/39
 storm-control broadcast level 10
 storm-control multicast level 10
 port security max 10
 spanning-tree portfast
 spanning-tree bpduguard enable
 switchport mode trunk
 switchport access vlan 14
 switchport trunk native vlan 14
 switchport trunk allowed vlan 1,14
 macro description ip_phone_desktop
 !next command is internal.
 macro auto smartport dynamic_type ip_phone_desktop
!

Please note that this port is not flapping down and up into the switch logs, so I'm not really sure the two problems are related.

 

Thank you!

1/0/39 is working no flaping is this correct ? so post the config which flapping ?

 

where is your Router Gateway for this IP address which you have issue ping lost every 8 or 10

 

what is the Logs you see on the above switch ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Yes, now even the port 1/0/39 is flapping, so every ports are flapping in a random way.

The strange thing is that client PCs are working good, devices which are not working good are VoIP phones.

 

The ping I posted was made in the same network of the VoIP phone, so there are no problem with router or gateway.

 

These are the logs from the switch:

 

2147475141 	2021-Jun-11 12:17:16	Informational 	%AAA-I-CONNECT: New http connection for user admin, source 192.168.234.6 destination 192.168.33.230 ACCEPTED   
2147475142 	2021-Jun-11 12:17:15	Informational 	%AAA-I-CONNECT: New http connection for user admin, source 192.168.33.103 destination 192.168.33.230 ACCEPTED   
2147475143 	2021-Jun-11 12:09:53	Warning 	%LINK-W-Down:  gi2/0/44   
2147475144 	2021-Jun-11 12:04:46	Informational 	%LINK-I-Up:  gi2/0/48   
2147475145 	2021-Jun-11 12:04:46	Warning 	%STP-W-PORTSTATUS: gi2/0/48: STP status Forwarding   
2147475146 	2021-Jun-11 12:04:41	Warning 	%LINK-W-Down:  gi1/0/39   
2147475147 	2021-Jun-11 12:00:43	Informational 	%LINK-I-Up:  gi1/0/39   
2147475148 	2021-Jun-11 12:00:43	Warning 	%STP-W-PORTSTATUS: gi1/0/39: STP status Forwarding   
2147475149 	2021-Jun-11 12:00:37	Warning 	%LINK-W-Down:  gi2/0/48   
2147475150 	2021-Jun-11 11:53:22	Informational 	%AAA-I-DISCONNECT: http connection for user admin, source 192.168.33.103 destination 192.168.33.230 TERMINATED   
2147475151 	2021-Jun-11 11:43:20	Notice 	%COPY-N-TRAP: The copy operation was completed successfully   
2147475152 	2021-Jun-11 11:43:13	Informational 	%COPY-I-FILECPY: Files Copy - source URL running-config destination URL flash://system/configuration/startup-config   
2147475153 	2021-Jun-11 11:42:12	Informational 	%AAA-I-DISCONNECT: http connection for user admin, source 192.168.234.6 destination 192.168.33.230 TERMINATED   
2147475154 	2021-Jun-11 11:36:04	Informational 	%LINK-I-Up:  gi2/0/42   
2147475155 	2021-Jun-11 11:36:04	Warning 	%STP-W-PORTSTATUS: gi2/0/42: STP status Forwarding   
2147475156 	2021-Jun-11 11:36:00	Notice 	%COPY-N-TRAP: The copy operation was completed successfully   
2147475157 	2021-Jun-11 11:35:52	Informational 	%COPY-I-FILECPY: Files Copy - source URL running-config destination URL flash://system/configuration/startup-config   
2147475158 	2021-Jun-11 11:32:51	Warning 	%LINK-W-Down:  gi2/0/42   
2147475159 	2021-Jun-11 11:30:08	Notice 	%COPY-N-TRAP: The copy operation was completed successfully   
2147475160 	2021-Jun-11 11:30:00	Informational 	%COPY-I-FILECPY: Files Copy - source URL running-config destination URL flash://system/configuration/startup-config   
2147475161 	2021-Jun-11 11:29:44	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475162 	2021-Jun-11 11:28:41	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475163 	2021-Jun-11 11:27:36	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475164 	2021-Jun-11 11:27:08	Informational 	%AAA-I-CONNECT: New http connection for user admin, source 192.168.234.6 destination 192.168.33.230 ACCEPTED   
2147475165 	2021-Jun-11 11:26:31	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475166 	2021-Jun-11 11:25:26	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475167 	2021-Jun-11 11:25:18	Informational 	%LINK-I-Up:  gi1/0/31   
2147475168 	2021-Jun-11 11:25:18	Warning 	%STP-W-PORTSTATUS: gi1/0/31: STP status Forwarding   
2147475169 	2021-Jun-11 11:25:16	Warning 	%LINK-W-Down:  gi1/0/31   
2147475170 	2021-Jun-11 11:25:15	Informational 	%LINK-I-Up:  gi1/0/31   
2147475171 	2021-Jun-11 11:25:15	Warning 	%STP-W-PORTSTATUS: gi1/0/31: STP status Forwarding   
2147475172 	2021-Jun-11 11:24:14	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475173 	2021-Jun-11 11:23:14	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475174 	2021-Jun-11 11:22:11	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475175 	2021-Jun-11 11:21:07	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475176 	2021-Jun-11 11:20:18	Informational 	%LINK-I-Up:  gi2/0/42   
2147475177 	2021-Jun-11 11:20:18	Warning 	%STP-W-PORTSTATUS: gi2/0/42: STP status Forwarding   
2147475178 	2021-Jun-11 11:20:12	Warning 	%LINK-W-Down:  gi2/0/42   
2147475179 	2021-Jun-11 11:20:07	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475180 	2021-Jun-11 11:19:05	Warning 	%2SWPORT-W-LOCKPORTACTIVE: A packet with source MAC c0:74:ad:3e:92:08 tried to access through port gi2/0/42 which is locked    
2147475181 	2021-Jun-11 11:14:20	Informational 	%LINK-I-Up:  gi1/0/43   
2147475182 	2021-Jun-11 11:14:20	Warning 	%STP-W-PORTSTATUS: gi1/0/43: STP status Forwarding   
2147475183 	2021-Jun-11 11:14:17	Warning 	%LINK-W-Down:  gi1/0/43   
2147475184 	2021-Jun-11 11:13:54	Informational 	%LINK-I-Up:  gi2/0/42   
2147475185 	2021-Jun-11 11:13:54	Warning 	%STP-W-PORTSTATUS: gi2/0/42: STP status Forwarding   
2147475186 	2021-Jun-11 11:13:41	Warning 	%LINK-W-Down:  gi1/0/39   
2147475187 	2021-Jun-11 11:10:49	Informational 	%LINK-I-Up:  gi1/0/43   
2147475188 	2021-Jun-11 11:10:49	Warning 	%STP-W-PORTSTATUS: gi1/0/43: STP status Forwarding   
2147475189 	2021-Jun-11 11:10:46	Warning 	%LINK-W-Down:  gi1/0/43   
2147475190 	2021-Jun-11 11:10:35	Informational 	%LINK-I-Up:  gi1/0/43   

Thanks.

The port getting in the STP process, for testing can you make one of the port as below and observe.

 

 

interface GigabitEthernet1/0/XX
 storm-control broadcast level 10
 storm-control multicast level 10
 port security max 10
 spanning-tree portfast
 switchport access vlan 14
 macro description ip_phone_desktop
 !next command is internal.
 macro auto smartport dynamic_type ip_phone_desktop
!

 

still see some issue, one more test, removing macro and simple access port as below :

 

interface GigabitEthernet1/0/XX
 storm-control broadcast level 10
 storm-control multicast level 10
 port security max 10
 spanning-tree portfast
  switchport access vlan 14
 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help