cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1348
Views
0
Helpful
12
Replies
Highlighted
Beginner

Cisco Stack. Ports dropping

I would appreciate any help on this.

Our environment consits of 4 cisco SGE2010 switches (stacked). I have implemented STP BPDUGUARD and Portfast on all client ports (suspected a loop). And our uplink to the Server DMZ recieves almost all of it's BPDU packets back(is that normal?)

The issues lies where we have random ports dropping out - across all stacks for seconds at a time. We get errors/warning such as:-

                  Port dropping.JPG

Pinging between the DMZ network appears to be fine. Pinging from the client/switch network show packets being dropped quite frequently.

All devices are on VLAN1 (I've have researched this and this could be the cause of the issue)

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Hall of Fame Cisco Employee

Hello Jake,

Thank you for the configuration. It does not seem to have any ill parts so far. Regarding the 3Com - sadly, I do not know how to operate it. I guess you need to find out first if it supports STP at all, and then pull out all STP-related information out of it. Specifically, its ports towards the stack should be Root Forwarding, and it should recognize the STP Bridge ID of the stack as the Root Bridge ID.

Best regards,

Peter

View solution in original post

Highlighted
Hall of Fame Cisco Employee

Hi Jake,

At this moment, it is hard to say. The similar count of sent/received BPDUs on the port towards the 3Com switch is a cause for concern and requires further investigation, but the logging messages regarding portss do not directly hint on a problem with STP. It looks more as if the ports got disconnected and reconnected again. Seems to me to be more like a physical layer problem. Perhaps too long or faulty cabling? Or simply those devices disconnected and came back? Would it make a difference if you forced the ports to 10Mbps operation?

Best regards,

Peter

View solution in original post

Highlighted
Hall of Fame Cisco Employee

Hi Jake,

Try configuring the Cisco stack for RSTP operation as well and decrease its STP priority to 4096 so that it is lower than the priority of the 3Com. Then let's see if 3Com starts recognizing the stack as the root bridge.

Best regards,

Peter

View solution in original post

12 REPLIES 12
Highlighted
Beginner

Hi Jake,

I can't understand, why server port is recieving the BPDUs. That is not suppose to be recieve any BPDUs because this port is connected to the Server and should work like a access-port. That would be more secore if you will configure that port with portfast and bpduguard.

And also i can see ports are going into forwarding mode then flapping.

Please check any stability issue of the Network as some ports or any stack switch is not seems stable.

Regards,

Amit

****Please rate helpful posts.**********

Highlighted

Amit,

Thanks for your response.

In regards to the "server port" It's a trunk over to a 3com switch. And the trunk port on the Cisco stack is receiving alot of BPDU's. This would suggest a port on the 3com switch is looping around somewhere, but as i said previously - I have followed each cable and implemented BPDUGUARD and PORTFAST on all client dedicated ports.

P.S How can I confirm the stability issues of the network? Ports only appear to be going up and down on this Cisco Stack.

Highlighted
Hall of Fame Cisco Employee

Hello Jake,

Is it possible for you to sketch a topology diagram of your network? It would be very helpful to understand your network topology.

When you say that your trunk on the Cisco stack is receiving a lot of BPDUs, do you consider that an indication of a problem? The 3Com switch is probably running STP too and so it may send BPDUs to you. If this was the case, it would be just a normal operation of STP. By the way, which switch is the root bridge in STP?

Best regards,

Peter

Highlighted

Peter - See below a Topology of the network in Question.

Here is the Show Spanning-Tree detail counters from the Trunk port on the cisco Stack.

Highlighted

The Cisco Stack is the "Root Bridge"

Highlighted
Hall of Fame Cisco Employee

Hello Jake,

The number of sent and received BPDUs is considerably  high and similar - that is indeed a cause for concern. However, at this  point, I am not willing to assume that the switch is receiving its own  BPDUs back. I haven't worked with Cisco SOHO switches like yours but I  know that if a Catalyst switch receives back its own BPDU, the port is  declared looped or broken, and is automatically put into STP Blocking  (Discarding) state. I assume that your Cisco switch should behave in a  similar way.

I wonder - does the 3Com switch speak STP? If it does, can you confirm that it is capable of understanding the BPDUs coming from the Cisco stack? Does it recognize it as the STP root?

Is it possible to post the configuration of the Cisco switch connected to the 3Com?

Best regards,

Peter

Highlighted

Config of the Cisco Switch/Stack is below.

console# show run

interface range ethernet 1/g(2-24,26-43),2/g(2-12),3/g(2-47),4/g(2-47)

spanning-tree portfast

exit

interface range ethernet 1/g(2-24,26-43),2/g(2-47),3/g(2-47),4/g(2-47)

spanning-tree bpduguard

exit

interface ethernet 1/g1

description LINK-TO-SERVERS

exit

interface ethernet 1/g25

description LINK-TO-PIX/DMZ

exit

interface ethernet 1/g19

speed 10

exit

interface ethernet 1/g25

speed 100

exit

interface ethernet 1/g1

switchport mode trunk

exit

interface range ethernet 1/g(19,25)

no negotiation

exit

interface vlan 1

ip address 10.10.2.80 255.255.0.0

exit

ip default-gateway 10.10.10.1

management access-list SSH-G1

permit ip-source 10.10.2.1 mask 255.255.255.0 ethernet 1/g1

In regards to the 3com switch - how can we determine if it understands the BPDU's coming from the cisco stack?  Maybe go to the web interface and look to see what the switch has elected it's root bridge?

Highlighted
Hall of Fame Cisco Employee

Hello Jake,

Thank you for the configuration. It does not seem to have any ill parts so far. Regarding the 3Com - sadly, I do not know how to operate it. I guess you need to find out first if it supports STP at all, and then pull out all STP-related information out of it. Specifically, its ports towards the stack should be Root Forwarding, and it should recognize the STP Bridge ID of the stack as the Root Bridge ID.

Best regards,

Peter

View solution in original post

Highlighted

Peter,

Going on your experience - Would you say this is a STP related issue?

Highlighted

Peter,

I think it's as we thought. The 3COM's ports are also going up and down. And as show below its STP root bridge is different (MAC Address). The cisco Stack is also only using STP as opposed to the 3COM which is currently using RSTP. What would you recommend my next step be?

Highlighted
Hall of Fame Cisco Employee

Hi Jake,

At this moment, it is hard to say. The similar count of sent/received BPDUs on the port towards the 3Com switch is a cause for concern and requires further investigation, but the logging messages regarding portss do not directly hint on a problem with STP. It looks more as if the ports got disconnected and reconnected again. Seems to me to be more like a physical layer problem. Perhaps too long or faulty cabling? Or simply those devices disconnected and came back? Would it make a difference if you forced the ports to 10Mbps operation?

Best regards,

Peter

View solution in original post

Highlighted
Hall of Fame Cisco Employee

Hi Jake,

Try configuring the Cisco stack for RSTP operation as well and decrease its STP priority to 4096 so that it is lower than the priority of the 3Com. Then let's see if 3Com starts recognizing the stack as the root bridge.

Best regards,

Peter

View solution in original post

Content for Community-Ad