cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
433
Views
0
Helpful
5
Replies
Highlighted
Beginner
Beginner

Cisco VPC 9000 and Cisco 3850

Hello Team, 

 

I am trying to establish Port-Channel from 3850 to Cisco 9K having VPC configuration, but I am getting this error (Peer does not have corresponding vPC) on 9K :-

 

*****************************************************

nXOS11# show vpc brief
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 200
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 30s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled
Virtual-peerlink mode : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po200 up 1


vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
33 Po33 down* failed Peer does not have -

corresponding vPC


Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.

*********************************************

 

Regards

WAQ

5 REPLIES 5
Highlighted
Hall of Fame Expert

Hi,

Can you post the configs from the 3850 and the 9ks?

HTH

Highlighted

You can also check out the "show vpc consistency-parameters vpc <vpc-num>" which it mentions above.
Highlighted
VIP Mentor

Couple of observation :

 

your VPC only allowed VLAN 1

1 Po200 up 1

 

What VLAN allowed in PO 33

is the PO 33 configured both the nexus? and put them VPC?

 

can you post the Port-channel 33 config from both the nexus also 3850 switches to review?

 

 

 

BB
*** Rate All Helpful Responses ***
Highlighted

Hello All, 

 

after design new VPC design, I am getting the same problem:-

vpc.PNG

***********************************************************

NXOS1# show running-config interface e1/1-2
interface Ethernet1/1
switchport mode trunk
channel-group 156 mode active

interface Ethernet1/2
switchport mode trunk
channel-group 156 mode active

 

NXOS1# show running-config interface port-channel 156

interface port-channel156
switchport mode trunk
vpc 156


NXOS1# show vpc consistency-parameters vp 156

Legend:
Type 1 : vPC will be suspended in case of mismatch

Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
delayed-lacp 1 disabled -
mode 1 active -
Switchport Isolated 1 0 -
Interface type 1 port-channel -
LACP Mode 1 on -
Virtual-ethernet-bridge 1 Disabled -
Speed 1 1000 Mb/s -
Duplex 1 full -
MTU 1 1500 -
Port Mode 1 trunk -
Native Vlan 1 1 -
Admin port mode 1 trunk -
STP Port Guard 1 Default -
STP Port Type 1 Default -
STP MST Simulate PVST 1 Default -
lag-id 1 [(7f9b, -
0-23-4-ee-be-64, 809c,
0, 0), (8000,
50-1a-0-5-80-0, f, 0,
0)]
Allow-Multi-Tag 1 Disabled
1 -
Vlan xlt mapping 1 Disabled
1 -
vPC card type 1 N9K TOR Empty
Allowed VLANs - 1-4094
Local suspended VLANs - 1 -

NXOS2# show running-config interface ethernet 1/1-2

interface Ethernet1/1
switchport mode trunk
channel-group 256 mode active

interface Ethernet1/2
switchport mode trunk
channel-group 256 mode active


NXOS2# show run int port-channel 256 

interface port-channel256
switchport mode trunk
vpc 256

 

NXOS2# show vpc consistency-parameters vpc 256

Legend:
Type 1 : vPC will be suspended in case of mismatch

Name Type Local Value Peer Value
------------- ---- ---------------------- -----------------------
delayed-lacp 1 disabled -
mode 1 active -
Switchport Isolated 1 0 -
Interface type 1 port-channel -
LACP Mode 1 on -
Virtual-ethernet-bridge 1 Disabled -
Speed 1 1000 Mb/s -
Duplex 1 full -
MTU 1 1500 -
Port Mode 1 trunk -
Native Vlan 1 1 -
Admin port mode 1 trunk -
STP Port Guard 1 Default -
STP Port Type 1 Default -
STP MST Simulate PVST 1 Default -
lag-id 1 [(7f9b, -
0-23-4-ee-be-64, 8100,
0, 0), (8000,
50-1a-0-5-80-0, 19, 0,
0)]
Allow-Multi-Tag 1 Disabled
1 -
Vlan xlt mapping 1 Disabled
1 -
vPC card type 1 N9K TOR Empty
Allowed VLANs - 1-4094
Local suspended VLANs - - -
NXOS2#

 

SW5#show running-config interface gigabitEthernet 1/1 

!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 25 mode active
end

SW5#show running-config interface gigabitEthernet 1/2 

!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 15 mode active

SW5#show etherchannel summary

-
15 Po15(SU) LACP Gi1/2(P)
25 Po25(SD) LACP Gi1/1(s)

 

 

SW6#show run interface gigabitEthernet 1/1 

!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 16 mode active
end

SW6#show run interface gigabitEthernet 1/2 

!
interface GigabitEthernet1/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 26 mode active
end

SW6#show etherchannel summary

16 Po16(SN) LACP Gi1/1(w)
26 Po26(SD) LACP Gi1/2(s)

 

 

Highlighted

There is difference information  from the orginal post to new Post - the new post do not have PO30

 

This look like you are testing this on EVE-NG ( i do believe you have 3850 image available for simulation)

 

you have IOL or vIOS for testing - if this is EVE-NG

 

i need to look your show version from nexus device and switch side.

 

Quick fix is

 

1. change all from ACTIVE to ON

example :

channel-group 156 on

 

2. make sure you allowed only required VLAN Nexus vPC or the same will need to be match vPC down to switch.

 

BB
*** Rate All Helpful Responses ***
Content for Community-Ad