cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
865
Views
0
Helpful
9
Replies
Highlighted
Beginner

CISCO881-K9

I have bought Cisco ISR 881 C880DATA-UNIVERSALK9-M with  c880data-universalk9-mz.150-1.M7.bin ios.

command "show ver" tell me:

License Information for 'c880-data'

    License Level: advsecurity   Type: Permanent

    Next reboot license Level: advsecurity

So I have advsecurity

On cisco site there  was a thing  http://www.cisco.com/en/US/prod/collateral/routers/ps380/data_sheet_c78_459542_ps380_Products_Data_Sheet.html

section "Table 5. Cisco IOS Software Features on Cisco 880 Series: Advanced Security Feature Set (Default)"

that tell me I have  RIP protocol to use.

But when I type "router rip" command and sub router sommands like: network, passive-interface, redistribution.

There are no in runnning-config such things after all I've done. It have not been saved.

then the command "show licence":

#show license

Index 1 Feature: advipservices

        Period left: Not Activated

        Period Used: 0  minute  0  second

        License Type: EvalRightToUse

        License State: Not in Use, EULA not accepted

        License Count: Non-Counted

        License Priority: None

Index 2 Feature: advsecurity

        Period left: Life time

        License Type: Permanent

        License State: Active, In Use

        License Count: Non-Counted

        License Priority: Medium

I need even RIPv2 to have simple routing information to exchange.

And I don't know. Cisco 880 series is G2 or G1. Cisco ISR beggining from 890 series is G2.

About 880 I don't know. There no informanion about it or at least I have not found it yet.

On one 891 is the same problem. When I type "router eigrp 1" everything is great. But when "router rip"  - do no work.

Please help.

9 REPLIES 9
Highlighted
Advocate

Victor,

The default on these routers in NO IP ROUTING.

http://www.cisco.com/en/US/docs/routers/access/800/880/software/configuration/guide/880_basic_router_config.pdf

Default config page

Have you enabled ip routing before configuring rip etc.

!

ip routing

!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Highlighted

acampbell wrote:

Victor,

The default on these routers in NO IP ROUTING.

http://www.cisco.com/en/US/docs/routers/access/800/880/software/configuration/guide/880_basic_router_config.pdf

Default config page

Have you enabled ip routing before configuring rip etc.

!

ip routing

!

Are you sure? I have installed very many of these, and all came with "ip routing" enabled by default from factory.

Highlighted
Hall of Fame Master

I have some of these with no addtional license, and can enable and use RIP without any problem.

Highlighted

What version of IOS do you have on this router?

Highlighted
Beginner

Victor,

When you do a "router ?" in config mode, what are your options?

Because at a minimum RIP most certainly should be available to you, even with that level of license.

Highlighted

I have comand "router rip". When I type "router rip" I go to rip configuration level where I type network commands, no auto-summary and so on as usual but I can't see these commands  in run-config, and it doesn't work.

I've  also read that this router has rip with any license and it has but it doesn't work.

May be I'll upgrade to new ios.

By the way. When I upgrade cisco router ISR G2 to new IOS, then do I need to recover some lisence or just upgrade and it's done?

I have never upgraded ISR G2 until now )

Highlighted

Victor,

When you do an IOS upgrade, you will still have the level of license access on the new IOS that you have with your current IOS.

As for why those RIP commands are not available to you is a mystery as they should be "there". Maybe it is time to open a TAC and see what Cisco has to say about it.

Highlighted

The same problem with Cisco 2911-K9 Security licence.

There are all routing protocols: bgp,eigrp,ospf,rip and some extra.

All routing work but rip not )!

I have upgraded IOS from 15.1 to 15.3 and there is no result.

But I try to configure RIP with Cisco Configuration Professional and it's working on all devices - CISCO 881, CIsco 891, Cisco 2911.

It's funny )

I suppose that there some CLI bug with "router rip" command on the routers.

Highlighted

Please open a case with us at CISCO so we can further investigate this,

Thanks

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Content for Community-Ad