cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


236
Views
5
Helpful
12
Replies
Highlighted
Beginner

Client loses randomly Connectivity

Hi @Aliki 

 

since some week´s we have a strange error and no one can told me a sollution. So i will ask here ;-)

I have Clients, Win 7 and Win 10 which losses randomly Network Connectivty. The LAN- Icon at the Client show the yellow exclamation mark. No communication can be done. Switch 2960x show no log the port is all the time up. Wireshark show no error, broadcaststrom an so on ... 

 

It seems that the client will have an IP- Adresse DNS- Server and so on but can not resolve the names ...

 

Did anyone hear about that problem. 

 

Stack 

 

Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 52 WS-C2960X-48LPS-L 15.2(2)E7 C2960X-UNIVERSALK9-M
2 52 WS-C2960X-48LPS-L 15.2(2)E7 C2960X-UNIVERSALK9-M
3 52 WS-C2960X-48LPS-L 15.2(2)E7 C2960X-UNIVERSALK9-M

 

Port Config 

 

interface GigabitEthernet3/0/2
network-policy 1
switchport access vlan xxx
switchport mode access
switchport port-security maximum 3
switchport port-security aging time 3
switchport port-security
srr-queue bandwidth share 1 80 10 15
srr-queue bandwidth shape 2 0 0 0
priority-queue out
no snmp trap link-status
mls qos trust dscp
storm-control broadcast level pps 500 300
storm-control multicast level pps 500 300
storm-control action shutdown
spanning-tree portfast
service-policy input PM-AccessPort_policed-dscp-transmit
end

 

Regards Mario 

12 REPLIES
VIP Expert

Re: Client loses randomly Connectivity

Hi,

For testing purpose, have you tried a port without security, QOS and storm control configs and watch for the same behavior?

HTH 

Beginner

Re: Client loses randomly Connectivity

Hi Reza

 

no. But i will do that now ;-)

 

interface GigabitEthernet3/0/2
 network-policy 1
 switchport access vlan xxx
 switchport mode access
 priority-queue out
 no snmp trap link-status
 spanning-tree portfast
end

VIP Mentor

Re: Client loses randomly Connectivity

Hello,

 

on a side note, this could be a NIC problem as well, try to un- and reinstall the drivers for the NIC on the 'problem' PCs. Also, do you have any antivirus software running on the clients ?

Does the event viewer in Windows show anything ?

Beginner

Re: Client loses randomly Connectivity

Hi 

 

the eventlog show nothing … i also made a test and disabled Stormcontrol at this port. 

This also dosn´t help ...

 

At the Moment i test QoS Settings … but i am not sure this will solve the Problem. 

Beginner

Re: Client loses randomly Connectivity

Mario,

 

Did you ever have a solution to this problem?  I am having the same issue after upgrading to 2960X switches....

Beginner

Re: Client loses randomly Connectivity

Hi Hank

 

i don´t have solved the problem. But i have a workaround. We removed the settings

 

switchport port-security maximum 3
switchport port-security aging time 3
switchport port-security

 

after i removed this setting all works fine. I think this is a IOS- BUG. Forthat issue i will also open a TAC

Beginner

Re: Client loses randomly Connectivity

Hi @MarioLieb,

 

your switch had found 3 differents MAC Address and that's why the port maybe got blocked, you can validate that using the next command:

show interfaces status | i err

and

show port-security interface [INTERFACE]

 

If your problem got a solution, please mark as solved. If you think that the commands I gave you are helpful, please mark as Helpful,

 

Regards,

 

 

 

Beginner

Re: Client loses randomly Connectivity

Hi Pedro

 

nice try that is not my problem the Port is NOT err- Dis and the port is always UP. The problem is that the Client shows limited Connectivity. The LAN- Icon shows a yellow exclamation mark. Same config on a 2960S works on a 2960X there are this Problems. Seems to by a similar bug like CSCve53124 or CSCue23882 but not 100 % the same.

 

Regard Mario

Beginner

Re: Client loses randomly Connectivity

MarioLieb,

Did you try upgrading IOS versions as suggested in CSCve53124 ??

We are trying this now...


Beginner

Re: Client loses randomly Connectivity

Hi Hank

 

no i don´t try this. we use the iOS

 

Switch Ports Model                     SW Version            SW Image
------ ----- -----                     ----------            ----------
     1 52    WS-C2960X-48LPS-L         15.2(2)E7             C2960X-UNIVERSALK9-M
*    2 52    WS-C2960X-48LPS-L         15.2(2)E7             C2960X-UNIVERSALK9-M
     3 52    WS-C2960X-48LPS-L         15.2(2)E7             C2960X-UNIVERSALK9-M

 

Please let me know if your try is working ;-)

 

THX

 

Beginner

Re: Client loses randomly Connectivity

Hi Hank

 

i tested the IOS 15.2(2)E9 with Port- Security … same error. I will now open a TAC. .Hope this will be help.

 

Regards Mario

Beginner

Re: Client loses randomly Connectivity

Please download and install IOS 15.2(6)E2 or higher... so far we have had
good results ( more than 1 week no issues)...
CreatePlease to create content
Content for Community-Ad
Blog-Cisco Community Designated VIP Class of 2019