cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9576
Views
2
Helpful
11
Replies
Dragomir
Beginner

command rejected Port-channel

I am getting this error when configuring a lacp port channel

 

channel-group 1 mode active
Port-channel1 and FastEthernet2/15 have different trust states

Command rejected (Port-channel1, Fa2/15): QoS attribute(s)(trust/cos/vlan-based) of Port-channel1, Fa2/15 is(are) not compatible with the port-channel

11 REPLIES 11
John Blakley
Advisor

You won't be able to group your PO1 interface with a fa2/15 interface. You'll need to have two L2 interfaces that logically bond to create the etherchannel. If you already have a port-channel that you're wanting to add to, you should be able to modify port f2/15 with the channel-group 1 mode active command and it will add to the existing channel...

HTH,

John

HTH, John *** Please rate all useful posts ***

I was able to add the 2 ports in the port channel but po1 is still showing (SD)

 

interface POrt-channel1

switchport

switchport access vlan 230

switchport mode access

no ip address

!

interface FastEthernet2/15

switchport

switchport access vlan 230

switchport mode access

no ip address

spanning-tree portfast

channel-group 1 mode active

!

interface FastEthernet2/17

switchport

switchport access vlan 230

switchport mode access

no ip address

spanning-tree portfast

channel-group 1 mode active

!

 

 

 

show etherchannel summary

 

Po1(SD)

Protocol LACP

PORts - fa 2/15(u), Fa 2/17 (u)

 

any idea?

What's connected to the other side?

HTH, John *** Please rate all useful posts ***

the other end is an esxi server lacp on a distributed vswitch

I can see that both of your ports are up. Have you (or someone you know) checked the config of the ports on the server? I've run into issues in the past where lacp simply wouldn't work and I had to configure the ports on my switch to simply on. "channel-group 1 mode on"

HTH, John *** Please rate all useful posts ***

i tried channel mode 1 on instead of active ans same issue

 

the server side is configured correctly according to vmware

The only other thing I could recommend is to remove all of the config and start over. That sometimes helps...

HTH, John *** Please rate all useful posts ***

i removed the dvswitch completely and recreated and same problem

 

po1 shows (SD) 

 

both links are showing up.

 

I was able to configure the portchannel on another switch but both are gigabit and the port channel is up fine on that one. 

 

is there something else needed for Fastethernet port channels?

dasiimwe
Beginner

all the ports in the port channel should have the same config.

Check this bug

hgoncer124
Beginner

I also have the same problem  , cannot config lacp port channel also i can not assign ip to the port channel