cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1337
Views
5
Helpful
8
Replies

Computer connects, phone drops.

swicklund
Level 1
Level 1

We have a 3750 stack on 12.2 (25).  They have been in place for years with no recent config changes.  We have two ports that the phone drops connection on after a couple of minutes.  The cable test fine.  If we jack in to the computer it is fine.  If I move the phone into the switch room on a patch cable (same port) it is fine. I am at a loss as to why the computer would connect, the phone stays powered up, but drops the network after a few minutes.  A snipped from the log reads:

 

163587: Jan  8 17:06:49: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3/0/21, changed state to down

163588: Jan  8 17:06:50: %LINK-3-UPDOWN: Interface FastEthernet3/0/21, changed state to down

163589: Jan  8 17:06:50: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Fa3/0/21, port set to untrusted.

8 Replies 8

Dennis Mink
VIP Alumni
VIP Alumni

hello,

 

you say that when you plug it straight into the switch its good, if you plug it in the wall socket at the desk, it display a problem, to me this sounds like you have a problem between the patch panel in your 'switch room' and the desk's wall socket, cable test it, using a FLUKE tester for instance

Please remember to rate useful posts, by clicking on the stars below.

luis_cordova
VIP Alumni
VIP Alumni

Hi @swicklund,

 

Could you show us the configurations of your switch?

 

Regards

First of all you need to determine if the switch port is good / semi bad or if its a cabling issue.

You need to connect another device (Phone in this case)  to the same cable / port along with the same PC setup to determine if a similar occurrence will be replayed.

 

If the switch port goes down , WALLA its the cable or device port. you will then have enough evidence to determine how to proceed with your diagnosis.

 

1. You can go directly to the device and connect your device with a short patch cable and see what happens.

2. If nothing happens you could some how have some freaky port security issue going on there in the background.

Always remember do not overthink your troubleshooting process, always start at the layer 1 , phone , cable switch then configs.

If you get to the config stage check the port security configs, maybe your port is going in an error disable mode then recovering thereafter.

 

 

Cheers.

 

 

P.Williams

Leo Laohoo
Hall of Fame
Hall of Fame
Post the complete output to the command "sh interface Fa 3/0/21 controll".
(The switch is a non-GigabitEthernet model of the 3750 therefore TDR isn't supported.)

AD3E#sh interface Fa 3/0/21 controll
FastEthernet3/0/21 is down, line protocol is down (notconnect)
Hardware is Fast Ethernet, address is 0016.461f.2617 (bia 0016.461f.2617)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, Auto-speed, media type is 10/100BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:06:24, output 00:05:50, output hang never
Last clearing of "show interface" counters 23:26:19
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
364838 packets input, 56728137 bytes, 0 no buffer
Received 2251 broadcasts (0 multicast)
1 runts, 0 giants, 0 throttles
3 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 1906 multicast, 0 pause input
0 input packets with dribble condition detected
961323 packets output, 708487449 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

Transmit FastEthernet3/0/21 Receive
2119930277 Bytes 2627341898 Bytes
180296864 Unicast frames 137577572 Unicast frames
59597411 Multicast frames 2855931 Multicast frames
19746553 Broadcast frames 357543 Broadcast frames
0 Too old frames 2240925896 Unicast bytes
0 Deferred frames 311943186 Multicast bytes
0 MTU exceeded frames 44898422 Broadcast bytes
0 1 collision frames 0 Alignment errors
0 2 collision frames 0 FCS errors
0 3 collision frames 0 Oversize frames
0 4 collision frames 29901 Undersize frames
0 5 collision frames 0 Collision fragments
0 6 collision frames
0 7 collision frames 55424972 Minimum size frames
0 8 collision frames 20295206 65 to 127 byte frames
0 9 collision frames 25445430 128 to 255 byte frames
0 10 collision frames 8812747 256 to 511 byte frames
0 11 collision frames 10706461 512 to 1023 byte frames
0 12 collision frames 20106233 1024 to 1518 byte frames
0 13 collision frames 0 Overrun frames
0 14 collision frames 0 Pause frames
0 15 collision frames
0 Excessive collisions 3 Symbol error frames
0 Late collisions 0 Invalid frames, too large
0 VLAN discard frames 0 Valid frames, too large
0 Excess defer frames 0 Invalid frames, too small
32002914 64 byte frames 29901 Valid frames, too small
68817800 127 byte frames
46059335 255 byte frames 0 Too old frames
15314351 511 byte frames 0 Valid oversize frames
11844226 1023 byte frames 0 System FCS error frames
85602202 1518 byte frames 0 RxPortFifoFull drop frame
0 Too large frames
0 Good (1 coll) frames
0 Good (>1 coll) frames

swicklund
Level 1
Level 1

Leo thanks for the command.  I tried TDR which obviously did not work.  I will hook the phone back up (its disconnected from that port now so the employee can use her computer), run the command and post the results.

 

Thanks for the other suggestions.  I might not have been clear enough in my post.  The cable test was a Fluke test and the line passed.  I did plug the phone in to the switch port directly with a tested patch cable and it works fine.  The issue only occurs plugged into the wall jack which works with any other device.  The issue happens with any phone and just on those two ports.  All other ports on the stack are fine.

 

Were you able to find a solution to this? I keep having these issues, I have worked with TAC on at least 5 cases and upgraded my switches 5 times and now once again we are hitting this type of issue. 

Hi,

It's been a wiring issue or a bad phone each time. Even when the wiring shows good on the tester, if we switch it out, the phone usually works.
Review Cisco Networking for a $25 gift card